~larsu/ubuntu/precise/gnome-control-center/remove-slider-hacks

« back to all changes in this revision

Viewing changes to debian/patches/60_ubuntu_nav_bar.patch

  • Committer: Sebastien Bacher
  • Date: 2012-02-23 19:57:44 UTC
  • Revision ID: seb128@ubuntu.com-20120223195744-ghurnkn13kflk3je
* debian/patches/96_sound_nua_panel.patch:
  - updated to r261

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
Index: gnome-control-center-3.3.90/shell/Makefile.am
6
6
===================================================================
7
7
--- gnome-control-center-3.3.90.orig/shell/Makefile.am  2012-02-20 11:22:59.000000000 +0100
8
 
+++ gnome-control-center-3.3.90/shell/Makefile.am       2012-02-21 13:34:48.671097886 +0100
 
8
+++ gnome-control-center-3.3.90/shell/Makefile.am       2012-02-23 19:59:15.815160152 +0100
9
9
@@ -27,6 +27,8 @@
10
10
        cc-shell-item-view.h                    \
11
11
        cc-shell-model.c                        \
18
18
Index: gnome-control-center-3.3.90/shell/cc-shell-marshal.list
19
19
===================================================================
20
20
--- gnome-control-center-3.3.90.orig/shell/cc-shell-marshal.list        2011-09-17 22:00:34.000000000 +0200
21
 
+++ gnome-control-center-3.3.90/shell/cc-shell-marshal.list     2012-02-21 13:34:43.511097690 +0100
 
21
+++ gnome-control-center-3.3.90/shell/cc-shell-marshal.list     2012-02-23 19:59:09.583159850 +0100
22
22
@@ -1 +1,2 @@
23
23
 VOID:STRING,STRING,STRING
24
24
+VOID:VOID
25
25
Index: gnome-control-center-3.3.90/shell/cc-shell-nav-bar.c
26
26
===================================================================
27
27
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
28
 
+++ gnome-control-center-3.3.90/shell/cc-shell-nav-bar.c        2012-02-21 13:34:43.511097690 +0100
 
28
+++ gnome-control-center-3.3.90/shell/cc-shell-nav-bar.c        2012-02-23 19:59:09.587159851 +0100
29
29
@@ -0,0 +1,150 @@
30
30
+/*
31
31
+ * Copyright 2012 Canonical
180
180
Index: gnome-control-center-3.3.90/shell/cc-shell-nav-bar.h
181
181
===================================================================
182
182
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
183
 
+++ gnome-control-center-3.3.90/shell/cc-shell-nav-bar.h        2012-02-21 13:34:43.511097690 +0100
 
183
+++ gnome-control-center-3.3.90/shell/cc-shell-nav-bar.h        2012-02-23 19:59:09.587159851 +0100
184
184
@@ -0,0 +1,76 @@
185
185
+/*
186
186
+ * Copyright 2012 Canonical
260
260
+#endif /* _CC_SHELL_NAV_BAR_H */
261
261
Index: gnome-control-center-3.3.90/shell/gnome-control-center.c
262
262
===================================================================
263
 
--- gnome-control-center-3.3.90.orig/shell/gnome-control-center.c       2012-02-21 13:34:43.467097689 +0100
264
 
+++ gnome-control-center-3.3.90/shell/gnome-control-center.c    2012-02-21 13:34:54.451098106 +0100
 
263
--- gnome-control-center-3.3.90.orig/shell/gnome-control-center.c       2012-02-23 19:59:09.543159848 +0100
 
264
+++ gnome-control-center-3.3.90/shell/gnome-control-center.c    2012-02-23 19:59:17.471160232 +0100
265
265
@@ -36,6 +36,7 @@
266
266
 #include "shell-search-renderer.h"
267
267
 #include "cc-shell-category-view.h"
278
278
 
279
279
   GMenuTree  *menu_tree;
280
280
   GtkListStore *store;
281
 
@@ -176,6 +177,7 @@
 
281
@@ -175,6 +177,7 @@
282
282
           /* switch to the new panel */
283
283
           gtk_widget_show (box);
284
284
           gtk_notebook_set_current_page (GTK_NOTEBOOK (priv->notebook), i);
286
286
 
287
287
           /* set the title of the window */
288
288
           icon_name = get_icon_name_from_g_icon (gicon);
289
 
@@ -246,6 +248,8 @@
 
289
@@ -246,6 +249,8 @@
290
290
 
291
291
   /* clear any custom widgets */
292
292
   _shell_remove_all_custom_widgets (priv);
295
295
 }
296
296
 
297
297
 void
298
 
@@ -837,11 +843,8 @@
 
298
@@ -837,11 +842,8 @@
299
299
                          gint                       page_num,
300
300
                          GnomeControlCenterPrivate *priv)
301
301
 {
307
307
       gtk_widget_show (W (priv->builder, "search-entry"));
308
308
       gtk_widget_hide (W (priv->builder, "lock-button"));
309
309
       gtk_scrolled_window_set_min_content_height (GTK_SCROLLED_WINDOW (priv->scrolled_window),
310
 
@@ -851,7 +854,6 @@
 
310
@@ -851,7 +853,6 @@
311
311
     }
312
312
   else
313
313
     {
315
315
       gtk_widget_hide (W (priv->builder, "search-entry"));
316
316
       gtk_scrolled_window_set_min_content_height (GTK_SCROLLED_WINDOW (priv->scrolled_window), MIN_ICON_VIEW_HEIGHT);
317
317
     }
318
 
@@ -1140,6 +1142,7 @@
 
318
@@ -1140,6 +1141,7 @@
319
319
 {
320
320
   GError *err = NULL;
321
321
   GnomeControlCenterPrivate *priv;
323
323
 
324
324
   priv = self->priv = CONTROL_CENTER_PRIVATE (self);
325
325
 
326
 
@@ -1171,8 +1174,14 @@
 
326
@@ -1171,8 +1173,14 @@
327
327
   g_signal_connect (priv->notebook, "switch-page",
328
328
                     G_CALLBACK (notebook_switch_page_cb), priv);
329
329
 
343
343
Index: gnome-control-center-3.3.90/shell/shell.ui
344
344
===================================================================
345
345
--- gnome-control-center-3.3.90.orig/shell/shell.ui     2012-02-20 11:22:59.000000000 +0100
346
 
+++ gnome-control-center-3.3.90/shell/shell.ui  2012-02-21 13:34:43.515097690 +0100
 
346
+++ gnome-control-center-3.3.90/shell/shell.ui  2012-02-23 20:00:06.807162620 +0100
347
347
@@ -34,25 +34,6 @@
348
348
                       <object class="GtkHBox" id="hbox1">
349
349
                         <property name="visible">True</property>
379
379
                           </packing>
380
380
                         </child>
381
381
                       </object>
 
382
@@ -169,13 +150,6 @@
 
383
       <column type="gchararray"/>
 
384
     </columns>
 
385
   </object>
 
386
-  <object class="GtkSizeGroup" id="sizegroup">
 
387
-    <property name="mode">vertical</property>
 
388
-    <widgets>
 
389
-      <widget name="home-button"/>
 
390
-      <widget name="entry-alignment"/>
 
391
-    </widgets>
 
392
-  </object>
 
393
   <object class="GtkImage" id="image1">
 
394
     <property name="visible">True</property>
 
395
     <property name="can_focus">False</property>