~linaro-maintainers/xbmc/xbmc-linaro-pkg-precise

« back to all changes in this revision

Viewing changes to debian/patches/0001-add-gstreamer-to-configure-script.patch

  • Committer: Ricardo Salveti de Araujo
  • Date: 2012-07-27 07:07:02 UTC
  • Revision ID: ricardo.salveti@linaro.org-20120727070702-6y67o6te21awg1a2
Removing patches as they are now applied at the flattened tree

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 98aa20bd177014671e8c02f583801cb19617de17 Mon Sep 17 00:00:00 2001
2
 
From: Rob Clark <rob@ti.com>
3
 
Date: Sat, 9 Jun 2012 10:34:20 -0500
4
 
Subject: [PATCH 01/12] add gstreamer to configure script
5
 
 
6
 
---
7
 
 configure.in |   54 ++++++++++++++++++++++++++++++++++++++++++++++++++++++
8
 
 1 file changed, 54 insertions(+)
9
 
 
10
 
diff --git a/configure.in b/configure.in
11
 
index bca9239..3b1a1f3 100755
12
 
--- a/configure.in
13
 
+++ b/configure.in
14
 
@@ -127,6 +127,8 @@ libusb_disabled_udev_found="== libusb disabled. =="
15
 
 libcec_enabled="== libcec enabled. =="
16
 
 libcec_disabled="== libcec disabled. CEC adapter support will not be available. =="
17
 
 libcec_disabled_missing_libs="== libcec disabled because both libudev and libusb are not available. CEC adapter support will not be available. =="
18
 
+gstreamer_not_found="== GStreamer libraries not found. GStreamer support disabled. =="
19
 
+gstreamer_disabled="== GStreamer support manually disabled. =="
20
 
 
21
 
 # External library message strings
22
 
 external_libraries_enabled="== Use of all supported external libraries enabled. =="
23
 
@@ -223,6 +225,12 @@ AC_ARG_ENABLE([openmax],
24
 
   [use_openmax=$enableval],
25
 
   [use_openmax=auto])
26
 
 
27
 
+AC_ARG_ENABLE([gstreamer],
28
 
+  [AS_HELP_STRING([--enable-gstreamer],
29
 
+  [enable GStreamer support (default is auto)])],
30
 
+  [use_gstreamer=$enableval],
31
 
+  [use_gstreamer=auto])
32
 
+
33
 
 AC_ARG_ENABLE([tegra],
34
 
   [AS_HELP_STRING([--enable-tegra],
35
 
   [enable Tegra2 arm (default is no)])],
36
 
@@ -1446,6 +1454,45 @@ AC_CHECK_HEADERS([yajl/yajl_version.h], [], [
37
 
 AC_DEFINE(YAJL_MAJOR, 1, [yajl version 1])
38
 
 ], [])
39
 
 
40
 
+# GSTREAMER
41
 
+if test "x$use_gstreamer" != "xno"; then
42
 
+  if test "$host_vendor" = "apple" ; then
43
 
+    if test "x$use_gstreamer" = "xyes"; then
44
 
+      AC_MSG_ERROR([GStreamer not supported on this platform])
45
 
+    else
46
 
+      use_gstreamer="no"
47
 
+      AC_MSG_NOTICE($gstreamer_disabled)
48
 
+    fi
49
 
+    USE_GSTREAMER=0
50
 
+  else
51
 
+    AC_SUBST(gstreamer_req, 0.10.0)
52
 
+    AC_SUBST(gstreamer_plugins_base_req, 0.10.0)
53
 
+    PKG_CHECK_MODULES(GSTREAMER, gstreamer-0.10 >= $gstreamer_req, HAVE_GSTREAMER=1, HAVE_GSTREAMER=0)
54
 
+    PKG_CHECK_MODULES(GSTREAMER_BASE, gstreamer-base-0.10 >= $gstreamer_req, HAVE_GSTREAMER_BASE=1, HAVE_GSTREAMER_BASE=0)
55
 
+    PKG_CHECK_MODULES(GSTREAMER_PLUGINS_BASE, gstreamer-plugins-base-0.10 >= $gstreamer_plugins_base_req, HAVE_GSTREAMER_PLUGINS_BASE=1, HAVE_GSTREAMER_PLUGINS_BASE=0)
56
 
+    HAVE_GSTREAMER_APP=1
57
 
+    AC_CHECK_LIB([gstapp-0.10], main, , HAVE_GSTREAMER_APP=0)
58
 
+
59
 
+    if test $HAVE_GSTREAMER -eq 1 -a $HAVE_GSTREAMER_BASE -eq 1 -a $HAVE_GSTREAMER_PLUGINS_BASE -eq 1 -a $HAVE_GSTREAMER_APP -eq 1; then
60
 
+      INCLUDES="$INCLUDES $GSTREAMER_CFLAGS $GSTREAMER_BASE_CFLAGS $GSTREAMER_PLUGINS_BASE_CFLAGS"
61
 
+      LIBS="$LIBS $GSTREAMER_LIBS $GSTREAMER_BASE_LIBS $GSTREAMER_PLUGINS_BASE_LIBS"
62
 
+      USE_GSTREAMER=1
63
 
+      AC_DEFINE([HAVE_LIBGSTREAMER], [1], [Define to 1 if you have the 'GStreamer' library.])
64
 
+    else
65
 
+      if test "x$use_gstreamer" = "xyes"; then
66
 
+        AC_MSG_ERROR([$gstreamer_not_found])
67
 
+      else
68
 
+        use_gstreamer="no"
69
 
+        USE_GSTREAMER=0
70
 
+        AC_MSG_RESULT($gstreamer_not_found)
71
 
+      fi
72
 
+    fi
73
 
+  fi
74
 
+else
75
 
+  USE_GSTREAMER=0
76
 
+  AC_MSG_NOTICE($gstreamer_disabled)
77
 
+fi
78
 
+
79
 
 # platform specific bin utilities
80
 
 if test "$host_vendor" != "apple" ; then
81
 
   AC_CHECK_PROG(HAVE_GAWK,gawk,"yes","no",)
82
 
@@ -1596,6 +1643,12 @@ else
83
 
   final_message="$final_message\n  OpenMax:\tNo"
84
 
 fi
85
 
 
86
 
+if test "$use_gstreamer" != "no"; then
87
 
+  final_message="$final_message\n  GStreamer:\tYes"
88
 
+else
89
 
+  final_message="$final_message\n  GStreamer:\tNo"
90
 
+fi
91
 
+
92
 
 if test "$use_joystick" = "yes"; then
93
 
   final_message="$final_message\n  Joystick:\tYes"
94
 
   SDL_DEFINES="$SDL_DEFINES -DHAS_SDL_JOYSTICK"
95
 
@@ -1949,6 +2002,7 @@ AC_SUBST(USE_LIBAFPCLIENT)
96
 
 AC_SUBST(USE_AIRPLAY)
97
 
 AC_SUBST(USE_VDA)
98
 
 AC_SUBST(USE_OPENMAX)
99
 
+AC_SUBST(USE_GSTREAMER)
100
 
 AC_SUBST(USE_PULSE)
101
 
 AC_SUBST(USE_XRANDR)
102
 
 AC_SUBST(USE_ALSA)
103
 
1.7.9.5
104