~logan/ubuntu/trusty/suitesparse/4.2.1-3ubuntu1

« back to all changes in this revision

Viewing changes to debian/patches/05-COLAMD_Lib_Makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Rafael Laboissiere, Rafael Laboissiere, Ondrej Certik
  • Date: 2008-02-21 14:46:50 UTC
  • mfrom: (1.1.2 upstream) (5.1.1 hardy)
  • Revision ID: james.westby@ubuntu.com-20080221144650-tgeppgj0t7s759i8
Tags: 3.1.0-3
[ Rafael Laboissiere ]
* Upload to unstable

[ Ondrej Certik ]
* XS-DM-Upload-Allowed: yes field added
* Ondrej Certik added to uploaders

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 05-COLAMD_Lib_Makefile.dpatch by Daniel Rus Morales <danirus@tol-project.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Build shared version of COLAMD library.
 
6
 
 
7
@DPATCH@
 
8
diff -u upstrm/CCOLAMD/Lib/Makefile debsrc/COLAMD/Lib/Makefile
 
9
--- upstrm/COLAMD/Lib/Makefile  2007-05-05 15:41:47.000000000 +0200
 
10
+++ debsrc/COLAMD/Lib/Makefile  2007-12-15 19:05:03.000000000 +0100
 
11
@@ -2,7 +2,7 @@
 
12
 # COLAMD Makefile
 
13
 #-------------------------------------------------------------------------------
 
14
 
 
15
-default: libcolamd.a
 
16
+default: libcolamd.a libcolamd.so.3.1.0
 
17
 
 
18
 include ../../UFconfig/UFconfig.mk
 
19
 
 
20
@@ -19,12 +19,22 @@
 
21
        $(CC) $(CFLAGS) $(I) -c ../Source/colamd.c -DDLONG -o colamd_l.o
 
22
        $(AR) libcolamd.a colamd.o colamd_l.o colamd_global.o
 
23
 
 
24
+libcolamd.so.3.1.0:  $(SRC) $(INC)
 
25
+       $(CC) -fPIC $(CFLAGS) $(I) -c ../Source/colamd_global.c -o colamd_global.oo
 
26
+       $(CC) -fPIC $(CFLAGS) $(I) -c ../Source/colamd.c -o colamd.oo
 
27
+       $(CC) -fPIC $(CFLAGS) $(I) -c ../Source/colamd.c -DDLONG -o colamd_l.oo
 
28
+       $(CC) -shared *.oo -lm -Wl,-soname -Wl,$@ -o $@
 
29
+       ln -s $@ libcolamd.so
 
30
+
 
31
 ccode: libcolamd.a
 
32
 
 
33
 library: libcolamd.a
 
34
 
 
35
 clean:
 
36
        - $(RM) $(CLEAN)
 
37
+       -$(RM) *.oo
 
38
+       -$(RM) *.a
 
39
+       -$(RM) *.so*
 
40
 
 
41
 purge: distclean
 
42