~manishsinha/ubuntu/saucy/nautilus/move-to-zeitgeist2

« back to all changes in this revision

Viewing changes to debian/patches/git_launcher_no_frame.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher, Sebastien Bacher, Iain Lane, Jeremy Bicha, Robert Ancell, Rico Tzschichholz, Tim Lunn, Marco Trevisan (Treviño)
  • Date: 2013-06-21 17:10:06 UTC
  • mfrom: (1.17.42)
  • Revision ID: package-import@ubuntu.com-20130621171006-0vajxyu6ebhp1p9p
Tags: 1:3.8.2-0ubuntu1
[ Sebastien Bacher ]
* Bring the 3.8 update work from the gnome3 ppa to the distribution vcs
* debian/patches/16_unity_new_documents.patch: 
  - updated to work on 3.8 (by adding a revert of the commit that broke it)
* debian/patches/ubuntu_revert_no_wallpaper.patch:
  - revert upstream changes to use a rgba desktop view, until the other
    components are ready for that change, see lp #1159430 for details
* debian/patches/ubuntu_sync_background_to_accountsservice.patch:
  - restore that dropped patch since we keep display the wallpaper there

[ Iain Lane ]
* debian/patches/disconnect-extra-location-widgets.patch:
  - updated for the new nautilus codebase

[ Jeremy Bicha ]
* New upstream release (LP: #1130746)
  - Share the show-hidden-files setting with the GTK file chooser
    (LP: #1039014)
  - Limit folder size and content count to a single filesystem (LP: #585472)
* debian/nautilus.install:
  - Shell search provider doesn't need a separate library any more
* Drop git patches
* Refreshed patches

[ Robert Ancell ]
* debian/control:
  - Bump build-depends on libglib2.0-dev

[ Rico Tzschichholz ]
* New upstream release
* debian/control:
  - Bump build-depends on libgtk-3-dev (>= 3.7.7)
* debian/patches:
  - 09_no-initial-fade.patch:
  - 10_sync_background_to_accountsservice.patch:
    + Dropped, Nautilus doesn't draw the background itself any more
* Refreshed patches

[ Tim Lunn ]
* Add build-dep on gsettings-desktop-schemas

[ Marco Trevisan (Treviño) ]
* debian/patches:
  - 19_unity_open_location_xid.patch: updated to apply properly

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 6cde4c5a6d639c85df09b8992a307f91d6b056a6 Mon Sep 17 00:00:00 2001
2
 
From: Cosimo Cecchi <cosimoc@gnome.org>
3
 
Date: Tue, 13 Nov 2012 13:16:17 +0000
4
 
Subject: file: don't add a thumbnail border around desktop file launchers
5
 
 
6
 
https://bugzilla.gnome.org/show_bug.cgi?id=688237
7
 
---
8
 
diff --git a/libnautilus-private/nautilus-file.c b/libnautilus-private/nautilus-file.c
9
 
index e9b7715..d554376 100644
10
 
--- a/libnautilus-private/nautilus-file.c
11
 
+++ b/libnautilus-private/nautilus-file.c
12
 
@@ -3953,6 +3953,18 @@ get_custom_icon_metadata_name (NautilusFile *file)
13
 
 }
14
 
 
15
 
 static GIcon *
16
 
+get_link_icon (NautilusFile *file)
17
 
+{
18
 
+       GIcon *icon = NULL;
19
 
+
20
 
+       if (file->details->got_link_info && file->details->custom_icon != NULL) {
21
 
+               icon = g_object_ref (file->details->custom_icon);
22
 
+       }
23
 
+
24
 
+       return icon;
25
 
+}
26
 
+
27
 
+static GIcon *
28
 
 get_custom_icon (NautilusFile *file)
29
 
 {
30
 
        char *custom_icon_uri, *custom_icon_name;
31
 
@@ -3985,11 +3997,7 @@ get_custom_icon (NautilusFile *file)
32
 
                        g_free (custom_icon_name);
33
 
                }
34
 
        }
35
 
36
 
-       if (icon == NULL && file->details->got_link_info && file->details->custom_icon != NULL) {
37
 
-               icon = g_object_ref (file->details->custom_icon);
38
 
-       }
39
 
40
 
+
41
 
        return icon;
42
 
 }
43
 
 
44
 
@@ -4086,6 +4094,12 @@ nautilus_file_get_gicon (NautilusFile *file,
45
 
                return icon;
46
 
        }
47
 
 
48
 
+       icon = get_link_icon (file);
49
 
+
50
 
+       if (icon != NULL) {
51
 
+               return icon;
52
 
+       }
53
 
+
54
 
        if (file->details->icon) {
55
 
                icon = NULL;
56
 
 
57
 
@@ -4218,27 +4232,36 @@ nautilus_file_get_icon (NautilusFile *file,
58
 
 {
59
 
        NautilusIconInfo *icon;
60
 
        GIcon *gicon;
61
 
+       gboolean custom_icon;
62
 
        GdkPixbuf *raw_pixbuf, *scaled_pixbuf;
63
 
        int modified_size;
64
 
 
65
 
        if (file == NULL) {
66
 
                return NULL;
67
 
        }
68
 
-       
69
 
+
70
 
+       custom_icon = FALSE;
71
 
        gicon = get_custom_icon (file);
72
 
+
73
 
        if (gicon) {
74
 
-               GdkPixbuf *pixbuf;
75
 
+               custom_icon = TRUE;
76
 
+       } else {
77
 
+               gicon = get_link_icon (file);
78
 
+       }
79
 
 
80
 
+       if (gicon) {
81
 
                icon = nautilus_icon_info_lookup (gicon, size);
82
 
                g_object_unref (gicon);
83
 
 
84
 
-               pixbuf = nautilus_icon_info_get_pixbuf (icon);
85
 
-               if (pixbuf != NULL) {
86
 
-                       nautilus_ui_frame_image (&pixbuf);
87
 
-                       g_object_unref (icon);
88
 
+               if (custom_icon) {
89
 
+                       raw_pixbuf = nautilus_icon_info_get_pixbuf (icon);
90
 
+                       if (raw_pixbuf != NULL) {
91
 
+                               nautilus_ui_frame_image (&raw_pixbuf);
92
 
+                               g_object_unref (icon);
93
 
 
94
 
-                       icon = nautilus_icon_info_new_for_pixbuf (pixbuf);
95
 
-                       g_object_unref (pixbuf);
96
 
+                               icon = nautilus_icon_info_new_for_pixbuf (raw_pixbuf);
97
 
+                               g_object_unref (raw_pixbuf);
98
 
+                       }
99
 
                }
100
 
 
101
 
                return icon;
102
 
--
103
 
cgit v0.9.0.2