~matttbe/ubuntu/raring/cairo/1074667

« back to all changes in this revision

Viewing changes to debian/patches/disable-flto-for-gcc-4.6

  • Committer: Steve Langasek
  • Date: 2011-05-06 08:24:21 UTC
  • Revision ID: steve.langasek@linaro.org-20110506082421-zhssi32egz5b6r3n
debian/patches/disable-flto-for-gcc-4.6: disable use of -flto when
building.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: disable use of -flto when building
 
2
 Don't check for -flto support; this works around a bug in gcc-4.6
 
3
 (https://bugs.launchpad.net/bugs/778292) where cairo fails to build when
 
4
 -flto is used.
 
5
Author: Steve Langasek <steve.langasek@ubuntu.com>
 
6
Forwarded: not-needed
 
7
Index: trunk/aclocal.m4
 
8
===================================================================
 
9
--- trunk.orig/aclocal.m4
 
10
+++ trunk/aclocal.m4
 
11
@@ -587,6 +587,46 @@
 
12
 rmdir .tst 2>/dev/null
 
13
 AC_SUBST([am__leading_dot])])
 
14
 
 
15
+# Add --enable-maintainer-mode option to configure.         -*- Autoconf -*-
 
16
+# From Jim Meyering
 
17
+
 
18
+# Copyright (C) 1996, 1998, 2000, 2001, 2002, 2003, 2004, 2005, 2008
 
19
+# Free Software Foundation, Inc.
 
20
+#
 
21
+# This file is free software; the Free Software Foundation
 
22
+# gives unlimited permission to copy and/or distribute it,
 
23
+# with or without modifications, as long as this notice is preserved.
 
24
+
 
25
+# serial 5
 
26
+
 
27
+# AM_MAINTAINER_MODE([DEFAULT-MODE])
 
28
+# ----------------------------------
 
29
+# Control maintainer-specific portions of Makefiles.
 
30
+# Default is to disable them, unless `enable' is passed literally.
 
31
+# For symmetry, `disable' may be passed as well.  Anyway, the user
 
32
+# can override the default with the --enable/--disable switch.
 
33
+AC_DEFUN([AM_MAINTAINER_MODE],
 
34
+[m4_case(m4_default([$1], [disable]),
 
35
+       [enable], [m4_define([am_maintainer_other], [disable])],
 
36
+       [disable], [m4_define([am_maintainer_other], [enable])],
 
37
+       [m4_define([am_maintainer_other], [enable])
 
38
+        m4_warn([syntax], [unexpected argument to AM@&t@_MAINTAINER_MODE: $1])])
 
39
+AC_MSG_CHECKING([whether to am_maintainer_other maintainer-specific portions of Makefiles])
 
40
+  dnl maintainer-mode's default is 'disable' unless 'enable' is passed
 
41
+  AC_ARG_ENABLE([maintainer-mode],
 
42
+[  --][am_maintainer_other][-maintainer-mode  am_maintainer_other make rules and dependencies not useful
 
43
+                         (and sometimes confusing) to the casual installer],
 
44
+      [USE_MAINTAINER_MODE=$enableval],
 
45
+      [USE_MAINTAINER_MODE=]m4_if(am_maintainer_other, [enable], [no], [yes]))
 
46
+  AC_MSG_RESULT([$USE_MAINTAINER_MODE])
 
47
+  AM_CONDITIONAL([MAINTAINER_MODE], [test $USE_MAINTAINER_MODE = yes])
 
48
+  MAINT=$MAINTAINER_MODE_TRUE
 
49
+  AC_SUBST([MAINT])dnl
 
50
+]
 
51
+)
 
52
+
 
53
+AU_DEFUN([jm_MAINTAINER_MODE], [AM_MAINTAINER_MODE])
 
54
+
 
55
 # Check to see how 'make' treats includes.                 -*- Autoconf -*-
 
56
 
 
57
 # Copyright (C) 2001, 2002, 2003, 2005, 2009  Free Software Foundation, Inc.
 
58
Index: trunk/build/configure.ac.warnings
 
59
===================================================================
 
60
--- trunk.orig/build/configure.ac.warnings
 
61
+++ trunk/build/configure.ac.warnings
 
62
@@ -27,7 +27,7 @@
 
63
 
 
64
 dnl We also abuse the warning-flag facility to enable other compiler
 
65
 dnl options.  Namely, the following:
 
66
-MAYBE_WARN="$MAYBE_WARN -fno-strict-aliasing -fno-common -flto"
 
67
+MAYBE_WARN="$MAYBE_WARN -fno-strict-aliasing -fno-common"
 
68
 
 
69
 dnl Also to turn various gcc/glibc-specific preprocessor checks
 
70
 MAYBE_WARN="$MAYBE_WARN -Wp,-D_FORTIFY_SOURCE=2"
 
71
Index: trunk/configure
 
72
===================================================================
 
73
--- trunk.orig/configure
 
74
+++ trunk/configure
 
75
@@ -748,6 +748,8 @@
 
76
 am__EXEEXT_TRUE
 
77
 LTLIBOBJS
 
78
 LIBOBJS
 
79
+CAIRO_HAS_PERF_UTILS_FALSE
 
80
+CAIRO_HAS_PERF_UTILS_TRUE
 
81
 HAVE_GTK_FALSE
 
82
 HAVE_GTK_TRUE
 
83
 gtk_LIBS
 
84
@@ -1001,6 +1003,9 @@
 
85
 build
 
86
 AM_BACKSLASH
 
87
 AM_DEFAULT_VERBOSITY
 
88
+MAINT
 
89
+MAINTAINER_MODE_FALSE
 
90
+MAINTAINER_MODE_TRUE
 
91
 am__fastdepCC_FALSE
 
92
 am__fastdepCC_TRUE
 
93
 CCDEPMODE
 
94
@@ -1085,6 +1090,7 @@
 
95
 ac_user_opts='
 
96
 enable_option_checking
 
97
 enable_dependency_tracking
 
98
+enable_maintainer_mode
 
99
 enable_silent_rules
 
100
 enable_shared
 
101
 enable_static
 
102
@@ -1142,6 +1148,7 @@
 
103
 enable_interpreter
 
104
 enable_symbol_lookup
 
105
 enable_some_floating_point
 
106
+enable_perf_utils
 
107
 '
 
108
       ac_precious_vars='build_alias
 
109
 host_alias
 
110
@@ -1831,6 +1838,8 @@
 
111
   --enable-FEATURE[=ARG]  include FEATURE [ARG=yes]
 
112
   --disable-dependency-tracking  speeds up one-time build
 
113
   --enable-dependency-tracking   do not reject slow dependency extractors
 
114
+  --enable-maintainer-mode  enable make rules and dependencies not useful
 
115
+                         (and sometimes confusing) to the casual installer
 
116
   --enable-silent-rules          less verbose build output (undo: `make V=1')
 
117
   --disable-silent-rules         verbose build output (undo: `make V=0')
 
118
   --enable-shared[=PKGS]  build shared libraries [default=yes]
 
119
@@ -1961,6 +1970,8 @@
 
120
                           option can improve performance on systems without a
 
121
                           double precision floating-point unit, but might
 
122
                           degrade performance on those that do.
 
123
+  --enable-perf-utils=[no/auto/yes]
 
124
+                          Enable cairo's cairo-perf-utils feature [default=no]
 
125
 
 
126
 Optional Packages:
 
127
   --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
 
128
@@ -5199,6 +5210,29 @@
 
129
 
 
130
 
 
131
 
 
132
+
 
133
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable maintainer-specific portions of Makefiles" >&5
 
134
+$as_echo_n "checking whether to enable maintainer-specific portions of Makefiles... " >&6; }
 
135
+    # Check whether --enable-maintainer-mode was given.
 
136
+if test "${enable_maintainer_mode+set}" = set; then :
 
137
+  enableval=$enable_maintainer_mode; USE_MAINTAINER_MODE=$enableval
 
138
+else
 
139
+  USE_MAINTAINER_MODE=no
 
140
+fi
 
141
+
 
142
+  { $as_echo "$as_me:${as_lineno-$LINENO}: result: $USE_MAINTAINER_MODE" >&5
 
143
+$as_echo "$USE_MAINTAINER_MODE" >&6; }
 
144
+   if test $USE_MAINTAINER_MODE = yes; then
 
145
+  MAINTAINER_MODE_TRUE=
 
146
+  MAINTAINER_MODE_FALSE='#'
 
147
+else
 
148
+  MAINTAINER_MODE_TRUE='#'
 
149
+  MAINTAINER_MODE_FALSE=
 
150
+fi
 
151
+
 
152
+  MAINT=$MAINTAINER_MODE_TRUE
 
153
+
 
154
+
 
155
 # Check whether --enable-silent-rules was given.
 
156
 if test "${enable_silent_rules+set}" = set; then :
 
157
   enableval=$enable_silent_rules;
 
158
@@ -6063,13 +6097,13 @@
 
159
 else
 
160
   lt_cv_nm_interface="BSD nm"
 
161
   echo "int some_variable = 0;" > conftest.$ac_ext
 
162
-  (eval echo "\"\$as_me:6066: $ac_compile\"" >&5)
 
163
+  (eval echo "\"\$as_me:6100: $ac_compile\"" >&5)
 
164
   (eval "$ac_compile" 2>conftest.err)
 
165
   cat conftest.err >&5
 
166
-  (eval echo "\"\$as_me:6069: $NM \\\"conftest.$ac_objext\\\"\"" >&5)
 
167
+  (eval echo "\"\$as_me:6103: $NM \\\"conftest.$ac_objext\\\"\"" >&5)
 
168
   (eval "$NM \"conftest.$ac_objext\"" 2>conftest.err > conftest.out)
 
169
   cat conftest.err >&5
 
170
-  (eval echo "\"\$as_me:6072: output\"" >&5)
 
171
+  (eval echo "\"\$as_me:6106: output\"" >&5)
 
172
   cat conftest.out >&5
 
173
   if $GREP 'External.*some_variable' conftest.out > /dev/null; then
 
174
     lt_cv_nm_interface="MS dumpbin"
 
175
@@ -7271,7 +7305,7 @@
 
176
   ;;
 
177
 *-*-irix6*)
 
178
   # Find out which ABI we are using.
 
179
-  echo '#line 7274 "configure"' > conftest.$ac_ext
 
180
+  echo '#line 7308 "configure"' > conftest.$ac_ext
 
181
   if { { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_compile\""; } >&5
 
182
   (eval $ac_compile) 2>&5
 
183
   ac_status=$?
 
184
@@ -8531,11 +8565,11 @@
 
185
    -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
 
186
    -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
 
187
    -e 's:$: $lt_compiler_flag:'`
 
188
-   (eval echo "\"\$as_me:8534: $lt_compile\"" >&5)
 
189
+   (eval echo "\"\$as_me:8568: $lt_compile\"" >&5)
 
190
    (eval "$lt_compile" 2>conftest.err)
 
191
    ac_status=$?
 
192
    cat conftest.err >&5
 
193
-   echo "$as_me:8538: \$? = $ac_status" >&5
 
194
+   echo "$as_me:8572: \$? = $ac_status" >&5
 
195
    if (exit $ac_status) && test -s "$ac_outfile"; then
 
196
      # The compiler can only warn and ignore the option if not recognized
 
197
      # So say no if there are warnings other than the usual output.
 
198
@@ -8870,11 +8904,11 @@
 
199
    -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
 
200
    -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
 
201
    -e 's:$: $lt_compiler_flag:'`
 
202
-   (eval echo "\"\$as_me:8873: $lt_compile\"" >&5)
 
203
+   (eval echo "\"\$as_me:8907: $lt_compile\"" >&5)
 
204
    (eval "$lt_compile" 2>conftest.err)
 
205
    ac_status=$?
 
206
    cat conftest.err >&5
 
207
-   echo "$as_me:8877: \$? = $ac_status" >&5
 
208
+   echo "$as_me:8911: \$? = $ac_status" >&5
 
209
    if (exit $ac_status) && test -s "$ac_outfile"; then
 
210
      # The compiler can only warn and ignore the option if not recognized
 
211
      # So say no if there are warnings other than the usual output.
 
212
@@ -8975,11 +9009,11 @@
 
213
    -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
 
214
    -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
 
215
    -e 's:$: $lt_compiler_flag:'`
 
216
-   (eval echo "\"\$as_me:8978: $lt_compile\"" >&5)
 
217
+   (eval echo "\"\$as_me:9012: $lt_compile\"" >&5)
 
218
    (eval "$lt_compile" 2>out/conftest.err)
 
219
    ac_status=$?
 
220
    cat out/conftest.err >&5
 
221
-   echo "$as_me:8982: \$? = $ac_status" >&5
 
222
+   echo "$as_me:9016: \$? = $ac_status" >&5
 
223
    if (exit $ac_status) && test -s out/conftest2.$ac_objext
 
224
    then
 
225
      # The compiler can only warn and ignore the option if not recognized
 
226
@@ -9030,11 +9064,11 @@
 
227
    -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
 
228
    -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
 
229
    -e 's:$: $lt_compiler_flag:'`
 
230
-   (eval echo "\"\$as_me:9033: $lt_compile\"" >&5)
 
231
+   (eval echo "\"\$as_me:9067: $lt_compile\"" >&5)
 
232
    (eval "$lt_compile" 2>out/conftest.err)
 
233
    ac_status=$?
 
234
    cat out/conftest.err >&5
 
235
-   echo "$as_me:9037: \$? = $ac_status" >&5
 
236
+   echo "$as_me:9071: \$? = $ac_status" >&5
 
237
    if (exit $ac_status) && test -s out/conftest2.$ac_objext
 
238
    then
 
239
      # The compiler can only warn and ignore the option if not recognized
 
240
@@ -11414,7 +11448,7 @@
 
241
   lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
 
242
   lt_status=$lt_dlunknown
 
243
   cat > conftest.$ac_ext <<_LT_EOF
 
244
-#line 11417 "configure"
 
245
+#line 11451 "configure"
 
246
 #include "confdefs.h"
 
247
 
 
248
 #if HAVE_DLFCN_H
 
249
@@ -11510,7 +11544,7 @@
 
250
   lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
 
251
   lt_status=$lt_dlunknown
 
252
   cat > conftest.$ac_ext <<_LT_EOF
 
253
-#line 11513 "configure"
 
254
+#line 11547 "configure"
 
255
 #include "confdefs.h"
 
256
 
 
257
 #if HAVE_DLFCN_H
 
258
@@ -15595,11 +15629,11 @@
 
259
    -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
 
260
    -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
 
261
    -e 's:$: $lt_compiler_flag:'`
 
262
-   (eval echo "\"\$as_me:15598: $lt_compile\"" >&5)
 
263
+   (eval echo "\"\$as_me:15632: $lt_compile\"" >&5)
 
264
    (eval "$lt_compile" 2>conftest.err)
 
265
    ac_status=$?
 
266
    cat conftest.err >&5
 
267
-   echo "$as_me:15602: \$? = $ac_status" >&5
 
268
+   echo "$as_me:15636: \$? = $ac_status" >&5
 
269
    if (exit $ac_status) && test -s "$ac_outfile"; then
 
270
      # The compiler can only warn and ignore the option if not recognized
 
271
      # So say no if there are warnings other than the usual output.
 
272
@@ -15694,11 +15728,11 @@
 
273
    -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
 
274
    -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
 
275
    -e 's:$: $lt_compiler_flag:'`
 
276
-   (eval echo "\"\$as_me:15697: $lt_compile\"" >&5)
 
277
+   (eval echo "\"\$as_me:15731: $lt_compile\"" >&5)
 
278
    (eval "$lt_compile" 2>out/conftest.err)
 
279
    ac_status=$?
 
280
    cat out/conftest.err >&5
 
281
-   echo "$as_me:15701: \$? = $ac_status" >&5
 
282
+   echo "$as_me:15735: \$? = $ac_status" >&5
 
283
    if (exit $ac_status) && test -s out/conftest2.$ac_objext
 
284
    then
 
285
      # The compiler can only warn and ignore the option if not recognized
 
286
@@ -15746,11 +15780,11 @@
 
287
    -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
 
288
    -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
 
289
    -e 's:$: $lt_compiler_flag:'`
 
290
-   (eval echo "\"\$as_me:15749: $lt_compile\"" >&5)
 
291
+   (eval echo "\"\$as_me:15783: $lt_compile\"" >&5)
 
292
    (eval "$lt_compile" 2>out/conftest.err)
 
293
    ac_status=$?
 
294
    cat out/conftest.err >&5
 
295
-   echo "$as_me:15753: \$? = $ac_status" >&5
 
296
+   echo "$as_me:15787: \$? = $ac_status" >&5
 
297
    if (exit $ac_status) && test -s out/conftest2.$ac_objext
 
298
    then
 
299
      # The compiler can only warn and ignore the option if not recognized
 
300
@@ -17236,7 +17270,7 @@
 
301
 MAYBE_WARN="$MAYBE_WARN -erroff=E_ENUM_TYPE_MISMATCH_ARG \
 
302
                        -erroff=E_ENUM_TYPE_MISMATCH_OP"
 
303
 
 
304
-MAYBE_WARN="$MAYBE_WARN -fno-strict-aliasing -fno-common -flto"
 
305
+MAYBE_WARN="$MAYBE_WARN -fno-strict-aliasing -fno-common"
 
306
 
 
307
 MAYBE_WARN="$MAYBE_WARN -Wp,-D_FORTIFY_SOURCE=2"
 
308
 
 
309
@@ -34814,6 +34848,219 @@
 
310
 fi
 
311
 
 
312
 
 
313
+
 
314
+                                                                                                                                       # Check whether --enable-perf-utils was given.
 
315
+if test "${enable_perf_utils+set}" = set; then :
 
316
+  enableval=$enable_perf_utils; enable_perf_utils=$enableval
 
317
+else
 
318
+  enable_perf_utils=no
 
319
+fi
 
320
+
 
321
+                       case $enable_perf_utils in #(
 
322
+  no) :
 
323
+               use_perf_utils="no (disabled, use --enable-perf-utils to enable)"
 
324
+        ;; #(
 
325
+       yes|auto) :
 
326
+                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               if test "x$cairo_cv_perf_utils_cache_version" != "x6" -o \
 
327
+                           "x$cairo_cv_perf_utils_cache_commands_len" != "x18" -o \
 
328
+                           "x$cairo_cv_perf_utils_cache_vars" != "x BASE REQUIRES CFLAGS NONPKGCONFIG_CFLAGS LIBS NONPKGCONFIG_LIBS NONPKGCONFIG_EXTRA_LIBS"; then :
 
329
+  unset cairo_cv_perf_utils_use
 
330
+fi
 
331
+               if test "x$enable_perf_utils" = xyes -a "x$cairo_cv_perf_utils_use" != xyes; then :
 
332
+  unset cairo_cv_perf_utils_use
 
333
+fi
 
334
+
 
335
+               { $as_echo "$as_me:${as_lineno-$LINENO}: checking for cairo's cairo-perf-utils feature" >&5
 
336
+$as_echo_n "checking for cairo's cairo-perf-utils feature... " >&6; }
 
337
+if test "${cairo_cv_perf_utils_use+set}" = set; then :
 
338
+  $as_echo_n "(cached) " >&6
 
339
+else
 
340
+                       echo
 
341
+                       use_perf_utils=yes
 
342
+                               perf_utils_BASE="cairo"
 
343
+perf_utils_REQUIRES="$ac_env_perf_utils_REQUIRES_value"
 
344
+perf_utils_CFLAGS="$ac_env_perf_utils_CFLAGS_value"
 
345
+perf_utils_NONPKGCONFIG_CFLAGS="$ac_env_perf_utils_NONPKGCONFIG_CFLAGS_value"
 
346
+perf_utils_LIBS="$ac_env_perf_utils_LIBS_value"
 
347
+perf_utils_NONPKGCONFIG_LIBS="$ac_env_perf_utils_NONPKGCONFIG_LIBS_value"
 
348
+perf_utils_NONPKGCONFIG_EXTRA_LIBS="$ac_env_perf_utils_NONPKGCONFIG_EXTRA_LIBS_value"
 
349
+
 
350
+                       use_perf_utils=yes
 
351
+                       cairo_cv_perf_utils_use=$use_perf_utils
 
352
+                       cairo_cv_perf_utils_cache_vars=" BASE REQUIRES CFLAGS NONPKGCONFIG_CFLAGS LIBS NONPKGCONFIG_LIBS NONPKGCONFIG_EXTRA_LIBS"
 
353
+                       cairo_cv_perf_utils_cache_commands_len="18"
 
354
+                       cairo_cv_perf_utils_cache_version="6"
 
355
+                               cairo_cv_perf_utils_BASE=$perf_utils_BASE
 
356
+cairo_cv_perf_utils_REQUIRES=$perf_utils_REQUIRES
 
357
+cairo_cv_perf_utils_CFLAGS=$perf_utils_CFLAGS
 
358
+cairo_cv_perf_utils_NONPKGCONFIG_CFLAGS=$perf_utils_NONPKGCONFIG_CFLAGS
 
359
+cairo_cv_perf_utils_LIBS=$perf_utils_LIBS
 
360
+cairo_cv_perf_utils_NONPKGCONFIG_LIBS=$perf_utils_NONPKGCONFIG_LIBS
 
361
+cairo_cv_perf_utils_NONPKGCONFIG_EXTRA_LIBS=$perf_utils_NONPKGCONFIG_EXTRA_LIBS
 
362
+
 
363
+                       { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether cairo's cairo-perf-utils feature could be enabled" >&5
 
364
+$as_echo_n "checking whether cairo's cairo-perf-utils feature could be enabled... " >&6; }
 
365
+
 
366
+fi
 
367
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $cairo_cv_perf_utils_use" >&5
 
368
+$as_echo "$cairo_cv_perf_utils_use" >&6; }
 
369
+               use_perf_utils=$cairo_cv_perf_utils_use
 
370
+
 
371
+               if test "x$enable_perf_utils" = "xyes" -a "x$use_perf_utils" != xyes; then :
 
372
+                       as_fn_error $? " cairo-perf-utils feature could not be enabled" "$LINENO" 5
 
373
+
 
374
+fi      ;; #(
 
375
+  *) :
 
376
+                       as_fn_error $? "invalid argument passed to --enable-perf-utils: \`$use_perf_utils', should be one of [no/auto/yes]" "$LINENO" 5
 
377
+        ;;
 
378
+esac
 
379
+       if test "x$use_perf_utils" = "xyes"; then :
 
380
+                       perf_utils_BASE=$cairo_cv_perf_utils_BASE
 
381
+perf_utils_REQUIRES=$cairo_cv_perf_utils_REQUIRES
 
382
+perf_utils_CFLAGS=$cairo_cv_perf_utils_CFLAGS
 
383
+perf_utils_NONPKGCONFIG_CFLAGS=$cairo_cv_perf_utils_NONPKGCONFIG_CFLAGS
 
384
+perf_utils_LIBS=$cairo_cv_perf_utils_LIBS
 
385
+perf_utils_NONPKGCONFIG_LIBS=$cairo_cv_perf_utils_NONPKGCONFIG_LIBS
 
386
+perf_utils_NONPKGCONFIG_EXTRA_LIBS=$cairo_cv_perf_utils_NONPKGCONFIG_EXTRA_LIBS
 
387
+
 
388
+                                                                               CAIRO_REQUIRES="$perf_utils_REQUIRES"" ${CAIRO_REQUIRES}"
 
389
+
 
390
+                                                                       CAIRO_CFLAGS="$perf_utils_CFLAGS"" ${CAIRO_CFLAGS}"
 
391
+
 
392
+                                                                       CAIRO_NONPKGCONFIG_CFLAGS="$perf_utils_NONPKGCONFIG_CFLAGS"" ${CAIRO_NONPKGCONFIG_CFLAGS}"
 
393
+
 
394
+                                                                       CAIRO_LIBS="$perf_utils_LIBS"" ${CAIRO_LIBS}"
 
395
+
 
396
+                                                                       CAIRO_NONPKGCONFIG_LIBS="$perf_utils_NONPKGCONFIG_LIBS"" ${CAIRO_NONPKGCONFIG_LIBS}"
 
397
+
 
398
+
 
399
+else
 
400
+                                       perf_utils_BASE=$cairo_cv_perf_utils_BASE
 
401
+perf_utils_REQUIRES=$cairo_cv_perf_utils_REQUIRES
 
402
+perf_utils_CFLAGS=$cairo_cv_perf_utils_CFLAGS
 
403
+perf_utils_NONPKGCONFIG_CFLAGS=$cairo_cv_perf_utils_NONPKGCONFIG_CFLAGS
 
404
+perf_utils_LIBS=$cairo_cv_perf_utils_LIBS
 
405
+perf_utils_NONPKGCONFIG_LIBS=$cairo_cv_perf_utils_NONPKGCONFIG_LIBS
 
406
+perf_utils_NONPKGCONFIG_EXTRA_LIBS=$cairo_cv_perf_utils_NONPKGCONFIG_EXTRA_LIBS
 
407
+
 
408
+
 
409
+fi
 
410
+
 
411
+                                                        if test "x$use_perf_utils" = xyes; then
 
412
+  CAIRO_HAS_PERF_UTILS_TRUE=
 
413
+  CAIRO_HAS_PERF_UTILS_FALSE='#'
 
414
+else
 
415
+  CAIRO_HAS_PERF_UTILS_TRUE='#'
 
416
+  CAIRO_HAS_PERF_UTILS_FALSE=
 
417
+fi
 
418
+
 
419
+
 
420
+                                                                               cr_make_tmp='CAIRO_HAS_PERF_UTILS=0'
 
421
+                                                                                                               CAIRO_MAKEFILE___WIN32="${CAIRO_MAKEFILE___WIN32}
 
422
+""$cr_make_tmp"
 
423
+
 
424
+
 
425
+                                                                               cr_make_tmp=''
 
426
+                                                                                       CAIRO_MAKEFILE_cairo_AMAKE="${CAIRO_MAKEFILE_cairo_AMAKE}
 
427
+""$cr_make_tmp"
 
428
+
 
429
+                                                                                                               CAIRO_MAKEFILE_cairo_WIN32="${CAIRO_MAKEFILE_cairo_WIN32}
 
430
+""$cr_make_tmp"
 
431
+                                                                               cr_make_tmp=''
 
432
+                                                                                       CAIRO_MAKEFILE_cairo_boilerplate_AMAKE="${CAIRO_MAKEFILE_cairo_boilerplate_AMAKE}
 
433
+""$cr_make_tmp"
 
434
+
 
435
+                                                                                                               CAIRO_MAKEFILE_cairo_boilerplate_WIN32="${CAIRO_MAKEFILE_cairo_boilerplate_WIN32}
 
436
+""$cr_make_tmp"
 
437
+
 
438
+
 
439
+
 
440
+
 
441
+
 
442
+
 
443
+                                                                               cr_make_tmp='all_cairo_private += $(cairo_perf_utils_private) $(cairo_perf_utils_headers)
 
444
+all_cairo_cxx_sources += $(cairo_perf_utils_cxx_sources)
 
445
+all_cairo_sources += $(cairo_perf_utils_sources)'
 
446
+                                                                                       CAIRO_MAKEFILE_cairo_AMAKE="${CAIRO_MAKEFILE_cairo_AMAKE}
 
447
+""$cr_make_tmp"
 
448
+
 
449
+                                                                                                               CAIRO_MAKEFILE_cairo_WIN32="${CAIRO_MAKEFILE_cairo_WIN32}
 
450
+""$cr_make_tmp"
 
451
+                                                                               cr_make_tmp='all_cairo_boilerplate_private += $(cairo_boilerplate_perf_utils_private) $(cairo_boilerplate_perf_utils_headers)
 
452
+all_cairo_boilerplate_cxx_sources += $(cairo_boilerplate_perf_utils_cxx_sources)
 
453
+all_cairo_boilerplate_sources += $(cairo_boilerplate_perf_utils_sources)'
 
454
+                                                                                       CAIRO_MAKEFILE_cairo_boilerplate_AMAKE="${CAIRO_MAKEFILE_cairo_boilerplate_AMAKE}
 
455
+""$cr_make_tmp"
 
456
+
 
457
+                                                                                                               CAIRO_MAKEFILE_cairo_boilerplate_WIN32="${CAIRO_MAKEFILE_cairo_boilerplate_WIN32}
 
458
+""$cr_make_tmp"
 
459
+
 
460
+
 
461
+                                                                               cr_make_tmp='enabled_cairo_private += $(cairo_perf_utils_private) $(cairo_perf_utils_headers)
 
462
+enabled_cairo_cxx_sources += $(cairo_perf_utils_cxx_sources)
 
463
+enabled_cairo_sources += $(cairo_perf_utils_sources)'
 
464
+                                                                               CAIRO_MAKEFILE_cairo_AMAKE="${CAIRO_MAKEFILE_cairo_AMAKE}
 
465
+"'if CAIRO_HAS_PERF_UTILS'
 
466
+                                       CAIRO_MAKEFILE_cairo_AMAKE="${CAIRO_MAKEFILE_cairo_AMAKE}
 
467
+""$cr_make_tmp"
 
468
+                                       CAIRO_MAKEFILE_cairo_AMAKE="${CAIRO_MAKEFILE_cairo_AMAKE}
 
469
+"'endif'
 
470
+
 
471
+                                                                                                       CAIRO_MAKEFILE_cairo_WIN32="${CAIRO_MAKEFILE_cairo_WIN32}
 
472
+"'ifeq ($(CAIRO_HAS_PERF_UTILS),1)'
 
473
+                                       CAIRO_MAKEFILE_cairo_WIN32="${CAIRO_MAKEFILE_cairo_WIN32}
 
474
+""$cr_make_tmp"
 
475
+                                       CAIRO_MAKEFILE_cairo_WIN32="${CAIRO_MAKEFILE_cairo_WIN32}
 
476
+"'endif'
 
477
+                                                                       cr_make_tmp='enabled_cairo_boilerplate_private += $(cairo_boilerplate_perf_utils_private) $(cairo_boilerplate_perf_utils_headers)
 
478
+enabled_cairo_boilerplate_cxx_sources += $(cairo_boilerplate_perf_utils_cxx_sources)
 
479
+enabled_cairo_boilerplate_sources += $(cairo_boilerplate_perf_utils_sources)'
 
480
+                                                                               CAIRO_MAKEFILE_cairo_boilerplate_AMAKE="${CAIRO_MAKEFILE_cairo_boilerplate_AMAKE}
 
481
+"'if CAIRO_HAS_PERF_UTILS'
 
482
+                                       CAIRO_MAKEFILE_cairo_boilerplate_AMAKE="${CAIRO_MAKEFILE_cairo_boilerplate_AMAKE}
 
483
+""$cr_make_tmp"
 
484
+                                       CAIRO_MAKEFILE_cairo_boilerplate_AMAKE="${CAIRO_MAKEFILE_cairo_boilerplate_AMAKE}
 
485
+"'endif'
 
486
+
 
487
+                                                                                                       CAIRO_MAKEFILE_cairo_boilerplate_WIN32="${CAIRO_MAKEFILE_cairo_boilerplate_WIN32}
 
488
+"'ifeq ($(CAIRO_HAS_PERF_UTILS),1)'
 
489
+                                       CAIRO_MAKEFILE_cairo_boilerplate_WIN32="${CAIRO_MAKEFILE_cairo_boilerplate_WIN32}
 
490
+""$cr_make_tmp"
 
491
+                                       CAIRO_MAKEFILE_cairo_boilerplate_WIN32="${CAIRO_MAKEFILE_cairo_boilerplate_WIN32}
 
492
+"'endif'
 
493
+
 
494
+
 
495
+
 
496
+
 
497
+
 
498
+
 
499
+
 
500
+
 
501
+
 
502
+                                       if test "x$use_perf_utils" = xyes; then :
 
503
+  :
 
504
+
 
505
+$as_echo "#define CAIRO_HAS_PERF_UTILS 1" >>confdefs.h
 
506
+
 
507
+
 
508
+
 
509
+fi
 
510
+                                                                               cr_make_tmp='   @echo "#define CAIRO_HAS_PERF_UTILS 1" >> src/cairo-features.h'
 
511
+                                                                                                       CAIRO_MAKEFILE_win32_features_h_WIN32="${CAIRO_MAKEFILE_win32_features_h_WIN32}
 
512
+"'ifeq ($(CAIRO_HAS_PERF_UTILS),1)'
 
513
+                                       CAIRO_MAKEFILE_win32_features_h_WIN32="${CAIRO_MAKEFILE_win32_features_h_WIN32}
 
514
+""$cr_make_tmp"
 
515
+                                       CAIRO_MAKEFILE_win32_features_h_WIN32="${CAIRO_MAKEFILE_win32_features_h_WIN32}
 
516
+"'endif'
 
517
+
 
518
+
 
519
+
 
520
+
 
521
+
 
522
+
 
523
+
 
524
+
 
525
+
 
526
 ac_config_files="$ac_config_files Makefile boilerplate/Makefile src/Makefile test/Makefile test/pdiff/Makefile perf/Makefile util/Makefile util/cairo-fdr/Makefile util/cairo-gobject/Makefile util/cairo-script/Makefile util/cairo-script/examples/Makefile util/cairo-sphinx/Makefile util/cairo-trace/Makefile util/cairo-trace/cairo-trace doc/Makefile doc/public/Makefile"
 
527
 
 
528
 
 
529
@@ -34931,6 +35178,10 @@
 
530
   am__EXEEXT_FALSE=
 
531
 fi
 
532
 
 
533
+if test -z "${MAINTAINER_MODE_TRUE}" && test -z "${MAINTAINER_MODE_FALSE}"; then
 
534
+  as_fn_error $? "conditional \"MAINTAINER_MODE\" was never defined.
 
535
+Usually this means the macro was only invoked conditionally." "$LINENO" 5
 
536
+fi
 
537
 if test -z "${ENABLE_GTK_DOC_TRUE}" && test -z "${ENABLE_GTK_DOC_FALSE}"; then
 
538
   as_fn_error $? "conditional \"ENABLE_GTK_DOC\" was never defined.
 
539
 Usually this means the macro was only invoked conditionally." "$LINENO" 5
 
540
@@ -35220,6 +35471,10 @@
 
541
   as_fn_error $? "conditional \"HAVE_GTK\" was never defined.
 
542
 Usually this means the macro was only invoked conditionally." "$LINENO" 5
 
543
 fi
 
544
+if test -z "${CAIRO_HAS_PERF_UTILS_TRUE}" && test -z "${CAIRO_HAS_PERF_UTILS_FALSE}"; then
 
545
+  as_fn_error $? "conditional \"CAIRO_HAS_PERF_UTILS\" was never defined.
 
546
+Usually this means the macro was only invoked conditionally." "$LINENO" 5
 
547
+fi
 
548
 
 
549
 : ${CONFIG_STATUS=./config.status}
 
550
 ac_write_fail=0
 
551
@@ -38789,6 +39044,7 @@
 
552
        echo "The following features and utilities:"
 
553
        echo "  cairo-trace:                $use_trace"
 
554
        echo "  cairo-script-interpreter:   $use_interpreter"
 
555
+       echo "  cairo-perf-utils:           $use_perf_utils"
 
556
        echo ""
 
557
        echo "And the following internal features:"
 
558
        echo "  pthread:       $use_pthread"