~mitya57/kubuntu-packaging/qt-4.8.6+git49-gbc62005

« back to all changes in this revision

Viewing changes to debian/patches/kubuntu_28_xi2.1.patch

  • Committer: Dmitry Shachnev
  • Date: 2014-04-25 10:22:59 UTC
  • Revision ID: mitya57@ubuntu.com-20140425102259-3yy1pvpk2zhqwb72
* Merge from Debian unstable.  Remaining changes:
  - Pass list-missing to dh_install instead of fail-missing, since we don't
    install the QtWebkit headers
  - Make sure libqt4-opengl-dev depends on gles libs for armel and armhf
  - Do not package ibase/firebird and sqlite2 package
    + remove from debian/control
    + libqt4-sql doesn't recommend libqt4-sql-ibase and libqt4-sql-sqlite2
  - Build QtWebkit and use it only for QtAssistant
    + Rule to put qt_webkit_version.pri in mkspecs/modules
    + Rule to remove libQtWebKit* after build
    + Exclude usr/bin/assistant-qt4 from dh_shlibdeps
  - Also exclude webkit examples from dh_shlibdeps
  - Do not build libqt4-phonon, disable in debian/control
  - Add debian/Trolltech.conf and install it in libqtcore4.install
  - On armel and armhf, build with -gstabs instead of -g in an effort to get
    the link step for QtWebkit to complete before timed out by the builders
  - Build with -no-neon on armel and armhf
  - Build with -no-javascript-jit on arm64
  - Install qatomic_aarch64.h
  - Add patches:
    + kubuntu_10_ibus_input_method.diff
    + kubuntu_12_fix_stack_protector.diff
    + kubuntu_14_systemtrayicon.diff
    + kubuntu_17_enable_qtwebkit_for_qtassistant.diff
    + kubuntu_28_xi2.1.patch
    + kubuntu_30_translucent_drag_pixmap.diff
    + kubuntu_31_unity_workarea_atom.diff
    + kubuntu_37_cups_settings.diff
    + kubuntu_39_fix_medium_font.diff
    + kubuntu_40_disable_neon.patch
    + kubuntu_93_disable_overlay_scrollbars.diff
    + kubuntu_94_xinput_valuators_fix.diff
    + kubuntu_95_qt_disable_bounce.diff
    + kubuntu_97_a11y_qt_and_qml_backport.diff
    + kubuntu_glib-honor-ExcludeSocketNotifiers-flag.diff
    + aarch64.patch
    + ppc64el.patch
  - Drop powerpc_designer_gstabs.diff, it breaks powerpc
  - Use Kubuntu Vcs fields
* Drop kubuntu_34_no_gold_check.diff, applied upstream.
* Drop aarch64_fix_jsc.patch, no longer needed.
* Drop aarch64_fix_atomic_set.patch, instead of patching a patch
  apply changes directly in aarch64.patch.
* Refresh and rebase other patches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
134
134
     xinput)
135
135
         if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ] || [ "$VAL" = "runtime" ]; then
136
136
             CFG_XINPUT="$VAL"
137
 
@@ -4305,6 +4313,13 @@
 
137
@@ -4311,6 +4319,13 @@
138
138
         XMY="*"
139
139
         XMN=" "
140
140
     fi
148
148
     if [ "$CFG_XINPUT" = "no" ]; then
149
149
         XIY=" "
150
150
         XIN="*"
151
 
@@ -4409,7 +4424,10 @@
 
151
@@ -4415,7 +4430,10 @@
152
152
                          Requires fontconfig/fontconfig.h, libfontconfig,
153
153
                          freetype.h and libfreetype.
154
154
 
160
160
  $XIY  -xinput ............ Compile Xinput support. This also enabled tablet support
161
161
                          which requires IRIX with wacom.h and libXi or
162
162
                          XFree86 with X11/extensions/XInput.h and libXi.
163
 
@@ -6381,7 +6399,22 @@
 
163
@@ -6420,7 +6438,22 @@
164
164
        fi
165
165
     fi
166
166
 
184
184
     if [ "$CFG_XINPUT" != "no" ]; then
185
185
         if compileTest x11/xinput "XInput" $X11TESTS_FLAGS; then
186
186
            if [ "$CFG_XINPUT" != "runtime" ]; then
187
 
@@ -7603,9 +7636,12 @@
 
187
@@ -7645,9 +7678,12 @@
188
188
     if [ "$CFG_FONTCONFIG" = "yes" ]; then
189
189
         QT_CONFIG="$QT_CONFIG fontconfig"
190
190
     fi
198
198
     if [ "$CFG_XINPUT" = "yes" ]; then
199
199
         QT_CONFIG="$QT_CONFIG xinput tablet"
200
200
     fi
201
 
@@ -8527,6 +8563,7 @@
 
201
@@ -8576,6 +8612,7 @@
202
202
     [ "$CFG_XVIDEO" = "no" ]     && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_XVIDEO"
203
203
     [ "$CFG_XSYNC" = "no" ]     && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_XSYNC"
204
204
     [ "$CFG_XINPUT" = "no" ]     && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_XINPUT QT_NO_TABLET"
206
206
 
207
207
     [ "$CFG_XCURSOR" = "runtime" ]   && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_RUNTIME_XCURSOR"
208
208
     [ "$CFG_XINERAMA" = "runtime" ]  && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_RUNTIME_XINERAMA"
209
 
@@ -9100,6 +9137,7 @@
 
209
@@ -9149,6 +9186,7 @@
210
210
     echo "Xfixes support ......... $CFG_XFIXES"
211
211
     echo "Xrandr support ......... $CFG_XRANDR"
212
212
     echo "Xrender support ........ $CFG_XRENDER"
822
822
         _QT_SETTINGS_TIMESTAMP = NPredefinedAtoms,
823
823
--- a/src/gui/kernel/qwidget.cpp
824
824
+++ b/src/gui/kernel/qwidget.cpp
825
 
@@ -11007,7 +11007,7 @@
 
825
@@ -11020,7 +11020,7 @@
826
826
 #endif
827
827
         break;
828
828
     case Qt::WA_AcceptTouchEvents: