~mitya57/network-manager-applet/drop-useless-patch

« back to all changes in this revision

Viewing changes to debian/patches/applet-wifi-menu-before-vpn.patch

  • Committer: Mathieu Trudel-Lapierre
  • Date: 2015-01-27 01:15:32 UTC
  • Revision ID: mathieu-tl@ubuntu.com-20150127011532-fgmu42251lul2njn
* New upstream release: 0.9.10.1.
* Resync packaging with Debian:
  - debian/rules: Set DEB_HOST_MULTIARCH, use dh_install exclusions rather
    than removing .la and .a files separately. 
  - debian/control: Build-depends: update NM b-deps, drop docbook-to-man,
    bump to dh 9, update libgtk/libglib2.0 b-deps versions and make
    libnm-gtk Multi-Arch-aware.
  - debian/*.install: update paths for multi-arch.
  - debian/compat: bump to compat level 9.
* debian/patches dropped because they were applied upstream:
  - git_use_paths_in_vpn_name_files_4867951.patch,
  - git_revert_system_ca_cert.patch,
  - lp289466_always_show_tray_icon.patch,
  - key-certificate-extensions.patch,
  - lp829673_gconf_hide_applet.patch,
  - 0001_Move_on_with_enter_in_the_country_page_of_the_new_mobile_wizard.patch
* debian/patches/lp328572-dxteam-connect-text.patch,
  debian/patches/lp330571_dxteam_wired_connect_text.patch,
  debian/patches/lp330608_dxteam_gsm_connect_text.patch: stop carrying
  needless string changes causing delta with upstream; any changes to the
  strings should happen there so we stay in sync.
  dropped; included upstream.
* Refreshed remaining patches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
---
2
 
 src/applet.c |    7 ++-----
3
 
 1 file changed, 2 insertions(+), 5 deletions(-)
 
2
 src/applet.c |    6 ++----
 
3
 1 file changed, 2 insertions(+), 4 deletions(-)
4
4
 
5
5
Index: b/src/applet.c
6
6
===================================================================
7
7
--- a/src/applet.c
8
8
+++ b/src/applet.c
9
 
@@ -1718,8 +1718,6 @@ nma_menu_add_vpn_submenu (GtkWidget *men
 
9
@@ -1794,8 +1794,6 @@ nma_menu_add_vpn_submenu (GtkWidget *men
10
10
        GSList *list, *iter;
11
11
        int num_vpn_active = 0;
12
12
 
15
15
        vpn_menu = GTK_MENU (gtk_menu_new ());
16
16
 
17
17
        item = GTK_MENU_ITEM (gtk_menu_item_new_with_mnemonic (_("_VPN Connections")));
18
 
@@ -1888,15 +1886,14 @@ static void nma_menu_show_cb (GtkWidget
19
 
 
20
 
        n_wifi = nma_menu_add_devices (menu, applet);
21
 
 
 
18
@@ -1985,14 +1983,14 @@ static void nma_menu_show_cb (GtkWidget
 
19
        }
 
20
 
 
21
        nma_menu_add_devices (menu, applet);
22
22
-       nma_menu_add_vpn_submenu (menu, applet);
23
 
-
24
 
        if (n_wifi > 0 && nm_client_wireless_get_enabled (applet->nm_client)) {
 
23
 
 
24
        if (has_usable_wifi (applet)) {
25
25
                /* Add the "Hidden Wi-Fi network..." entry */
26
26
-               nma_menu_add_separator_item (menu);
27
27
                nma_menu_add_hidden_network_item (menu, applet);
28
28
                nma_menu_add_create_network_item (menu, applet);
29
29
+               nma_menu_add_separator_item (menu);
30
30
        }
31
 
 
32
31
+       nma_menu_add_vpn_submenu (menu, applet);
 
32
 
33
33
        gtk_widget_show_all (menu);
34
34
 
35
 
 //     nmi_dbus_signal_user_interface_activated (applet->connection);