~mmach/netext73/lz4

« back to all changes in this revision

Viewing changes to debian/patches/0002-Fix-static-link.patch

  • Committer: mmach
  • Date: 2020-11-29 19:46:48 UTC
  • Revision ID: netbit73@gmail.com-20201129194648-8g87ivgzol71gnma
1.9.3

Show diffs side-by-side

added added

removed removed

Lines of Context:
9
9
 tests/Makefile    | 3 ++-
10
10
 2 files changed, 5 insertions(+), 4 deletions(-)
11
11
 
12
 
diff --git a/programs/Makefile b/programs/Makefile
13
 
index 4994551..626fec0 100644
14
 
--- a/programs/Makefile
15
 
+++ b/programs/Makefile
16
 
@@ -41,7 +41,7 @@ LIBVER_MINOR := $(shell echo $(LIBVER_MINOR_SCRIPT))
17
 
 LIBVER_PATCH := $(shell echo $(LIBVER_PATCH_SCRIPT))
18
 
 LIBVER   := $(shell echo $(LIBVER_SCRIPT))
19
 
 
20
 
-SRCFILES := $(sort $(wildcard $(LZ4DIR)/*.c) $(wildcard *.c))
21
 
+SRCFILES := $(sort $(wildcard $(LZ4DIR)/*.c)  $(wildcard *.c))
22
 
 OBJFILES := $(SRCFILES:.c=.o)
23
 
 
24
 
 CPPFLAGS += -I$(LZ4DIR) -DXXH_NAMESPACE=LZ4_
25
 
@@ -79,10 +79,10 @@ lz4-exe.o: lz4-exe.rc
26
 
        $(WINDRES) -i lz4-exe.rc -o lz4-exe.o
27
 
 
28
 
 lz4: $(OBJFILES) lz4-exe.o
29
 
-       $(CC) $(FLAGS) $^ -o $@$(EXT)
30
 
+       $(CC) $(FLAGS) $^ -o $@$(EXT) -L ../lib -llz4
31
 
 else
32
 
 lz4: $(OBJFILES)
33
 
-       $(CC) $(FLAGS) $^ -o $@$(EXT)
34
 
+       $(CC) $(FLAGS) $^ -o $@$(EXT) -L ../lib -llz4
35
 
 endif
36
 
 
37
 
 
38
 
@@ -94,7 +94,7 @@ lz4c: lz4
 
12
Index: lz4-1.9.3/programs/Makefile
 
13
===================================================================
 
14
--- lz4-1.9.3.orig/programs/Makefile
 
15
+++ lz4-1.9.3/programs/Makefile
 
16
@@ -107,7 +107,7 @@ lz4c: lz4
39
17
 
40
18
 lz4c32: CFLAGS += -m32
41
19
 lz4c32 : $(SRCFILES)
44
22
 
45
23
 lz4.1: lz4.1.md $(LIBVER_SRC)
46
24
        cat $< | $(MD2ROFF) $(MD2ROFF_FLAGS) | sed -n '/^\.\\\".*/!p' > $@
47
 
diff --git a/tests/Makefile b/tests/Makefile
48
 
index 67514e4..2c5f253 100644
49
 
--- a/tests/Makefile
50
 
+++ b/tests/Makefile
 
25
Index: lz4-1.9.3/tests/Makefile
 
26
===================================================================
 
27
--- lz4-1.9.3.orig/tests/Makefile
 
28
+++ lz4-1.9.3/tests/Makefile
51
29
@@ -43,6 +43,8 @@ CFLAGS  += $(DEBUGFLAGS) $(MOREFLAGS)
52
30
 CPPFLAGS+= -I$(LZ4DIR) -I$(PRGDIR) -DXXH_NAMESPACE=LZ4_
53
31
 FLAGS    = $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
57
35
 include ../Makefile.inc
58
36
 
59
37
 LZ4 := $(PRGDIR)/lz4$(EXT)
60
 
@@ -61,7 +63,7 @@ all32: CFLAGS+=-m32
 
38
@@ -62,7 +64,7 @@ all32: CFLAGS+=-m32
61
39
 all32: all
62
40
 
63
41
 lz4: