~mniess/ubuntu/precise/compiz/fix-screenshot

« back to all changes in this revision

Viewing changes to debian/patches/103_driver_workaround.patch

  • Committer: Package Import Robot
  • Author(s): Didier Roche, David Barth, Didier Roche
  • Date: 2011-09-12 08:09:46 UTC
  • mfrom: (0.168.10 upstream)
  • Revision ID: package-import@ubuntu.com-20110912080946-1tp6975muls4eb2v
Tags: 1:0.9.5.94+bzr2803-0ubuntu1
[ David Barth ]
* New upstream release 0.9.5.94
  - Merge in change to have a serverWindows () this break the API
  - "mumble fix", ie "It is possible to stack windows relative to windows that are destroyed" (LP: #837252)
  - fix for "Severe screen corruption after rotate the screen" (LP: #833549)
  - Remove inactive API
  - Fix for "vp switch causes windows to move further offscreen" (LP: #831987)
  - Debug messages removed
  - Memory leak fix in gtk and unity window decorators
  - Fix further issues with shaped windows mapping/unmapping (rev. 2793)
* removed patches that were integrated into the new upstream release
  - debian/patches/100_core-fix-rev-2794.patch
  - debian/patches/101_memleak-fix-rev-2794.patch
  - debian/patches/102_attrib-fix-rev-2796.patch
  - debian/patches/103_driver_workaround.patch

[ Didier Roche ]
* debian/rules, debian/compiz-gnome.install, debian/compiz-keybindings.sed:
  - readd and tweak some compiz keys for g-c-c and Gnome integration
    This fixes Ctrl + Alt + T to open a terminal (LP: #820266)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
=== modified file 'compiz-0.9.5.92/plugins/opengl/src/screen.cpp'
2
 
--- compiz-0.9.5.92/plugins/opengl/src/screen.cpp       2011-02-24 07:52:09 +0000
3
 
+++ compiz-0.9.5.92/plugins/opengl/src/screen.cpp       2011-08-23 14:33:20 +0000
4
 
@@ -25,6 +25,11 @@
5
 
  *          David Reveman <davidr@novell.com>
6
 
  */
7
 
 
8
 
+#ifndef _GNU_SOURCE
9
 
+#define _GNU_SOURCE
10
 
+#endif
11
 
+#include <errno.h>
12
 
+
13
 
 #include "privates.h"
14
 
 
15
 
 #include <dlfcn.h>
16
 
@@ -97,6 +102,11 @@
17
 
     const char           *glRenderer;
18
 
     CompOption::Vector o (0);
19
 
 
20
 
+#if defined (__GLIBC__) && (__GLIBC__ >= 2)
21
 
+    /* bug #685682 */
22
 
+    program_invocation_short_name[0] = 'C';
23
 
+#endif
24
 
+
25
 
     if (indirectRendering)
26
 
     {
27
 
        /* force Mesa libGL into indirect rendering mode, because
28
 
@@ -531,6 +541,10 @@
29
 
     if (GL::textureFromPixmap)
30
 
        registerBindPixmap (TfpTexture::bindPixmapToTexture);
31
 
 
32
 
+#if defined (__GLIBC__) && (__GLIBC__ >= 2)
33
 
+    /* bug #685682 */
34
 
+    program_invocation_short_name[0] = 'c';
35
 
+#endif
36
 
 }
37
 
 
38
 
 GLScreen::~GLScreen ()
39