~mozillateam/firefox/firefox-beta.mantic

« back to all changes in this revision

Viewing changes to debian/patches/armhf-clang-no-integrated-as-for-neon.patch

  • Committer: Rico Tzschichholz
  • Date: 2024-01-12 22:29:38 UTC
  • Revision ID: ricotz@ubuntu.com-20240112222938-9kxudf8enw2l60c2
* New upstream release from the beta channel (FIREFOX_122_0b9_BUILD1)
* Update patches
  - debian/patches/armhf-clang-no-integrated-as-for-neon.patch
  - debian/patches/armhf-do-not-build-pixman-with-neon.patch
  - debian/patches/ppc64el-workaround-gcc-ice.patch
  - debian/patches/webrtc-fix-compiler-flags-for-armhf.patch
* Bump build-dep to python3 >= 3.8
  -debian/control{,.in}

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
 
6
6
--- a/media/libjpeg/moz.build
7
7
+++ b/media/libjpeg/moz.build
8
 
@@ -192,6 +192,10 @@ if CONFIG['CPU_ARCH'] == 'x86_64':
 
8
@@ -192,6 +192,10 @@ if CONFIG['TARGET_CPU'] == 'x86_64':
9
9
     ASFLAGS += ['-I%s/media/libjpeg/simd/nasm/' % TOPSRCDIR]
10
10
     ASFLAGS += ['-I%s/media/libjpeg/simd/x86_64/' % TOPSRCDIR]
11
11
 
12
12
+# The integrated assembler fails to build simd/arm/jsimd_neon.S because it doesn't have NEON
13
 
+if CONFIG['CC_TYPE'] == 'clang' and CONFIG['CPU_ARCH'] == 'arm':
 
13
+if CONFIG['CC_TYPE'] == 'clang' and CONFIG['TARGET_CPU'] == 'arm':
14
14
+    ASFLAGS += ['-fno-integrated-as']
15
15
+
16
16
 # We allow warnings for third-party code that can be updated from upstream.
18
18
 
19
19
--- a/gfx/ycbcr/moz.build
20
20
+++ b/gfx/ycbcr/moz.build
21
 
@@ -60,6 +60,9 @@ if CONFIG['CPU_ARCH'] == 'arm' and CONFI
 
21
@@ -60,6 +60,9 @@ if CONFIG['TARGET_CPU'] == 'arm' and CONFI
22
22
     SOURCES += [
23
23
         'yuv_convert_arm.cpp',
24
24
     ]