~mozillateam/firefox/firefox-beta.zesty

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu-ua-string-changes.patch

  • Committer: Rico Tzschichholz
  • Date: 2017-11-28 06:37:05 UTC
  • Revision ID: ricotz@ubuntu.com-20171128063705-n2wx3nqcba5ciems
* New upstream release from the beta channel (FIREFOX_58_0b7_BUILD1)
* Fix build on ppc64
  - debian/patches/ppc64_moz1416170.patch
* Fix LP: #1733970 - Search suggestions are broken after refreshing the
  Google searchplugin
* Fix a missing token in the user agent string
  - update debian/patches/ubuntu-ua-string-changes.patch
  - update debian/patches/support-coinstallable-trunk-build.patch
  - update debian/build/rules.mk
  - update debian/config/mozconfig.in
* Update patches
  - debian/patches/normalize-distribution-searchplugins.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
Author: Chris Coulson <chris.coulson@canonical.com>
3
3
Forwarded: not-needed
4
4
 
5
 
Index: firefox-trunk-43.0~a1~hg20150916r262830/netwerk/protocol/http/nsHttpHandler.cpp
6
 
===================================================================
7
 
--- firefox-trunk-43.0~a1~hg20150916r262830.orig/netwerk/protocol/http/nsHttpHandler.cpp        2015-09-17 19:42:31.429286277 +0100
8
 
+++ firefox-trunk-43.0~a1~hg20150916r262830/netwerk/protocol/http/nsHttpHandler.cpp     2015-09-17 19:43:17.257423792 +0100
9
 
@@ -172,6 +172,9 @@
 
5
--- a/netwerk/protocol/http/nsHttpHandler.cpp
 
6
+++ b/netwerk/protocol/http/nsHttpHandler.cpp
 
7
@@ -213,6 +213,9 @@
10
8
     , mLegacyAppName("Mozilla")
11
9
     , mLegacyAppVersion("5.0")
12
10
     , mProduct("Gecko")
16
14
     , mCompatFirefoxEnabled(false)
17
15
     , mUserAgentIsDirty(true)
18
16
     , mAcceptLanguagesIsDirty(true)
19
 
@@ -343,6 +346,9 @@
 
17
@@ -502,6 +505,9 @@
20
18
     LOG(("> misc = %s\n", mMisc.get()));
21
19
     LOG(("> product = %s\n", mProduct.get()));
22
20
     LOG(("> product-sub = %s\n", mProductSub.get()));
26
24
     LOG(("> app-name = %s\n", mAppName.get()));
27
25
     LOG(("> app-version = %s\n", mAppVersion.get()));
28
26
     LOG(("> compat-firefox = %s\n", mCompatFirefox.get()));
29
 
@@ -639,8 +645,10 @@
 
27
@@ -872,8 +878,10 @@
30
28
                            mCompatFirefox.Length() +
31
29
                            mCompatDevice.Length() +
32
30
                            mDeviceModelId.Length() +
33
31
-                           13);
34
32
-
35
33
+#ifdef MOZ_UA_VENDOR
36
 
+                           mVendor.Length() + 
 
34
+                           mVendor.Length() +
37
35
+#endif
38
36
+                           15);
39
37
     // Application portion
40
38
     mUserAgent.Assign(mLegacyAppName);
41
39
     mUserAgent += '/';
42
 
@@ -655,6 +663,10 @@
 
40
@@ -888,6 +896,10 @@
43
41
       mUserAgent.AppendLiteral("; ");
44
42
     }
45
43
 #endif
50
48
     if (!mCompatDevice.IsEmpty()) {
51
49
         mUserAgent += mCompatDevice;
52
50
         mUserAgent.AppendLiteral("; ");
53
 
Index: firefox-trunk-43.0~a1~hg20150916r262830/netwerk/protocol/http/nsHttpHandler.h
54
 
===================================================================
55
 
--- firefox-trunk-43.0~a1~hg20150916r262830.orig/netwerk/protocol/http/nsHttpHandler.h  2015-09-17 19:42:31.429286277 +0100
56
 
+++ firefox-trunk-43.0~a1~hg20150916r262830/netwerk/protocol/http/nsHttpHandler.h       2015-09-17 19:42:31.369286096 +0100
57
 
@@ -441,6 +441,7 @@
 
51
--- a/netwerk/protocol/http/nsHttpHandler.h
 
52
+++ b/netwerk/protocol/http/nsHttpHandler.h
 
53
@@ -506,6 +506,7 @@
58
54
     // useragent components
59
55
     nsCString      mLegacyAppName;
60
56
     nsCString      mLegacyAppVersion;
62
58
     nsCString      mPlatform;
63
59
     nsCString      mOscpu;
64
60
     nsCString      mMisc;
65
 
Index: firefox-trunk-43.0~a1~hg20150916r262830/netwerk/protocol/http/Makefile.in
66
 
===================================================================
67
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
68
 
+++ firefox-trunk-43.0~a1~hg20150916r262830/netwerk/protocol/http/Makefile.in   2015-09-17 19:42:31.369286096 +0100
69
 
@@ -0,0 +1,9 @@
70
 
+# This Source Code Form is subject to the terms of the Mozilla Public
71
 
+# License, v. 2.0. If a copy of the MPL was not distributed with this
72
 
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
73
 
+
74
 
+include $(topsrcdir)/config/rules.mk
75
 
+
76
 
+ifdef MOZ_UA_VENDOR
77
 
+DEFINES += -DMOZ_UA_VENDOR=\""$(MOZ_UA_VENDOR)"\"
78
 
+endif
 
61
--- a/old-configure.in
 
62
+++ b/old-configure.in
 
63
@@ -2185,6 +2185,16 @@
 
64
     MOZ_APP_BASENAME="$WITH_APP_BASENAME"
 
65
 fi
 
66
 
 
67
+# Allow someone to add a vendor component to the default user agent string
 
68
+MOZ_ARG_WITH_STRING(ua-vendor,
 
69
+[--with-ua-vendor=VENDOR sets MOZ_UA_VENDOR to VENDOR],
 
70
+WITH_UA_VENDOR=$withval,
 
71
+)
 
72
+
 
73
+if test -n "$WITH_UA_VENDOR" ; then
 
74
+    MOZ_UA_VENDOR="$WITH_UA_VENDOR"
 
75
+fi
 
76
+
 
77
 # Special cases where we need to AC_DEFINE something. Also a holdover for apps
 
78
 # that haven't made a confvars.sh yet. Don't add new stuff here, use
 
79
 # MOZ_BUILD_APP.
 
80
@@ -4744,6 +4754,7 @@
 
81
 AC_SUBST(MOZ_APP_DISPLAYNAME)
 
82
 AC_SUBST(MOZ_APP_BASENAME)
 
83
 AC_SUBST(MOZ_APP_VENDOR)
 
84
+AC_SUBST(MOZ_UA_VENDOR)
 
85
 AC_SUBST(MOZ_APP_PROFILE)
 
86
 AC_SUBST(MOZ_APP_ID)
 
87
 AC_SUBST(MOZ_APP_ANDROID_VERSION_CODE)
 
88
--- a/build/moz.configure/old.configure
 
89
+++ b/build/moz.configure/old.configure
 
90
@@ -278,6 +278,7 @@
 
91
     '--with-system-zlib',
 
92
     '--with-thumb',
 
93
     '--with-thumb-interwork',
 
94
+    '--with-ua-vendor',
 
95
     '--with-unify-dist',
 
96
     '--with-user-appdir',
 
97
     '--x-includes',
 
98
--- a/netwerk/protocol/http/moz.build
 
99
+++ b/netwerk/protocol/http/moz.build
 
100
@@ -138,3 +138,6 @@
 
101
         DEFINES.update(
 
102
             HAS_CONNECTX=True,
 
103
         )
 
104
+
 
105
+if CONFIG['MOZ_UA_VENDOR']:
 
106
+    DEFINES['MOZ_UA_VENDOR'] = '"%s"' % CONFIG['MOZ_UA_VENDOR']