~mozillateam/firefox/firefox.utopic

« back to all changes in this revision

Viewing changes to debian/patches/test-fixes/xpcshell-xunit-output-no-bell.patch

  • Committer: Chris Coulson
  • Date: 2013-05-14 00:25:28 UTC
  • Revision ID: chris.coulson@canonical.com-20130514002528-gwea17pqls10xxy6
* New upstream release from the beta channel (FIREFOX_22_0b1_BUILD1)
* Switch saucy to beta
  - update debian/config/branch.mk
  - update debian/config/locales.shipped
  - refresh debian/control
* Drop the menubar addon
  - remove debian/globalmenu
  - update debian/build/mozbuild.mk
  - update debian/config/mozconfig.in
  - update debian/control.in
  - remove debian/firefox-globalmenu.dirs.in
  - remove debian/firefox-globalmenu.links.in
  - remove debian/patches/unity-globalmenu-build-support.patch
  - add debian/unity-menubar.patch
  - update debian/patches/series.in
* Don't access the network from 395609.xul to see if it fixes a hang
  - add d/p/test-fixes/crashtest-no-network-access.patch
  - update debian/patches/series.in
* Get rid of the autogenerated debian/patches/series, as we don't use
  it now
  - rename debian/patches/series.in => debian/patches/series
  - update debian/build/mozbuild.mk
  - update debian/source/options
* Fix LP: #1158931 by making the testsuite depend on hunspell-en-us
  - update debian/control.in
* Drop unneeded test-integration/mochitest-optional-websock-log.patch
* Stop patching upstream manifests to mark tests as failing, as this is
  too much of a maintenance burden. Instead, post-process the test
  results using our own manifest
  - update debian/patches/series
  - remove d/p/test-overrides/reftest-disable-failing-tests.patch
  - remove d/p/test-overrides/xpcshell-disable-failing-tests.patch
  - update debian/rules
  - update debian/testing/extra/mochitest/mochitest-chrome.json
  - update debian/testing/extra/mochitest/mochitest.json
  - add debian/testing/filter_results
  - update debian/tests/control.in
  - add debian/tests/post-process
  - add debian/testing/results-filter-manifest.json
  - update debian/firefox-testsuite.install.in
* Don't return non-zero exit status from xpcshell test failures, as this
  turns the build red in Jenkins
  - add d/p/test-integration/xpcshell-dont-return-nonzero-on-test-failure.patch
  - update debian/patches/series.in
* Fix testrunhelper.py to work now that libxpcom.so has gone
* Disable some unsupported tests that test search healthreporting, as these
  don't work on Ubuntu where the searchplugins are not in the application
  directory
  - update debian/testing/extra/mochitest/mochitest-chrome.json
* Remove obsolete patches
  - remove debian/patches/fix-makefile-substitution-bug.patch
  - remove debian/patches/gcc-4.7-name-lookup-fixes.patch
  - update debian/patches/series
* Refresh patches
  - update debian/patches/no_neon_on_arm.patch
  - update debian/patches/ubuntu-ua-string-changes.patch
  - update debian/patches/fix-broken-langpack-install-manifests.patch
  - update d/p/test-fixes/xpcshell-xunit-output-no-bell.patch
  - update d/p/test-integration/automation-output-junit-xml.patch
  - update d/p/test-integration/xpcshell-output-valid-junit-xml.patch
  - update d/p/test-overrides/disable-failing-python-tests.patch
* Fix test_langpack_chrome.js for Hindi, Mongolian and Tamil
  - update debian/testing/extra/xpcshell/package-tests/test_langpack_chrome.js
* browser/distribution has moved back up a level
  - update debian/build/rules.mk
  - update debian/firefox-locale.preinst.in
  - update debian/firefox.dirs.in
  - update debian/firefox.install.in
  - update debian/firefox.links.in
  - update debian/firefox.postinst.in
  - update debian/firefox.preinst.in

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: firefox-21.0~a2~hg20130321r128664/testing/xpcshell/runxpcshelltests.py
 
1
Description: Clean the terminal bell character from the test output, as this
 
2
 breaks Jenkins
 
3
Author: Chris Coulson <chris.coulson@canonical.com>
 
4
Forwarded: no
 
5
 
 
6
Index: firefox-trunk-22.0~a1~hg20130314r124794/testing/xpcshell/runxpcshelltests.py
2
7
===================================================================
3
 
--- firefox-21.0~a2~hg20130321r128664.orig/testing/xpcshell/runxpcshelltests.py 2013-03-21 22:18:51.000000000 +0000
4
 
+++ firefox-21.0~a2~hg20130321r128664/testing/xpcshell/runxpcshelltests.py      2013-03-21 22:22:00.835254089 +0000
 
8
--- firefox-trunk-22.0~a1~hg20130314r124794.orig/testing/xpcshell/runxpcshelltests.py   2013-03-15 11:07:36.353751094 +0000
 
9
+++ firefox-trunk-22.0~a1~hg20130314r124794/testing/xpcshell/runxpcshelltests.py    2013-03-15 11:10:15.865757647 +0000
5
10
@@ -538,6 +538,7 @@
6
 
             cdata = ""
 
11
                     cdata = ""
7
12
 
8
 
         cdata = cdata.replace("]]>", "]] >")
9
 
+        cdata = cdata.replace("\x07", "")
10
 
         text = doc.createCDATASection(cdata)
11
 
         failure.appendChild(text)
12
 
         testcase.appendChild(failure)
 
13
                 cdata = cdata.replace("]]>", "]] >")
 
14
+                cdata = cdata.replace("\x07", "")
 
15
                 text = doc.createCDATASection(cdata)
 
16
                 failure.appendChild(text)
 
17
                 testcase.appendChild(failure)