~mozillateam/thunderbird/thunderbird-beta.vivid

« back to all changes in this revision

Viewing changes to debian/patches/add-syspref-dir.patch

  • Committer: Chris Coulson
  • Date: 2012-07-13 21:55:50 UTC
  • Revision ID: chris.coulson@canonical.com-20120713215550-yiifogw5jq3q0cgi
* New upstream release from the beta channel (THUNDERBIRD_14_0b5_BUILD1)
* New upstream release from the beta channel (THUNDERBIRD_14_0b4_BUILD1)
* Update globalmenu-extension to 3.3 prerelease r388
  - Fix LP: #775305 - Use style to determine menuitem visibility
  - Fix LP: #1017247 - Manually register our UA stylesheet rather than
    relying on this happening via chrome registration, to work around a
    bug in various bootstrapped third party addons, which initialize and
    use the stylesheet service before extension chrome is registered for
    non-restartless addons such as ours
  - Fix a crash in uGlobalMenu::RecycleList::~RecycleList()
* Apport hook improvements:
  - Sort preferences alphabetically in the apport data
  - Treat preferences set in default addons as default prefs so that
    they don't show up in apport data, unless the preference files have
    been modified
  - Support random pref files dropped in to the Firefox install folder, and
    preferences from application bundles
  - Fix ordering issues when loading preferences
* Fix LP: #1013171 - Fully support Python 3 in the apport hook
  - update debian/apport/source_firefox.py.in
* Update the Apport blacklist file after dropping thunderbird-bin
  - update debian/apport/blacklist.in
* Update eds extension to 0.3.11 for YAEDSABI (yet another EDS ABI)
* Update eds dependencies for YAEDSABI
  - update debian/rules
* Add partial support for Python 3 in the apport hook (LP: #1013171)
  - update debian/apport/source_firefox.py.in
* Cherry pick patch from aurora to use YARR interpreter on ppc
  - update debian/patches/fix-build-failure-without-yarr-jit.patch
  - update debian/patches/series
* Fix ppc build due to new dtoa library
  - add debian/patches/fix-dtoa-build-on-ppc.patch
  - update debian/patches/series
* debian/apport/source_thunderbird.py.in:
  - Update apport hook for python3
* Add missing file
* New upstream release from the beta channel (THUNDERBIRD_14_0b3_BUILD1)
* Update globalmenu-extension to 3.3 prerelease r369
  - Fix LP: #1010580 - update the window event timestamp when handling
    menu events
  - Fix LP: #775080 - Thunderbird with Firetray/MinimizeToTray -
    Global menu disappears
  - Fix LP: #813775 - Hitting an assertion in dbusmenu
* Update eds extension to 0.3.10 for new evolution-data-server ABI
  (thanks to Tim Gardner)
* Update eds dependencies for quantal (LP: #1015723)
* New upstream release from the beta channel (THUNDERBIRD_14_0b2_BUILD1)
* Switch back to GCC4.7 now that LP: #1003733 is fixed
  - update debian/config/branch.mk
  - update debian/control{,.in}
* Don't set LD_LIBRARY_PATH in our shell wrapper, and install
  dependentlibs.list instead now
  - update debian/thunderbird.sh.in
  - update debian/thunderbird.install.in
* Drop StartupWMClass from the desktop file now that WM_CLASS is the same
  as the binary name (also fixes LP: #1012158)
  - update debian/thunderbird.desktop.in
  - update debian/rules
* New upstream release from the beta channel (THUNDERBIRD_14_0b1_BUILD2)
* Update globalmenu-extension to 3.2.4 prerelease r338
* Drop patches fixed upstream
  - remove debian/patches/revert-bmo621446-investigation.patch
  - update debian/patches/series
* Update desktop file translations
  - update debian/thunderbird.desktop.in
* Ensure that additional actions in the desktop file match the fd.o spec
  in precise
  - update debian/thunderbird.desktop.in
  - update debian/rules
* Add application/x-xpinstall to the MimeType field of the desktop file
  - update debian/thunderbird.desktop.in
* Drop almost all mimetypes from the desktop file. Thunderbird won't display
  any of them if you invoke it with files of these types. It will just 
  open a Compose window and add the file as an attachment
  - update debian/thunderbird.desktop.in
* Drop the ability to select between tree/system libraries using a single
  option in debian/rules. It adds additional complexity and was never used
  - update debian/config/mozconfig.in
  - update debian/control.in
  - update debian/thunderbird-dev.links.in
  - update debian/rules
* Add Catalan keywords
  - update debian/thunderbird.desktop.in

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
 
5
5
Index: mozilla/mozilla/toolkit/xre/nsXREDirProvider.cpp
6
6
===================================================================
7
 
--- mozilla.orig/mozilla/toolkit/xre/nsXREDirProvider.cpp       2011-09-29 00:59:39.000000000 +0100
8
 
+++ mozilla/mozilla/toolkit/xre/nsXREDirProvider.cpp    2011-09-29 10:22:10.700227676 +0100
9
 
@@ -591,6 +591,7 @@
 
7
--- mozilla.orig/mozilla/toolkit/xre/nsXREDirProvider.cpp       2012-04-18 03:11:27.000000000 +0100
 
8
+++ mozilla/mozilla/toolkit/xre/nsXREDirProvider.cpp    2012-04-18 10:45:26.885434464 +0100
 
9
@@ -606,6 +606,7 @@
10
10
 }
11
11
 
12
12
 static const char *const kAppendPrefDir[] = { "defaults", "preferences", nsnull };
14
14
 
15
15
 #ifdef DEBUG_bsmedberg
16
16
 static void
17
 
@@ -632,6 +633,9 @@
18
 
     LoadAppDirIntoArray(mXULAppDir, kAppendPrefDir, directories);
 
17
@@ -647,6 +648,9 @@
 
18
     LoadDirIntoArray(mXULAppDir, kAppendPrefDir, directories);
19
19
     LoadDirsIntoArray(mAppBundleDirectories,
20
20
                       kAppendPrefDir, directories);
21
 
+    LoadAppDirIntoArray(mXULAppDir, kAppendSysPrefDir, directories);
 
21
+    LoadDirIntoArray(mXULAppDir, kAppendSysPrefDir, directories);
22
22
+    LoadDirsIntoArray(mAppBundleDirectories,
23
23
+                      kAppendSysPrefDir, directories);
24
24
 
25
 
     rv = NS_NewArrayEnumerator(aResult, directories);
26
 
   }
 
25
     // Include the WebappRT-specific prefs dir if we're running WebappRT.
 
26
     if (gAppData && !strcmp(gAppData->ID, WEBAPPRT_APPID)) {
27
27
Index: mozilla/mozilla/xpcom/io/nsAppDirectoryServiceDefs.h
28
28
===================================================================
29
 
--- mozilla.orig/mozilla/xpcom/io/nsAppDirectoryServiceDefs.h   2011-09-29 00:59:46.000000000 +0100
30
 
+++ mozilla/mozilla/xpcom/io/nsAppDirectoryServiceDefs.h        2011-09-29 10:22:10.700227676 +0100
 
29
--- mozilla.orig/mozilla/xpcom/io/nsAppDirectoryServiceDefs.h   2012-04-18 03:11:43.000000000 +0100
 
30
+++ mozilla/mozilla/xpcom/io/nsAppDirectoryServiceDefs.h        2012-04-18 10:43:24.269436643 +0100
31
31
@@ -63,6 +63,7 @@
32
32
 
33
33
 #define NS_APP_DEFAULTS_50_DIR                  "DefRt"         // The root dir of all defaults dirs
38
38
 #define NS_APP_PROFILE_DEFAULTS_NLOC_50_DIR     "ProfDefNoLoc"  // The profile defaults of the "default"
39
39
Index: mozilla/mozilla/xpcom/io/nsAppFileLocationProvider.cpp
40
40
===================================================================
41
 
--- mozilla.orig/mozilla/xpcom/io/nsAppFileLocationProvider.cpp 2011-09-29 00:59:46.000000000 +0100
42
 
+++ mozilla/mozilla/xpcom/io/nsAppFileLocationProvider.cpp      2011-09-29 10:22:10.700227676 +0100
 
41
--- mozilla.orig/mozilla/xpcom/io/nsAppFileLocationProvider.cpp 2012-04-18 03:11:43.000000000 +0100
 
42
+++ mozilla/mozilla/xpcom/io/nsAppFileLocationProvider.cpp      2012-04-18 10:43:24.269436643 +0100
43
43
@@ -94,6 +94,7 @@
44
44
 
45
45
 #define DEFAULTS_DIR_NAME           NS_LITERAL_CSTRING("defaults")
66
66
     {
67
67
Index: mozilla/mozilla/modules/libpref/src/Preferences.cpp
68
68
===================================================================
69
 
--- mozilla.orig/mozilla/modules/libpref/src/Preferences.cpp    2011-09-29 10:22:28.616227359 +0100
70
 
+++ mozilla/mozilla/modules/libpref/src/Preferences.cpp 2011-09-29 10:26:43.716222825 +0100
71
 
@@ -1093,6 +1093,15 @@
 
69
--- mozilla.orig/mozilla/modules/libpref/src/Preferences.cpp    2012-04-18 03:09:13.000000000 +0100
 
70
+++ mozilla/mozilla/modules/libpref/src/Preferences.cpp 2012-04-18 10:43:24.269436643 +0100
 
71
@@ -1122,6 +1122,15 @@
72
72
   if (NS_FAILED(rv))
73
73
     NS_WARNING("Error parsing application default preferences.");
74
74
 
82
82
+    NS_WARNING("Error parsing application system preferences.");
83
83
+
84
84
   // Load jar:$app/omni.jar!/defaults/preferences/*.js
85
 
   nsZipArchive *appJarReader = mozilla::Omnijar::GetReader(mozilla::Omnijar::APP);
 
85
   nsRefPtr<nsZipArchive> appJarReader = mozilla::Omnijar::GetReader(mozilla::Omnijar::APP);
86
86
   if (appJarReader) {