~mterry/+junk/gnome-keyring-apparmor

« back to all changes in this revision

Viewing changes to debian/patches/03_kfreebsd.patch

  • Committer: Package Import Robot
  • Author(s): Martin Pitt
  • Date: 2012-01-03 12:49:49 UTC
  • mfrom: (116.1.1 sid)
  • Revision ID: package-import@ubuntu.com-20120103124949-wbal957heafylj4b
* Merge with Debian unstable. Remaining Ubuntu changes:
  - Add debian/gnome-keyring.gsettings-override: Prefer
    keyserver.ubuntu.com.
  - Add debian/gnome-keyring.ubiquity: Apply capabilities at the end of the
    ubiquity process to make sure new installs have gnome-keyring-daemon with
    cap_ipc_lock+ep. Install this in debian/rules.
  - Add 04_nodisplay_autostart.patch: Clean up Startup Applications dialog
    by hiding default apps.
  - debian/watch: Watch for development versions.
* Add 01_gmodule_include.patch: Fix FTBFS due to missing include/wrong
  linking.
* Add 00git_glib_2.31_deprecations.patch: Fix deprecated API for building
  with glib 2.31. Backported from upstream git head. (LP: #911125)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- gnome-keyring-2.28.1-orig/egg/egg-unix-credentials.c        2009-10-18 01:27:22.000000000 +0200
2
 
+++ gnome-keyring-2.28.1/egg/egg-unix-credentials.c     2009-12-07 01:13:17.000000000 +0100
 
1
Index: gnome-keyring-3.2.0/egg/egg-unix-credentials.c
 
2
===================================================================
 
3
--- gnome-keyring-3.2.0.orig/egg/egg-unix-credentials.c 2011-09-15 10:57:03.000000000 +0200
 
4
+++ gnome-keyring-3.2.0/egg/egg-unix-credentials.c      2011-09-29 17:13:54.211741623 +0200
3
5
@@ -37,6 +37,10 @@
4
6
 #include <ucred.h>
5
7
 #endif
38
40
        if (cmsg.hdr.cmsg_len < CMSG_LEN (sizeof *cred) ||
39
41
            cmsg.hdr.cmsg_type != SCM_CREDS) {
40
42
                fprintf (stderr, "message from recvmsg() was not SCM_CREDS\n");
41
 
@@ -119,6 +123,18 @@
 
43
@@ -121,6 +125,18 @@
 
44
                } else {
 
45
                        fprintf (stderr, "failed to getsockopt() credentials, returned len %d/%d\n",
42
46
                                     cr_len, (int) sizeof (cr));
43
 
                        return -1;
44
 
                }
 
47
+                       return -1;
 
48
+               }
45
49
+#elif defined(LOCAL_PEERCRED) /* GNU/kFreeBSD */
46
50
+               struct xucred cr;
47
51
+               socklen_t cr_len = sizeof(cr);
52
56
+               } else {
53
57
+                       fprintf (stderr, "failed to getsockopt() credentials, returned len %d/%d\n",
54
58
+                                    cr_len, (int) sizeof (cr));
55
 
+                       return -1;
56
 
+               }
 
59
                        return -1;
 
60
                }
57
61
 #elif defined(HAVE_CMSGCRED)
58
 
                cred = (struct cmsgcred *) CMSG_DATA (&cmsg.hdr);
59
 
                *pid = cred->cmcred_pid;