~muktupavels/gnome-panel/fix-for-lp-1310929-and-lp-1222339

« back to all changes in this revision

Viewing changes to debian/patches/fix-for-1083811.patch

  • Committer: Package Import Robot
  • Author(s): Jeremy Bicha
  • Date: 2013-06-19 11:49:35 UTC
  • mfrom: (2.1.20 sid)
  • Revision ID: package-import@ubuntu.com-20130619114935-e912mx6nwxecoaib
Tags: 1:3.6.2-0ubuntu7
* Sync with Debian svn (LP: #1185873). Remaining changes:
  - Use epoch
  - Add apport hook
  - debian/control:
    + Recommend indicator-complete
    + Don't depend on nautilus 3.8 yet
  - debian/patches/14_revert_timedate_change.patch:
    + Dropped, we're using timedated
  - debian/patches/40_unset_menuproxy.patch:
    + Make sure gnome-panel and the applets don't pick up menu proxies.
  - debian/patches/41_classic_layout.patch:
    + Change the defaults to be more "classic Ubuntu": Show indicators
      & show desktop, drop GNOME clock & notification area
  - debian/patches/85_disable_shutdown_on_ltsp.patch:
    + Suppress the shutdown option in the panel if LTSP_CLIENT is set.
* debian/patches/50_ubuntu_sessions.patch:
  - Merge patch from gnome-session to split sessions into GNOME Flashback
    (No effects) using Metacity and GNOME Flashback using Compiz
* debian/patches/51_dont_require_nautilus38.patch:
  - Run Flashback without Nautilus 3.8 since it's not in Saucy yet

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
## Description: add some description
2
 
## Origin/Author: add some origin or author
3
 
## Bug: bug URL
4
 
Index: gnome-panel/gnome-panel/panel-toplevel.c
5
 
===================================================================
6
 
--- gnome-panel.orig/gnome-panel/panel-toplevel.c       2012-12-03 23:45:17.737596000 +0200
7
 
+++ gnome-panel/gnome-panel/panel-toplevel.c    2012-12-03 23:54:46.288102218 +0200
8
 
@@ -4455,7 +4455,7 @@
9
 
 {
10
 
        GdkScreen *screen = g_value_get_object (value);
11
 
 
12
 
-       if (!screen || GDK_IS_SCREEN (screen))
13
 
+       if (!screen || !GDK_IS_SCREEN (screen))
14
 
                screen = gdk_screen_get_default ();
15
 
 
16
 
        return g_variant_new ("i", gdk_screen_get_number (screen));
17
 
Index: gnome-panel/libpanel-applet/panel-applet.c
18
 
===================================================================
19
 
--- gnome-panel.orig/libpanel-applet/panel-applet.c     2012-12-03 23:45:17.737596000 +0200
20
 
+++ gnome-panel/libpanel-applet/panel-applet.c  2012-12-04 00:05:24.004103338 +0200
21
 
@@ -1141,6 +1141,8 @@
22
 
        applet = PANEL_APPLET (widget);
23
 
 
24
 
        screen = gtk_widget_get_screen (widget);
25
 
+       
26
 
+       gtk_menu_set_screen(menu, screen);
27
 
 
28
 
        gtk_widget_get_preferred_size (GTK_WIDGET (menu), &requisition, NULL);
29
 
        gdk_window_get_origin (gtk_widget_get_window (widget),