~mvo/gnome-session/run-on-shutdown

« back to all changes in this revision

Viewing changes to debian/patches/20_polkit1.patch

  • Committer: chrisccoulson at ubuntu
  • Date: 2009-07-15 17:55:10 UTC
  • Revision ID: chrisccoulson@ubuntu.com-20090715175510-p0gaduai0gv2lps2
* debian/patches/20_polkit1.patch:
  - Change to not crash in gsm_consolekit_can_{stop,restart}
    functions.

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
# Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=497619
3
3
Index: gnome-session-2.26.2/configure.in
4
4
===================================================================
5
 
--- gnome-session-2.26.2.orig/configure.in      2009-07-14 00:02:47.000000000 +0100
6
 
+++ gnome-session-2.26.2/configure.in   2009-07-14 00:02:47.000000000 +0100
 
5
--- gnome-session-2.26.2.orig/configure.in      2009-07-15 18:37:02.000000000 +0100
 
6
+++ gnome-session-2.26.2/configure.in   2009-07-15 18:37:02.000000000 +0100
7
7
@@ -32,7 +32,7 @@
8
8
 AT_SPI_REGISTRYD_DIR=$with_at_spi_registryd_directory
9
9
 AC_SUBST(AT_SPI_REGISTRYD_DIR)
45
45
 dnl GConf Checks
46
46
Index: gnome-session-2.26.2/gnome-session/gsm-consolekit.c
47
47
===================================================================
48
 
--- gnome-session-2.26.2.orig/gnome-session/gsm-consolekit.c    2009-07-14 00:02:47.000000000 +0100
49
 
+++ gnome-session-2.26.2/gnome-session/gsm-consolekit.c 2009-07-14 00:06:42.000000000 +0100
 
48
--- gnome-session-2.26.2.orig/gnome-session/gsm-consolekit.c    2009-07-15 18:37:02.000000000 +0100
 
49
+++ gnome-session-2.26.2/gnome-session/gsm-consolekit.c 2009-07-15 18:37:47.000000000 +0100
50
50
@@ -31,10 +31,6 @@
51
51
 #include <dbus/dbus-glib.h>
52
52
 #include <dbus/dbus-glib-lowlevel.h>
499
499
                                               G_TYPE_INVALID,
500
500
-                                              /* return values: */
501
501
-                                              G_TYPE_STRING, &type,
502
 
+                                              &can_restart,
 
502
+                                              G_TYPE_BOOLEAN, &can_restart,
503
503
                                               G_TYPE_INVALID);
504
504
 
505
505
-        /* error is bad: we consider there's another user */
728
728
+                                              INT_MAX,
729
729
+                                              error,
730
730
+                                              G_TYPE_INVALID,
731
 
+                                              &can_stop,
 
731
+                                              G_TYPE_BOOLEAN, &can_stop,
732
732
+                                              G_TYPE_INVALID);
733
733
 
734
734
-gboolean
747
747
 gchar *
748
748
Index: gnome-session-2.26.2/gnome-session/Makefile.am
749
749
===================================================================
750
 
--- gnome-session-2.26.2.orig/gnome-session/Makefile.am 2009-07-01 11:25:30.000000000 +0100
751
 
+++ gnome-session-2.26.2/gnome-session/Makefile.am      2009-07-14 00:02:47.000000000 +0100
 
750
--- gnome-session-2.26.2.orig/gnome-session/Makefile.am 2009-07-15 18:28:14.000000000 +0100
 
751
+++ gnome-session-2.26.2/gnome-session/Makefile.am      2009-07-15 18:37:02.000000000 +0100
752
752
@@ -17,7 +17,6 @@
753
753
        $(ICE_CFLAGS)                           \
754
754
        $(GNOME_SESSION_CFLAGS)                 \