~n-muench/ubuntu/maverick/open-vm-tools/open-vm-tools.fix-632101

« back to all changes in this revision

Viewing changes to debian/patches/02-procps.patch

  • Committer: Evan Broder
  • Date: 2010-03-22 15:41:59 UTC
  • mfrom: (2.4.13 sid)
  • Revision ID: broder@mit.edu-20100322154159-qmubu0btz6xkj7ar
Tags: 2010.02.23-236320-1+ubuntu1
* Merge from Debian testing (LP: #543888), remaining changes:
  - Recommend open-vm-toolbox in open-vm-tools.
  - Add support for dkms.
* Fixes building on Lucid kernels (LP: #498677).
* Updating to standards 3.8.4.
* Merging upstream version 2010.02.23-236320.
* Updating year in copyright file.
* Merging upstream version 2010.01.19-226760.
* Correcting plugins handling (Closes: #564069).
* Updating packaging for upstreams vmxnet3 module removal.
* Updating packaging for upstreams test plugin removal.
* Adding explicit debian source version 1.0 until switch to 3.0.
* Merging upstream version 2009.12.16-217847.
* Rediffing kvers.patch.
* Rediffing procps.patch.

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
Description: Don't hardcode procps version.
3
3
 
4
4
diff -Naurp open-vm-tools.orig/configure open-vm-tools/configure
5
 
--- open-vm-tools.orig/configure        2009-05-29 05:25:21.000000000 +0000
6
 
+++ open-vm-tools/configure     2009-06-01 11:01:12.000000000 +0000
7
 
@@ -23019,7 +23019,7 @@ if test "$with_procps" = "yes"; then
8
 
    fi
 
5
--- open-vm-tools.orig/configure        2009-12-18 01:31:04.000000000 +0000
 
6
+++ open-vm-tools/configure     2009-12-20 12:20:47.000000000 +0000
 
7
@@ -24379,7 +24379,7 @@ fi
 
8
    if test "$have_procps" = "no"; then
9
9
 
10
10
 
11
11
-   if test -z "proc-3.2.7"; then
13
13
       { { echo "$as_me:$LINENO: error: 'library' parameter is required.'" >&5
14
14
 echo "$as_me: error: 'library' parameter is required.'" >&2;}
15
15
    { (exit 1); exit 1; }; }
16
 
@@ -23038,7 +23038,7 @@ echo "$as_me: error: 'lvar' parameter is
 
16
@@ -24399,7 +24399,7 @@ echo "$as_me: error: 'lvar' parameter is
17
17
    # First, try any user-defined CUSTOM_* flags.
18
18
    #
19
19
    if test -n "${CUSTOM_PROCPS_CPPFLAGS}" || test -n "${CUSTOM_PROCPS_LIBS}"; then
20
 
-      CUSTOM_PROCPS_LIBS="${CUSTOM_PROCPS_LIBS} -lproc-3.2.7"
21
 
+      CUSTOM_PROCPS_LIBS="${CUSTOM_PROCPS_LIBS} -lproc"
 
20
-      ac_vmw_custom_libs="${CUSTOM_PROCPS_LIBS} -lproc-3.2.7"
 
21
+      ac_vmw_custom_libs="${CUSTOM_PROCPS_LIBS} -lproc"
22
22
       if test -n ""; then
23
23
          ORIGINAL_CPPFLAGS="$CPPFLAGS"
24
24
          CPPFLAGS="${CUSTOM_PROCPS_CPPFLAGS} $CPPFLAGS"
25
 
@@ -23193,14 +23193,14 @@ fi
 
25
@@ -24554,14 +24554,14 @@ fi
26
26
          else
27
27
             ac_vmw_function=strlen
28
28
          fi
36
36
   echo $ECHO_N "(cached) $ECHO_C" >&6
37
37
 else
38
38
   ac_check_lib_save_LIBS=$LIBS
39
 
-LIBS="-lproc-3.2.7 ${CUSTOM_PROCPS_LIBS} $LIBS"
40
 
+LIBS="-lproc ${CUSTOM_PROCPS_LIBS} $LIBS"
 
39
-LIBS="-lproc-3.2.7 $ac_vmw_custom_libs $LIBS"
 
40
+LIBS="-lproc $ac_vmw_custom_libs $LIBS"
41
41
 cat >conftest.$ac_ext <<_ACEOF
42
42
 /* confdefs.h.  */
43
43
 _ACEOF
44
44
diff -Naurp open-vm-tools.orig/configure.ac open-vm-tools/configure.ac
45
 
--- open-vm-tools.orig/configure.ac     2009-05-29 05:25:21.000000000 +0000
46
 
+++ open-vm-tools/configure.ac  2009-06-01 11:00:51.000000000 +0000
47
 
@@ -608,7 +608,7 @@ if test "$with_procps" = "yes"; then
48
 
    if test -z "$CUSTOM_PROCPS_LIBS"; then
49
 
       CUSTOM_PROCPS_LIBS="-L/lib"
50
 
    fi
51
 
-   AC_VMW_CHECK_LIB([proc-3.2.7],
52
 
+   AC_VMW_CHECK_LIB([proc],
53
 
                     [PROCPS],
54
 
                     [],
55
 
                     [],
 
45
--- open-vm-tools.orig/configure.ac     2009-12-18 01:27:53.000000000 +0000
 
46
+++ open-vm-tools/configure.ac  2009-12-20 12:20:52.000000000 +0000
 
47
@@ -664,7 +664,7 @@ if test "$with_procps" = "yes"; then
 
48
                     [])
 
49
 
 
50
    if test "$have_procps" = "no"; then
 
51
-      AC_VMW_CHECK_LIB([proc-3.2.7],
 
52
+      AC_VMW_CHECK_LIB([proc],
 
53
                        [PROCPS],
 
54
                        [],
 
55
                        [],