~nathwill-deactivatedaccount-deactivatedaccount/ubuntu/precise/gnome-control-center/fix-lp-978118

« back to all changes in this revision

Viewing changes to debian/patches/revert_ua_gsettings.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher, Ken VanDine
  • Date: 2012-02-21 22:23:29 UTC
  • mfrom: (1.1.57)
  • Revision ID: package-import@ubuntu.com-20120221222329-moj5n1lsl9kwvapt
Tags: 1:3.3.90-0ubuntu1
* New upstream version:
  - gnome-control-center crashed with SIGSEGV in supply_levels_draw_cb()
    (lp: #903680)
* Refreshed patches for the new version
* debian/control.in:
  - updated g-s-d requirement
* debian/patches/91_configure_cheese.patch:
  - dropped, the fix is in the new version
* debian/source_gnome-control-center.py:
  - don't update the title several times, tag as well 
     
[ Ken VanDine ] 
* debian/patches/96_sound_nua_panel.patch
  - sound-nua: fixed crashers in gtk_tree_model_get_valist() 
    (LP: #931708) and (LP: #932446)
  - sound-nua: fixed a failure in profile selection

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gnome-control-center-3.3.5/panels/universal-access/cc-ua-panel.c
 
1
Index: gnome-control-center-3.3.90/panels/universal-access/cc-ua-panel.c
2
2
===================================================================
3
 
--- gnome-control-center-3.3.5.orig/panels/universal-access/cc-ua-panel.c       2012-01-30 15:13:20.000000000 +0100
4
 
+++ gnome-control-center-3.3.5/panels/universal-access/cc-ua-panel.c    2012-02-15 23:16:10.547706865 +0100
 
3
--- gnome-control-center-3.3.90.orig/panels/universal-access/cc-ua-panel.c      2012-02-20 11:22:59.000000000 +0100
 
4
+++ gnome-control-center-3.3.90/panels/universal-access/cc-ua-panel.c   2012-02-21 13:34:43.707097698 +0100
5
5
@@ -25,10 +25,12 @@
6
6
 #include <config.h>
7
7
 
220
220
   priv->kb_settings = g_settings_new ("org.gnome.desktop.a11y.keyboard");
221
221
   priv->mouse_settings = g_settings_new ("org.gnome.desktop.a11y.mouse");
222
222
   priv->application_settings = g_settings_new ("org.gnome.desktop.a11y.applications");
223
 
Index: gnome-control-center-3.3.5/panels/universal-access/gconf-property-editor.c
 
223
Index: gnome-control-center-3.3.90/panels/universal-access/gconf-property-editor.c
224
224
===================================================================
225
225
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
226
 
+++ gnome-control-center-3.3.5/panels/universal-access/gconf-property-editor.c  2012-02-15 23:16:10.551706865 +0100
 
226
+++ gnome-control-center-3.3.90/panels/universal-access/gconf-property-editor.c 2012-02-21 13:34:43.711097698 +0100
227
227
@@ -0,0 +1,1869 @@
228
228
+/* -*- mode: c; style: linux -*- */
229
229
+
2094
2094
+
2095
2095
+       return peditor;
2096
2096
+}
2097
 
Index: gnome-control-center-3.3.5/panels/universal-access/gconf-property-editor.h
 
2097
Index: gnome-control-center-3.3.90/panels/universal-access/gconf-property-editor.h
2098
2098
===================================================================
2099
2099
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
2100
 
+++ gnome-control-center-3.3.5/panels/universal-access/gconf-property-editor.h  2012-02-15 23:16:10.555706865 +0100
 
2100
+++ gnome-control-center-3.3.90/panels/universal-access/gconf-property-editor.h 2012-02-21 13:34:43.711097698 +0100
2101
2101
@@ -0,0 +1,164 @@
2102
2102
+/* -*- mode: c; style: linux -*- */
2103
2103
+
2263
2263
+G_END_DECLS
2264
2264
+
2265
2265
+#endif /* __GCONF_PROPERTY_EDITOR_H */
2266
 
Index: gnome-control-center-3.3.5/configure.ac
 
2266
Index: gnome-control-center-3.3.90/configure.ac
2267
2267
===================================================================
2268
 
--- gnome-control-center-3.3.5.orig/configure.ac        2012-02-15 23:16:10.527706865 +0100
2269
 
+++ gnome-control-center-3.3.5/configure.ac     2012-02-15 23:16:14.263707046 +0100
 
2268
--- gnome-control-center-3.3.90.orig/configure.ac       2012-02-21 13:34:43.687097697 +0100
 
2269
+++ gnome-control-center-3.3.90/configure.ac    2012-02-21 13:34:45.811097777 +0100
2270
2270
@@ -133,7 +133,7 @@
2271
2271
                   libpulse-mainloop-glib >= $PA_REQUIRED_VERSION
2272
2272
                   gsettings-desktop-schemas >= $SCHEMAS_REQUIRED_VERSION
2273
2273
                   gconf-2.0)
2274
2274
-PKG_CHECK_MODULES(UNIVERSAL_ACCESS_PANEL, $COMMON_MODULES gsettings-desktop-schemas >= $SCHEMAS_REQUIRED_VERSION)
2275
2275
+PKG_CHECK_MODULES(UNIVERSAL_ACCESS_PANEL, $COMMON_MODULES gconf-2.0)
2276
 
 PKG_CHECK_MODULES(USER_ACCOUNTS_PANEL, $COMMON_MODULES dbus-glib-1
 
2276
 PKG_CHECK_MODULES(USER_ACCOUNTS_PANEL, $COMMON_MODULES
2277
2277
                   polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION
2278
2278
                   gnome-desktop-3.0
2279
 
Index: gnome-control-center-3.3.5/panels/universal-access/Makefile.am
 
2279
Index: gnome-control-center-3.3.90/panels/universal-access/Makefile.am
2280
2280
===================================================================
2281
 
--- gnome-control-center-3.3.5.orig/panels/universal-access/Makefile.am 2012-01-30 15:13:20.000000000 +0100
2282
 
+++ gnome-control-center-3.3.5/panels/universal-access/Makefile.am      2012-02-15 23:16:10.559706866 +0100
 
2281
--- gnome-control-center-3.3.90.orig/panels/universal-access/Makefile.am        2012-02-20 11:22:59.000000000 +0100
 
2282
+++ gnome-control-center-3.3.90/panels/universal-access/Makefile.am     2012-02-21 13:34:43.715097698 +0100
2283
2283
@@ -16,6 +16,8 @@
2284
2284
        universal-access-module.c               \
2285
2285
        cc-ua-panel.c                           \