~noskcaj/gnome-settings-daemon/3.14

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu-lid-open-reset-ideletime.patch

  • Committer: Daniel Holbach
  • Date: 2014-05-28 12:42:05 UTC
  • Revision ID: daniel.holbach@canonical.com-20140528124205-nsl4atink1jsxtq9
* Drop all Unity patches and legacy features (LP: #1318539)
  - Keep schemas for background plugin, since they are used by u-s-d
* debian/patches: Refreshed
  - git_new_screencast_keybinding.patch
  - git_xsettings_segfaults.patch
* debian/control.in: Fix lintian warnings
  - gnome-settings-daemon-schemas add ${misc:Depends}
  - gnome-settings-daemon fix binNMUable error for gnome-settings-daemon-schemas
* Bump standards to 3.9.5 (No changes)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Choose a different key to inject to reset the X11 idle time on
2
 
 resume.
3
 
Author: Stephen M. Webb <stephen.webb@canonical.com>
4
 
Bug-Ubuntu: https://bugs.launchpad.net/unity/+bug/1227920
5
 
Forwarded: https://bugzilla.gnome.org/show_bug.cgi?id=710106
6
 
 
7
 
Index: gnome-settings-daemon/plugins/power/gpm-common.c
8
 
===================================================================
9
 
--- gnome-settings-daemon.orig/plugins/power/gpm-common.c       2013-10-11 14:31:10.538433000 -0400
10
 
+++ gnome-settings-daemon/plugins/power/gpm-common.c    2013-10-11 15:05:49.482697946 -0400
11
 
@@ -1667,8 +1667,8 @@
12
 
         static gboolean first_keycode = FALSE;
13
 
 
14
 
         if (inited == FALSE) {
15
 
-                keycode1 = XKeysymToKeycode (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), GDK_KEY_Alt_L);
16
 
-                keycode2 = XKeysymToKeycode (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), GDK_KEY_Alt_R);
17
 
+                keycode1 = XKeysymToKeycode (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), GDK_KEY_Shift_L);
18
 
+                keycode2 = XKeysymToKeycode (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), GDK_KEY_Shift_R);
19
 
         }
20
 
 
21
 
         gdk_error_trap_push ();