~om26er/ubuntu/natty/empathy/empathy-fix-769234

« back to all changes in this revision

Viewing changes to debian/patches/40_unity_launcher_count.patch

  • Committer: Ken VanDine
  • Date: 2011-02-24 18:21:05 UTC
  • Revision ID: ken.vandine@canonical.com-20110224182105-722b8faszc2nzje3
Tags: 2.33.2-0ubuntu1
releasing version 2.33.2-0ubuntu1

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
=== modified file 'configure.ac'
2
 
--- old/configure.ac    2011-02-15 17:12:52 +0000
3
 
+++ new/configure.ac    2011-02-15 17:13:00 +0000
 
2
--- old/configure.ac    2011-02-24 17:06:45 +0000
 
3
+++ new/configure.ac    2011-02-24 17:09:26 +0000
4
4
@@ -58,6 +58,7 @@
5
5
 GNOME_CONTROL_CENTER_GTK3_REQUIRED=2.31.4
6
6
 INDICATE_REQUIRED=0.4.91
7
7
 INDICATE_GTK_REQUIRED=0.4.91
8
8
+UNITY_REQUIRED=3.4.0
9
9
 
10
 
 AC_CONFIG_MACRO_DIR([m4])
11
 
 AC_CONFIG_HEADERS([config.h])
12
 
@@ -468,12 +469,41 @@
 
10
 # telepathy-yell
 
11
 prev_top_build_prefix=$ac_top_build_prefix
 
12
@@ -506,12 +507,41 @@
13
13
 fi
14
14
 
15
15
 if test "x$enable_libindicate" = "xyes" -a "x$have_libindicate" != "xyes"; then
52
52
 # nautilus-sendto
53
53
 # -----------------------------------------------------------
54
54
 AC_ARG_ENABLE(nautilus-sendto,
55
 
@@ -576,6 +606,7 @@
 
55
@@ -614,6 +644,7 @@
56
56
 
57
57
     Features:
58
58
        Message indicator support (libindicate):  ${have_libindicate}
62
62
        Location awareness (Geoclue):  ${have_geoclue}
63
63
 
64
64
=== modified file 'src/Makefile.am'
65
 
--- old/src/Makefile.am 2011-02-15 17:12:08 +0000
66
 
+++ new/src/Makefile.am 2011-02-15 17:13:00 +0000
67
 
@@ -18,6 +18,7 @@
 
65
--- old/src/Makefile.am 2011-02-24 17:04:31 +0000
 
66
+++ new/src/Makefile.am 2011-02-24 17:09:26 +0000
 
67
@@ -19,6 +19,7 @@
68
68
        $(CPPFLAGS_COMMON)                              \
69
69
        $(LIBNOTIFY_CFLAGS)                             \
70
70
        $(INDICATE_CFLAGS)                              \
72
72
        $(UNIQUE_CFLAGS) \
73
73
        $(LIBCHAMPLAIN_CFLAGS)                          \
74
74
        $(WEBKIT_CFLAGS)                                \
75
 
@@ -29,6 +30,7 @@
 
75
@@ -30,6 +31,7 @@
76
76
        $(top_builddir)/extensions/libemp-extensions.la         \
77
77
        $(LIBNOTIFY_LIBS)                                       \
78
78
        $(INDICATE_LIBS)                                        \
80
80
        $(UNIQUE_LIBS)                                          \
81
81
        $(EMPATHY_LIBS)                                         \
82
82
        $(GTK_LIBS)                                             \
83
 
@@ -147,6 +149,7 @@
 
83
@@ -203,6 +205,7 @@
84
84
         $(UNIQUE_LIBS)                                         \
85
85
         $(EMPATHY_LIBS)                                                        \
86
86
        $(INDICATE_LIBS)                                                \
90
90
        $(NULL)
91
91
 
92
92
=== modified file 'src/empathy-chat-window.c'
93
 
--- old/src/empathy-chat-window.c       2011-02-15 17:12:08 +0000
94
 
+++ new/src/empathy-chat-window.c       2011-02-15 19:58:49 +0000
 
93
--- old/src/empathy-chat-window.c       2011-02-24 17:04:31 +0000
 
94
+++ new/src/empathy-chat-window.c       2011-02-24 17:09:26 +0000
95
95
@@ -71,6 +71,10 @@
96
96
 #define DEBUG_FLAG EMPATHY_DEBUG_CHAT
97
97
 #include <libempathy/empathy-debug.h>
113
113
        GtkTargetList *contact_targets;
114
114
        GtkTargetList *file_targets;
115
115
 
116
 
@@ -1304,8 +1311,19 @@
 
116
@@ -1308,8 +1315,19 @@
117
117
                        sender, body);
118
118
                g_signal_connect (indicator, "activate",
119
119
                                  G_CALLBACK (chat_window_indicator_activate_cb), chat);
134
134
        }
135
135
        empathy_indicator_show (indicator);
136
136
 }
137
 
@@ -1322,6 +1340,25 @@
 
137
@@ -1326,6 +1344,25 @@
138
138
                DEBUG ("indicator is %p", indicator);
139
139
                empathy_indicator_hide (indicator);
140
140
                g_hash_table_remove (priv->indicators, chat);
160
160
        } else {
161
161
                DEBUG ("indicator is NULL, nothing to remove");
162
162
        }
163
 
@@ -1955,6 +1992,11 @@
 
163
@@ -1959,6 +1996,11 @@
164
164
                priv->chat_manager = NULL;
165
165
        }
166
166
 
172
172
        chat_windows = g_list_remove (chat_windows, window);
173
173
        gtk_widget_destroy (priv->dialog);
174
174
 
175
 
@@ -2053,6 +2095,9 @@
 
175
@@ -2057,6 +2099,9 @@
176
176
        priv->indicators = g_hash_table_new_full (g_direct_hash, g_direct_equal,
177
177
                              NULL, g_object_unref);
178
178
 #endif
184
184
        gtk_notebook_set_group (GTK_NOTEBOOK (priv->notebook), "EmpathyChatWindow");
185
185
 
186
186
=== modified file 'src/empathy-indicator-manager.c'
187
 
--- old/src/empathy-indicator-manager.c 2011-02-15 17:12:52 +0000
188
 
+++ new/src/empathy-indicator-manager.c 2011-02-15 19:58:35 +0000
 
187
--- old/src/empathy-indicator-manager.c 2011-02-24 17:06:45 +0000
 
188
+++ new/src/empathy-indicator-manager.c 2011-02-24 17:09:26 +0000
189
189
@@ -45,6 +45,10 @@
190
190
 #define DEBUG_FLAG EMPATHY_DEBUG_OTHER
191
191
 #include <libempathy/empathy-debug.h>