~om26er/ubuntu/natty/totem/totem-fix-696171

« back to all changes in this revision

Viewing changes to debian/patches/80_webm.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Ancell
  • Date: 2010-06-25 13:53:18 UTC
  • mfrom: (2.2.16 sid)
  • Revision ID: james.westby@ubuntu.com-20100625135318-ifzregtf3p7vet3o
Tags: 2.30.2-2ubuntu1
* debian/patches/70_bbc_plugin.patch:
  - Fix crash in BBC plugin, thanks Sam Tygier (LP: #563671)
* Merge with Debian unstable, remaining Ubuntu changes:
* debian/control:
  - Build-depend on gnome-common for autotools
  - Don't build using libepc, galago those are in universe
  - Don't use libtracker, the current version is not very useful and not
    something to recommend to users and totem requires a newer version
  - Remove superfluous xulrunner-dev build-depend
  - Build-depend on liblaunchpad-integration-dev
  - Add Vcs-Bzr link
  - totem-plugins doesn't depend on python-gdata since libgdata is used
    instead nowadays
  - Add XB-Npp-Description and XB-Npp-Filename header to the 
    totem-mozilla package to improve ubufox/ubuntu plugin db integration 
  - Change refences from Iceweasel to Firefox
  - Split totem-plugins package in an extra package for the components 
    which have depends in universe
  - Use suggests rather than recommends for universe gstreamer components
  - Add totem-plugins-extra package
* debian/rules:
  - Run autotools on build
* debian/source_totem.py:
  - Apport hook
* debian/totem-common.gconf-defaults: 
  - Activate content retrieval plugins (BBC and YouTube) by default
* debian/totem-common.install:
  - Install apport hook
* debian/totem-plugins-extra.install:
  - Plugins split out ouf totem-plugins
* debian/totem-plugins.install:    
  - Move some plugins to totem-plugins-extra
* debian/totem.preinst:
  - No longer required as Lucid has been released
* debian/patches/02_lpi.patch:
  - Launchpad integration
* debian/patches/07_disable_web_browser_midi.patch:
  - Karmic's version of gstreamer does not support MIDI over HTTP
* debian/patches/70_bbc_plugin.patch:
  - Updated from upstream bug report
* debian/patches/90_autotools.patch:
  - Not required, autotools run from debian/rules
* debian/patches/91_git_correct_rgba_use.patch:
  - git change to fix totem crashing with gtk csd
* debian/watch:
  - Watch for unstable versions

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 2285e792f616f3be400f7eaab51d3a528afe8e68 Mon Sep 17 00:00:00 2001
 
2
From: Bastien Nocera <hadess@hadess.net>
 
3
Date: Thu, 20 May 2010 15:57:42 +0000
 
4
Subject: Add WebM support to Totem and browser plugin
 
5
 
 
6
---
 
7
diff --git a/browser-plugin/totemPlugin.cpp b/browser-plugin/totemPlugin.cpp
 
8
index 5382bb2..1c420f3 100644
 
9
--- a/browser-plugin/totemPlugin.cpp
 
10
+++ b/browser-plugin/totemPlugin.cpp
 
11
@@ -126,6 +126,7 @@ static const totemPluginMimeEntry kMimeTypes[] = {
 
12
   { "audio/mpeg", "mp3", NULL },
 
13
   { "application/x-nsv-vp3-mp3", "nsv", "video/x-nsv" },
 
14
   { "video/flv", "flv", "application/x-flash-video" },
 
15
+  { "video/webm", "webm", NULL },
 
16
   { "application/x-totem-plugin", "", "Totem Multimedia plugin" },
 
17
   { "audio/midi", "mid, midi", NULL },
 
18
 #else
 
19
diff --git a/data/mime-type-list.txt b/data/mime-type-list.txt
 
20
index 303bb23..a6eab04 100644
 
21
--- a/data/mime-type-list.txt
 
22
+++ b/data/mime-type-list.txt
 
23
@@ -82,6 +82,7 @@ video/vivo
 
24
 video/vnd.divx
 
25
 video/vnd.rn-realvideo
 
26
 video/vnd.vivo
 
27
+video/webm
 
28
 video/x-anim
 
29
 video/x-avi
 
30
 video/x-flc
 
31
--
 
32
cgit v0.8.3.1
 
33