~peter-pearse/ubuntu/natty/guile-1.8/prop001

« back to all changes in this revision

Viewing changes to debian/patches/improve-stack-direction-test-2.diff

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2009-06-04 19:01:38 UTC
  • mfrom: (8.1.1 sid)
  • Revision ID: james.westby@ubuntu.com-20090604190138-1ao3t6sj31cqvcfe
Tags: 1.8.6+1-1ubuntu1
* Merge from Debian unstable, remaining changes:
  - Build with -Wno-error.
  - Build with thread support. Some guile-using programs like autogen need it.
  - Add debian/guile-1.8-libs.shlibs: Thread support breaks ABI, bump the soname.
* Dropped changes:
  - libltdl3-dev -> libltdl7-dev: current libltdl-dev Provides: both.
  - debian/patches/libtool-ftbfs.diff: integrated upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Backported version of this original patch:
2
 
 
3
 
From: Neil Jerram <neil@ossau.uklinux.net>
4
 
Date: Thu, 7 Aug 2008 21:24:31 +0000 (+0200)
5
 
Subject: Fix build failure on Debian hppa architecture (bad stack growth detection)
6
 
X-Git-Url: http://git.savannah.gnu.org/gitweb/?p=guile.git;a=commitdiff_plain;h=adacd2dac5ad1c80a8faf8933c228533fb82cc80
7
 
 
8
 
Fix build failure on Debian hppa architecture (bad stack growth detection)
9
 
 
10
 
        * configure.in (SCM_I_GSC_STACK_GROWS_UP): Remove use of
11
 
        AC_CACHE_CHECK, which was inadvertently causing
12
 
        SCM_I_GSC_STACK_GROWS_UP _always_ to be 0.
13
 
 
14
 
Index: sid/ChangeLog
15
 
===================================================================
16
 
--- sid.orig/ChangeLog
17
 
+++ sid/ChangeLog
18
 
@@ -1,3 +1,9 @@
19
 
+2008-08-07  Neil Jerram  <neil@ossau.uklinux.net>
20
 
+
21
 
+       * configure.in (SCM_I_GSC_STACK_GROWS_UP): Remove use of
22
 
+       AC_CACHE_CHECK, which was inadvertently causing
23
 
+       SCM_I_GSC_STACK_GROWS_UP _always_ to be 0.
24
 
+
25
 
 2008-05-07  Ludovic Courtès  <ludo@gnu.org>
26
 
 
27
 
        Guile 1.8.5 released.
28
 
Index: sid/configure.in
29
 
===================================================================
30
 
--- sid.orig/configure.in
31
 
+++ sid/configure.in
32
 
@@ -1115,9 +1115,7 @@
33
 
 #--------------------------------------------------------------------
34
 
 
35
 
 SCM_I_GSC_STACK_GROWS_UP=0
36
 
-AC_CACHE_CHECK([stack direction],
37
 
-              [SCM_I_GSC_STACK_GROWS_UP],
38
 
-[AC_RUN_IFELSE([AC_LANG_SOURCE(
39
 
+AC_RUN_IFELSE([AC_LANG_SOURCE(
40
 
 [AC_INCLUDES_DEFAULT
41
 
 int
42
 
 find_stack_direction ()
43
 
@@ -1140,7 +1138,7 @@
44
 
 }])],
45
 
               [SCM_I_GSC_STACK_GROWS_UP=1],
46
 
               [],
47
 
-              [AC_MSG_WARN(Guessing that stack grows down -- see scmconfig.h)])])
48
 
+              [AC_MSG_WARN(Guessing that stack grows down -- see scmconfig.h)])
49
 
 
50
 
 AC_CHECK_SIZEOF(float)
51
 
 if test "$ac_cv_sizeof_float" -le "$ac_cv_sizeof_long"; then