~peter-pearse/ubuntu/natty/usb-modeswitch/prop001

« back to all changes in this revision

Viewing changes to debian/patches/04_cross.patch

  • Committer: Peter Pearse
  • Date: 2011-04-27 14:37:08 UTC
  • Revision ID: peter.pearse@linaro.org-20110427143708-45nyssqj0up0hr4i
Pass CC & strip program for cross builds.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: usb-modeswitch/Makefile
 
2
===================================================================
 
3
--- usb-modeswitch.orig/Makefile        2011-04-27 14:26:38.000000000 +0000
 
4
+++ usb-modeswitch/Makefile     2011-04-27 14:33:59.000000000 +0000
 
5
@@ -21,8 +21,11 @@
 
6
 clean:
 
7
        $(RM) usb_modeswitch
 
8
 
 
9
+
 
10
+# Allow cross build to override
 
11
+INSTALL_STRIP_ARGS = -s
 
12
 install: all
 
13
-       install -D -s --mode=755 usb_modeswitch $(SBINDIR)/usb_modeswitch
 
14
+       install -D ${INSTALL_STRIP_ARGS} --mode=755 usb_modeswitch $(SBINDIR)/usb_modeswitch
 
15
        install -D --mode=755 usb_modeswitch.tcl $(SBINDIR)/usb_modeswitch_dispatcher
 
16
        install -D --mode=755 usb_modeswitch.sh $(UDEVDIR)/usb_modeswitch
 
17
        install -D --mode=644 usb_modeswitch.conf $(ETCDIR)/usb_modeswitch.conf