~peter-pearse/ubuntu/oneiric/wget/prop001

« back to all changes in this revision

Viewing changes to debian/patches/CVE-2010-2252.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Lorenzo De Liso
  • Date: 2010-11-02 15:17:29 UTC
  • mfrom: (2.1.8 sid)
  • Revision ID: james.westby@ubuntu.com-20101102151729-b6shpzcqo8hpxy9i
Tags: 1.12-2.1ubuntu1
* Merge from debian unstable (LP: #403070), remaining changes:
  - Add wget-udeb to ship wget.gnu as alternative to busybox wget
    implementation.
  - Keep build dependencies in main:
    + debian/control: remove info2man build-dep
    + debian/patches/00list: disable wget-infopod_generated_manpage.dpatch
  - Depend on libssl-dev 0.9.8k-7ubuntu4 (LP: #503339)
* Dropped changes:
  - SECURITY UPDATE: arbitrary file overwrite via 3xx redirect
    + debian/patches/CVE-2010-2252.dpatch: don't use server names in
      doc/wget.texi, src/{http.*,init.c,main.c,options.h,retr.c}.
    + This update changes previous behaviour by ignoring the filename
      supplied by the server during redirects. To re-enable previous
      behaviour, see the new --trust-server-names option.
    + CVE-2010-2252: fixed in debian

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
# Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=590296
6
6
 
7
7
@DPATCH@
8
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget-1.12~/doc/wget.texi wget-1.12/doc/wget.texi
9
 
--- wget-1.12~/doc/wget.texi    2010-09-03 09:18:48.000000000 -0400
10
 
+++ wget-1.12/doc/wget.texi     2010-09-03 09:19:04.000000000 -0400
 
8
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget~/doc/wget.texi wget/doc/wget.texi
 
9
--- wget~/doc/wget.texi 2010-09-05 15:32:44.000000000 +0200
 
10
+++ wget/doc/wget.texi  2010-09-05 15:32:44.000000000 +0200
11
11
@@ -1487,6 +1487,13 @@
12
12
 @code{Content-Disposition} headers to describe what the name of a
13
13
 downloaded file should be.
33
33
 @item continue = on/off
34
34
 If set to on, force continuation of preexistent partially retrieved
35
35
 files.  See @samp{-c} before setting it.
36
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget-1.12~/src/http.c wget-1.12/src/http.c
37
 
--- wget-1.12~/src/http.c       2009-09-21 23:02:18.000000000 -0400
38
 
+++ wget-1.12/src/http.c        2010-09-03 09:19:04.000000000 -0400
 
36
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget~/src/http.c wget/src/http.c
 
37
--- wget~/src/http.c    2010-09-05 15:30:22.000000000 +0200
 
38
+++ wget/src/http.c     2010-09-05 15:32:44.000000000 +0200
39
39
@@ -2410,8 +2410,9 @@
40
40
 /* The genuine HTTP loop!  This is the part where the retrieval is
41
41
    retried, and retried, and retried, and...  */
91
91
 
92
92
               ret = RETROK;
93
93
               goto exit;
94
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget-1.12~/src/http.h wget-1.12/src/http.h
95
 
--- wget-1.12~/src/http.h       2009-09-04 12:31:54.000000000 -0400
96
 
+++ wget-1.12/src/http.h        2010-09-03 09:19:04.000000000 -0400
 
94
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget~/src/http.h wget/src/http.h
 
95
--- wget~/src/http.h    2010-09-05 15:30:22.000000000 +0200
 
96
+++ wget/src/http.h     2010-09-05 15:32:44.000000000 +0200
97
97
@@ -33,8 +33,8 @@
98
98
 
99
99
 struct url;
105
105
 void save_cookies (void);
106
106
 void http_cleanup (void);
107
107
 time_t http_atotm (const char *);
108
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget-1.12~/src/init.c wget-1.12/src/init.c
109
 
--- wget-1.12~/src/init.c       2009-09-21 23:02:41.000000000 -0400
110
 
+++ wget-1.12/src/init.c        2010-09-03 09:19:04.000000000 -0400
 
108
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget~/src/init.c wget/src/init.c
 
109
--- wget~/src/init.c    2010-09-05 15:30:22.000000000 +0200
 
110
+++ wget/src/init.c     2010-09-05 15:32:44.000000000 +0200
111
111
@@ -243,6 +243,7 @@
112
112
   { "timeout",          NULL,                   cmd_spec_timeout },
113
113
   { "timestamping",     &opt.timestamping,      cmd_boolean },
116
116
   { "useproxy",         &opt.use_proxy,         cmd_boolean },
117
117
   { "user",             &opt.user,              cmd_string },
118
118
   { "useragent",        NULL,                   cmd_spec_useragent },
119
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget-1.12~/src/main.c wget-1.12/src/main.c
120
 
--- wget-1.12~/src/main.c       2009-09-21 23:03:11.000000000 -0400
121
 
+++ wget-1.12/src/main.c        2010-09-03 09:19:04.000000000 -0400
 
119
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget~/src/main.c wget/src/main.c
 
120
--- wget~/src/main.c    2010-09-05 15:30:22.000000000 +0200
 
121
+++ wget/src/main.c     2010-09-05 15:32:44.000000000 +0200
122
122
@@ -266,6 +266,7 @@
123
123
     { "timeout", 'T', OPT_VALUE, "timeout", -1 },
124
124
     { "timestamping", 'N', OPT_BOOLEAN, "timestamping", -1 },
136
136
   -X,  --exclude-directories=LIST  list of excluded directories.\n"),
137
137
     N_("\
138
138
   -np, --no-parent                 don't ascend to the parent directory.\n"),
139
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget-1.12~/src/options.h wget-1.12/src/options.h
140
 
--- wget-1.12~/src/options.h    2009-09-21 23:03:47.000000000 -0400
141
 
+++ wget-1.12/src/options.h     2010-09-03 09:19:04.000000000 -0400
 
139
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget~/src/options.h wget/src/options.h
 
140
--- wget~/src/options.h 2010-09-05 15:30:22.000000000 +0200
 
141
+++ wget/src/options.h  2010-09-05 15:32:44.000000000 +0200
142
142
@@ -242,6 +242,7 @@
143
143
   char *encoding_remote;
144
144
   char *locale;
147
147
 #ifdef __VMS
148
148
   int ftp_stmlf;                /* Force Stream_LF format for binary FTP. */
149
149
 #endif /* def __VMS */
150
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget-1.12~/src/retr.c wget-1.12/src/retr.c
151
 
--- wget-1.12~/src/retr.c       2009-09-04 12:31:54.000000000 -0400
152
 
+++ wget-1.12/src/retr.c        2010-09-03 09:19:04.000000000 -0400
 
150
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' wget~/src/retr.c wget/src/retr.c
 
151
--- wget~/src/retr.c    2010-09-05 15:30:22.000000000 +0200
 
152
+++ wget/src/retr.c     2010-09-05 15:32:44.000000000 +0200
153
153
@@ -689,7 +689,8 @@
154
154
 #endif
155
155
       || (proxy_url && proxy_url->scheme == SCHEME_HTTP))