~pirabarlen-cheenaramen/ubuntu/wily/nagios-plugins/crypto-fix

« back to all changes in this revision

Viewing changes to debian/patches/03_check_smtp_help.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Chuck Short
  • Date: 2010-05-10 15:02:18 UTC
  • mfrom: (12.1.6 sid)
  • Revision ID: james.westby@ubuntu.com-20100510150218-fzjeicfgpfmrik29
Tags: 1.4.14-5ubuntu1
* Merge from debian unstable.  Remaining changes:
  - debian/control: keep on building with libradius1-dev to avoid pusing radiusclient-ng
    to main.
  - Don't depend on nagios-plugins-extra, we dont need qstat and fping in main.
  - debian/{control,rules}: add an enable hardened build for PIE.
    (Debian bug 542728).
  - Build with libmysqlclient-dev only. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 01_check_smtp_help.dpatch by Jan Wagner <waja@cyconet.org>
 
3
##
 
4
## DP: Add -F to help output (bugs.debian.org/578333)
 
5
## DP: Upstream bug is: https://sourceforge.net/tracker/?func=detail&aid=2989193&group_id=29880&atid=397597
 
6
 
 
7
@DPATCH@
 
8
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' nagios-plugins-1.4.14~/plugins/check_smtp.c nagios-plugins-1.4.14/plugins/check_smtp.c
 
9
--- nagios-plugins-1.4.14~/plugins/check_smtp.c 2009-06-06 09:04:49.000000000 +0200
 
10
+++ nagios-plugins-1.4.14/plugins/check_smtp.c  2010-04-19 10:54:02.000000000 +0200
 
11
@@ -782,6 +782,8 @@
 
12
   printf ("    %s\n", _("Expected response to command (may be used repeatedly)"));
 
13
   printf (" %s\n", "-f, --from=STRING");
 
14
   printf ("    %s\n", _("FROM-address to include in MAIL command, required by Exchange 2000")),
 
15
+  printf (" %s\n", "-F, --fqdn=STRING");
 
16
+  printf ("    %s\n", _("FQDN used for HELO"));
 
17
 #ifdef HAVE_SSL
 
18
   printf (" %s\n", "-D, --certificate=INTEGER");
 
19
   printf ("    %s\n", _("Minimum number of days a certificate has to be valid."));
 
20
@@ -823,8 +825,8 @@
 
21
 print_usage (void)
 
22
 {
 
23
   printf (_("Usage:"));
 
24
-       printf ("%s -H host [-p port] [-e expect] [-C command] [-f from addr]", progname);
 
25
+  printf ("%s -H host [-p port] [-e expect] [-C command] [-f from addr]\n", progname);
 
26
   printf ("[-A authtype -U authuser -P authpass] [-w warn] [-c crit] [-t timeout]\n");
 
27
-  printf ("[-S] [-D days] [-v] [-4|-6]\n");
 
28
+  printf ("[-F fqdn] [-S] [-D days] [-v] [-4|-6]\n");
 
29
 }
 
30