~psusi/ubuntu/utopic/udisks2/fix-standby

« back to all changes in this revision

Viewing changes to debian/patches/00git_firewire_removable.patch

  • Committer: Package Import Robot
  • Author(s): Martin Pitt
  • Date: 2013-03-26 08:31:00 UTC
  • mfrom: (14.1.3 experimental)
  • Revision ID: package-import@ubuntu.com-20130326083100-w7isex7ct7tf7q09
* debian/rules: Call dh_girepository to get correct dependencies of
  gir1.2-udisks-2.0.
* Add 00git_firewire_removable.patch: Properly identify firewire devices as
  non-system devices.
* Add 00git_hide_smartware_partitions.patch: Fix hiding of "WD SmartWare"
  partitions. (LP: #732365)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From b841e30a98459816dfc49a735d3db4355a88edcd Mon Sep 17 00:00:00 2001
 
2
From: David Zeuthen <zeuthen@gmail.com>
 
3
Date: Mon, 18 Mar 2013 21:31:40 -0700
 
4
Subject: Properly identify firewire devices as non-system devices
 
5
 
 
6
This was reported in bug 62077.
 
7
 
 
8
https://bugs.freedesktop.org/show_bug.cgi?id=62077
 
9
 
 
10
Signed-off-by: David Zeuthen <zeuthen@gmail.com>
 
11
---
 
12
 src/udiskslinuxblock.c | 2 +-
 
13
 1 file changed, 1 insertion(+), 1 deletion(-)
 
14
 
 
15
diff --git a/src/udiskslinuxblock.c b/src/udiskslinuxblock.c
 
16
index a1781cf..d619850 100644
 
17
--- a/src/udiskslinuxblock.c
 
18
+++ b/src/udiskslinuxblock.c
 
19
@@ -354,7 +354,7 @@ update_hints (UDisksLinuxBlock  *block,
 
20
       connection_bus = udisks_drive_get_connection_bus (drive);
 
21
       removable = udisks_drive_get_media_removable (drive);
 
22
       if (removable ||
 
23
-          (g_strcmp0 (connection_bus, "usb") == 0 || g_strcmp0 (connection_bus, "firewire") == 0) ||
 
24
+          (g_strcmp0 (connection_bus, "usb") == 0 || g_strcmp0 (connection_bus, "ieee1394") == 0) ||
 
25
           (g_str_has_prefix (device_file, "/dev/mmcblk") || g_str_has_prefix (device_file, "/dev/mspblk")))
 
26
         {
 
27
           hint_system = FALSE;
 
28
-- 
 
29
1.8.1.2
 
30