~saltmakrell/launchpad/fixtiles-osm-gps-map

« back to all changes in this revision

Viewing changes to debian/patches/01_correct-python-package-location-configure.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): David Paleino
  • Date: 2010-01-23 18:01:56 UTC
  • mfrom: (0.1.3 squeeze) (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20100123180156-g9bge7mrrx4j10lz
Tags: 0.5-1
* New upstream release
  - fixed missing #include in src/osm-gps-map.c (Closes: #564907)
* debian/patches/:
  - 02-fix_python_library_linking.patch removed, fixed upstream
* debian/python-osmgpsmap.examples updated
* debian/rules: don't remove COPYING on clean
* debian/libosmgpsmap0.symbols updated

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01_correct-python-package-location-configure.dpatch by Andrew Gee <andrew@andrewgee.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Working python/configure for dist-packages python modules location
6
 
## DP: Generated from changes from 02_correct-python-package-location-aclocal.dpatch
7
 
 
8
 
@DPATCH@
9
 
diff -urNad osm-gps-map-0.2~/python/configure osm-gps-map-0.2/python/configure
10
 
--- osm-gps-map-0.2~/python/configure   2009-01-29 08:42:55.000000000 +0000
11
 
+++ osm-gps-map-0.2/python/configure    2009-07-01 14:10:42.000000000 +0100
12
 
@@ -11778,7 +11778,13 @@
13
 
 if test "${am_cv_python_pythondir+set}" = set; then
14
 
   echo $ECHO_N "(cached) $ECHO_C" >&6
15
 
 else
16
 
-  am_cv_python_pythondir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(0,0,prefix='$PYTHON_PREFIX')" 2>/dev/null ||
17
 
+  if test "x$prefix" = xNONE
18
 
+     then
19
 
+       py_prefix_arg=
20
 
+     else
21
 
+       py_prefix_arg=",prefix='$prefix'"
22
 
+     fi
23
 
+     am_cv_python_pythondir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(0,0$py_prefix_arg)" -n -q install $py_prefix_arg 2>/dev/null ||
24
 
      echo "$PYTHON_PREFIX/lib/python$PYTHON_VERSION/site-packages"`
25
 
 fi
26
 
 { echo "$as_me:$LINENO: result: $am_cv_python_pythondir" >&5
27
 
@@ -11795,8 +11801,14 @@
28
 
 if test "${am_cv_python_pyexecdir+set}" = set; then
29
 
   echo $ECHO_N "(cached) $ECHO_C" >&6
30
 
 else
31
 
-  am_cv_python_pyexecdir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(1,0,prefix='$PYTHON_EXEC_PREFIX')" 2>/dev/null ||
32
 
-     echo "${PYTHON_EXEC_PREFIX}/lib/python${PYTHON_VERSION}/site-packages"`
33
 
+  if test "x$exec_prefix" = xNONE
34
 
+     then
35
 
+       py_exec_prefix_arg=$py_prefix_arg
36
 
+     else
37
 
+       py_exec_prefix_arg=",prefix='$exec_prefix'"
38
 
+     fi
39
 
+     am_cv_python_pyexecdir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(1,0$py_exec_prefix_arg)" -n -q install $py_exec_prefix_arg 2>/dev/null ||
40
 
+     echo "$PYTHON_EXEC_PREFIX/lib/python$PYTHON_VERSION/site-packages"`
41
 
 fi
42
 
 { echo "$as_me:$LINENO: result: $am_cv_python_pyexecdir" >&5
43
 
 echo "${ECHO_T}$am_cv_python_pyexecdir" >&6; }