~serge-hallyn/ubuntu/natty/lxc/lxc-fix-3bugs

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-0.7.2-1

  • Committer: Bazaar Package Importer
  • Author(s): Guido Trotter
  • Date: 2010-08-04 13:23:42 UTC
  • mfrom: (1.1.5 upstream) (3.1.6 sid)
  • Revision ID: james.westby@ubuntu.com-20100804132342-ds4lm3oaroeoxfxx
Tags: 0.7.2-1
* New upstream version
* Convert libcap dependency to versioned (closes: #571527)
* Bump up standards version to 3.9.0
* Fix too-deep /usr/lib/lxc/lxc path (closes: #587847)
* Add init script (closes: #573830)
  Thanks to Przemysław Knycz <pknycz@kolnet.eu> for the base example
* Bump up standards version (3.9.1)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Upstream changes introduced in version 0.7.2-1
 
2
 This patch has been created by dpkg-source during the package build.
 
3
 Here's the last changelog entry, hopefully it gives details on why
 
4
 those changes were made:
 
5
 .
 
6
 lxc (0.7.2-1) unstable; urgency=low
 
7
 .
 
8
   * New upstream version
 
9
   * Convert libcap dependency to versioned (closes: #571527)
 
10
   * Bump up standards version to 3.9.0
 
11
   * Fix too-deep /usr/lib/lxc/lxc path (closes: #587847)
 
12
   * Add init script (closes: #573830)
 
13
     Thanks to Przemysław Knycz <pknycz@kolnet.eu> for the base example
 
14
   * Bump up standards version (3.9.1)
 
15
 .
 
16
 The person named in the Author field signed this changelog entry.
 
17
Author: Guido Trotter <ultrotter@debian.org>
 
18
Bug-Debian: http://bugs.debian.org/571527
 
19
Bug-Debian: http://bugs.debian.org/573830
 
20
Bug-Debian: http://bugs.debian.org/587847
 
21
 
 
22
---
 
23
The information above should follow the Patch Tagging Guidelines, please
 
24
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
 
25
are templates for supplementary fields that you might want to add:
 
26
 
 
27
Origin: <vendor|upstream|other>, <url of original patch>
 
28
Bug: <url in upstream bugtracker>
 
29
Bug-Debian: http://bugs.debian.org/<bugnumber>
 
30
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
 
31
Forwarded: <no|not-needed|url proving that it has been forwarded>
 
32
Reviewed-By: <name and email of someone who approved the patch>
 
33
Last-Update: <YYYY-MM-DD>
 
34
 
 
35
--- lxc-0.7.2.orig/configure.ac
 
36
+++ lxc-0.7.2/configure.ac
 
37
@@ -56,8 +56,8 @@ AS_AC_EXPAND(LXC_GENERATE_DATE, "$(date)
 
38
 
 
39
 AS_AC_EXPAND(LXCPATH, "${with_config_path}")
 
40
 AS_AC_EXPAND(LXCROOTFSMOUNT, "${with_rootfs_path}")
 
41
-AS_AC_EXPAND(LXCINITDIR, $libdir/lxc)
 
42
-AS_AC_EXPAND(LXCTEMPLATEDIR, $libdir/lxc/templates)
 
43
+AS_AC_EXPAND(LXCINITDIR, $libdir)
 
44
+AS_AC_EXPAND(LXCTEMPLATEDIR, $libdir/templates)
 
45
 AH_TEMPLATE([LXCPATH], [lxc configuration repository])
 
46
 AH_TEMPLATE([LXCINITDIR], [lxc-init directory location])
 
47
 AH_TEMPLATE([LXCROOTFSMOUNT], [lxc default rootfs mount point])
 
48
--- lxc-0.7.2.orig/configure
 
49
+++ lxc-0.7.2/configure
 
50
@@ -4702,7 +4702,7 @@ fi
 
51
 
 
52
 
 
53
     EXP_VAR=LXCINITDIR
 
54
-    FROM_VAR=$libdir/lxc
 
55
+    FROM_VAR=$libdir
 
56
 
 
57
         prefix_save=$prefix
 
58
     exec_prefix_save=$exec_prefix
 
59
@@ -4730,7 +4730,7 @@ fi
 
60
 
 
61
 
 
62
     EXP_VAR=LXCTEMPLATEDIR
 
63
-    FROM_VAR=$libdir/lxc/templates
 
64
+    FROM_VAR=$libdir/templates
 
65
 
 
66
         prefix_save=$prefix
 
67
     exec_prefix_save=$exec_prefix
 
68
--- lxc-0.7.2.orig/src/lxc/Makefile.am
 
69
+++ lxc-0.7.2/src/lxc/Makefile.am
 
70
@@ -14,6 +14,7 @@ pkginclude_HEADERS = \
 
71
                state.h
 
72
 
 
73
 sodir=$(libdir)
 
74
+pkglibdir = $(libdir)
 
75
 # use PROGRAMS to avoid complains from automake
 
76
 so_PROGRAMS = liblxc.so
 
77
 
 
78
--- lxc-0.7.2.orig/src/lxc/Makefile.in
 
79
+++ lxc-0.7.2/src/lxc/Makefile.in
 
80
@@ -20,7 +20,6 @@
 
81
 VPATH = @srcdir@
 
82
 pkgdatadir = $(datadir)/@PACKAGE@
 
83
 pkgincludedir = $(includedir)/@PACKAGE@
 
84
-pkglibdir = $(libdir)/@PACKAGE@
 
85
 pkglibexecdir = $(libexecdir)/@PACKAGE@
 
86
 am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
 
87
 install_sh_DATA = $(install_sh) -c -m 644
 
88
@@ -197,6 +196,7 @@ HEADERS = $(pkginclude_HEADERS)
 
89
 ETAGS = etags
 
90
 CTAGS = ctags
 
91
 DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
 
92
+pkglibdir = $(libdir)
 
93
 ACLOCAL = @ACLOCAL@
 
94
 AMTAR = @AMTAR@
 
95
 AUTOCONF = @AUTOCONF@