~serge-hallyn/ubuntu/natty/lxc/lxc-fix-3bugs

« back to all changes in this revision

Viewing changes to debian/patches/0001-fix-too-deep-lib-dir.patch

  • Committer: Bazaar Package Importer
  • Author(s): Guido Trotter
  • Date: 2010-12-06 16:24:31 UTC
  • mfrom: (1.1.6 upstream) (3.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20101206162431-lvg92fyuiupfoqek
Tags: 0.7.3-1
* New upstream version (closes: #602631)
  - Support for specifying debian suite (closes: #600459)
  - Support for declaring a different architecture (closes: #597875)
* Fix restart init.d action sequence (closes: #597998)
* Move too-deep /usr/lib/lxc/lxc path to a proper patch
* Disable checkroot script in debian template (closes: #601001)
* Create missing tty devices under squeeze (closes: #600466)
* Restore bindmount functionality in newer kernels (closes: #604475)
* Make debian mirror configurable (closes: #601422)
* Default to cdn.debian.net as a debian mirror (closes: #600464)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Guido Trotter <ultrotter@debian.org>
 
2
Date: Mon, 6 Dec 2010 15:41:43 +0100
 
3
Subject: [PATCH] fix-too-deep-lib-dir
 
4
 
 
5
---
 
6
 configure           |    4 ++--
 
7
 configure.ac        |    4 ++--
 
8
 src/lxc/Makefile.am |    1 +
 
9
 src/lxc/Makefile.in |    2 +-
 
10
 4 files changed, 6 insertions(+), 5 deletions(-)
 
11
 
 
12
diff --git a/configure b/configure
 
13
index 92858d7..8c78a80 100755
 
14
--- a/configure
 
15
+++ b/configure
 
16
@@ -4702,7 +4702,7 @@ fi
 
17
 
 
18
 
 
19
     EXP_VAR=LXCINITDIR
 
20
-    FROM_VAR=$libdir/lxc
 
21
+    FROM_VAR=$libdir
 
22
 
 
23
         prefix_save=$prefix
 
24
     exec_prefix_save=$exec_prefix
 
25
@@ -4730,7 +4730,7 @@ fi
 
26
 
 
27
 
 
28
     EXP_VAR=LXCTEMPLATEDIR
 
29
-    FROM_VAR=$libdir/lxc/templates
 
30
+    FROM_VAR=$libdir/templates
 
31
 
 
32
         prefix_save=$prefix
 
33
     exec_prefix_save=$exec_prefix
 
34
diff --git a/configure.ac b/configure.ac
 
35
index ec3ec13..d508573 100644
 
36
--- a/configure.ac
 
37
+++ b/configure.ac
 
38
@@ -56,8 +56,8 @@ AS_AC_EXPAND(LXC_GENERATE_DATE, "$(date)")
 
39
 
 
40
 AS_AC_EXPAND(LXCPATH, "${with_config_path}")
 
41
 AS_AC_EXPAND(LXCROOTFSMOUNT, "${with_rootfs_path}")
 
42
-AS_AC_EXPAND(LXCINITDIR, $libdir/lxc)
 
43
-AS_AC_EXPAND(LXCTEMPLATEDIR, $libdir/lxc/templates)
 
44
+AS_AC_EXPAND(LXCINITDIR, $libdir)
 
45
+AS_AC_EXPAND(LXCTEMPLATEDIR, $libdir/templates)
 
46
 AH_TEMPLATE([LXCPATH], [lxc configuration repository])
 
47
 AH_TEMPLATE([LXCINITDIR], [lxc-init directory location])
 
48
 AH_TEMPLATE([LXCROOTFSMOUNT], [lxc default rootfs mount point])
 
49
diff --git a/src/lxc/Makefile.am b/src/lxc/Makefile.am
 
50
index d2ee4d9..f3f03db 100644
 
51
--- a/src/lxc/Makefile.am
 
52
+++ b/src/lxc/Makefile.am
 
53
@@ -14,6 +14,7 @@ pkginclude_HEADERS = \
 
54
                state.h
 
55
 
 
56
 sodir=$(libdir)
 
57
+pkglibdir = $(libdir)
 
58
 # use PROGRAMS to avoid complains from automake
 
59
 so_PROGRAMS = liblxc.so
 
60
 
 
61
diff --git a/src/lxc/Makefile.in b/src/lxc/Makefile.in
 
62
index 16c38b0..942ce4c 100644
 
63
--- a/src/lxc/Makefile.in
 
64
+++ b/src/lxc/Makefile.in
 
65
@@ -20,7 +20,6 @@
 
66
 VPATH = @srcdir@
 
67
 pkgdatadir = $(datadir)/@PACKAGE@
 
68
 pkgincludedir = $(includedir)/@PACKAGE@
 
69
-pkglibdir = $(libdir)/@PACKAGE@
 
70
 pkglibexecdir = $(libexecdir)/@PACKAGE@
 
71
 am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
 
72
 install_sh_DATA = $(install_sh) -c -m 644
 
73
@@ -198,6 +197,7 @@ HEADERS = $(pkginclude_HEADERS)
 
74
 ETAGS = etags
 
75
 CTAGS = ctags
 
76
 DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
 
77
+pkglibdir = $(libdir)
 
78
 ACLOCAL = @ACLOCAL@
 
79
 AMTAR = @AMTAR@
 
80
 AUTOCONF = @AUTOCONF@
 
81
--