~serge-hallyn/ubuntu/raring/shadow/shadow-userns

« back to all changes in this revision

Viewing changes to debian/patches/userns/13_subordinate_parse_static_buf

  • Committer: Serge Hallyn
  • Date: 2013-02-05 03:40:17 UTC
  • Revision ID: serge.hallyn@canonical.com-20130205034017-juql9us0tsdme9e2
* userns/12_userns_selinuxlibs: fix FTBFS (provided debian/rules actually
  does autoconf - otherwise we'll have to do that manually before upload)
* userns/13_subordinate_parse_static_buf: bugfix from Eric.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: subordinateio: Fix subordinate_parse to have an internal static buffer
 
2
 subordinate_parse is supposed to return a static structure that
 
3
 represents one line in /etc/subuid or /etc/subgid.  I goofed and
 
4
 failed to make the variable rangebuf that holds the username of
 
5
 in the returned structure static.
 
6
 .
 
7
 Add this missing static specification.
 
8
Author: <Eric W. Biederman" <ebiederm@xmission.com>
 
9
Origin: upstream
 
10
Forwarded: no
 
11
Index: shadow-4.1.5.1/lib/subordinateio.c
 
12
===================================================================
 
13
--- shadow-4.1.5.1.orig/lib/subordinateio.c     2013-02-04 11:56:40.265335433 -0600
 
14
+++ shadow-4.1.5.1/lib/subordinateio.c  2013-02-04 12:32:46.653298752 -0600
 
15
@@ -48,7 +48,7 @@
 
16
 static void *subordinate_parse (const char *line)
 
17
 {
 
18
        static struct subordinate_range range;
 
19
-       char rangebuf[1024];
 
20
+       static char rangebuf[1024];
 
21
        int i;
 
22
        char *cp;
 
23
        char *fields[NFIELDS];