~serge-hallyn/ubuntu/raring/spice/spice-compiler-warnings

« back to all changes in this revision

Viewing changes to debian/patches/build-automated-tests

  • Committer: Serge Hallyn
  • Date: 2013-02-02 18:46:09 UTC
  • Revision ID: serge.hallyn@canonical.com-20130202184609-bwvlb42c8bhq9jic
Build and run the one automated testcase - test_display_streaming.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Build automated test
 
2
 The testcases are (as acknowledged on the spice homepage) are for the most
 
3
 part a big to-do.  However there is one testcase which build and runs.  It
 
4
 does not require snappy to run, and none of the testcases actually need
 
5
 snappy to build.  So always add -DAUTOMATED_TESTS to the build flags, and
 
6
 add a 'make check' target which will be run during package build, which
 
7
 runs the automated testcase.
 
8
Author: Serge Hallyn <serge.hallyn@ubuntu.com>
 
9
Forwarded: no
 
10
 
 
11
Index: spice/server/tests/Makefile.am
 
12
===================================================================
 
13
--- spice.orig/server/tests/Makefile.am 2013-02-01 14:24:08.683413000 -0600
 
14
+++ spice/server/tests/Makefile.am      2013-02-02 12:41:57.960424928 -0600
 
15
@@ -10,9 +10,7 @@
 
16
        $(SPICE_NONPKGCONFIG_CFLAGS)            \
 
17
        $(NULL)
 
18
 
 
19
-if SUPPORT_AUTOMATED_TESTS
 
20
 INCLUDES += -DAUTOMATED_TESTS
 
21
-endif
 
22
 
 
23
 LDADD =                                                                \
 
24
        $(top_builddir)/spice-common/common/libspice-common.la  \
 
25
@@ -90,4 +88,5 @@
 
26
        test_two_servers.c                      \
 
27
        $(NULL)
 
28
 
 
29
-
 
30
+check:
 
31
+       ./test_display_streaming --automated-tests