~timo-jyrinki/ubuntu/trusty/maliit-framework/fix_qt52

« back to all changes in this revision

Viewing changes to debian/patches/0001-rename_input_context.patch

  • Committer: Package Import Robot
  • Author(s): Ricardo Salveti de Araujo, Sergio Schvezov, Ricardo Salveti de Araujo
  • Date: 2013-07-23 19:47:04 UTC
  • mfrom: (1.1.2) (1.2.1 experimental)
  • Revision ID: package-import@ubuntu.com-20130723194704-1lsy1kmlda069cea
Tags: 0.99.0+git20130615+97e8335-0ubuntu1
[ Sergio Schvezov ]
* New build from HEAD 97e8335.
* Packaging import from lp:phablet-extras/maliit-framework.

[ Ricardo Salveti de Araujo ]
* debian/control: adding vcs and fixing dependencies
* General package cleanup

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Thomas Moenicke <thomas.moenicke@canonical.com>
 
2
Subject: Renaming plugin to not conflict with the one provided by Qt
 
3
Forwarded: no
 
4
 
 
5
Index: maliit-framework-0.99+git20130702+97e8335/input-context/input-context.pro
 
6
===================================================================
 
7
--- maliit-framework-0.99+git20130702+97e8335.orig/input-context/input-context.pro      2013-07-16 09:57:37.000000000 +0000
 
8
+++ maliit-framework-0.99+git20130702+97e8335/input-context/input-context.pro   2013-07-16 09:57:37.000000000 +0000
 
9
@@ -5,7 +5,7 @@
 
10
 QT += dbus gui-private quick
 
11
 TEMPLATE = lib
 
12
 CONFIG += plugin
 
13
-TARGET = maliitplatforminputcontextplugin
 
14
+TARGET = maliitphabletplatforminputcontextplugin
 
15
 
 
16
 target.path = $$[QT_INSTALL_PLUGINS]/platforminputcontexts
 
17
 
 
18
Index: maliit-framework-0.99+git20130702+97e8335/input-context/main.cpp
 
19
===================================================================
 
20
--- maliit-framework-0.99+git20130702+97e8335.orig/input-context/main.cpp       2013-07-16 09:57:37.000000000 +0000
 
21
+++ maliit-framework-0.99+git20130702+97e8335/input-context/main.cpp    2013-07-16 09:57:37.000000000 +0000
 
22
@@ -32,7 +32,7 @@
 
23
 {
 
24
     Q_UNUSED(paramList);
 
25
 
 
26
-    if (system.compare(system, QStringLiteral("maliit"), Qt::CaseInsensitive) == 0) {
 
27
+    if (system.compare(system, QStringLiteral("MaliitPhablet"), Qt::CaseInsensitive) == 0) {
 
28
         return new MInputContext;
 
29
     }
 
30
     return 0;
 
31
 
 
32
 
 
33
Index: maliit-framework-0.99+git20130702+97e8335/input-context/maliit.json
 
34
===================================================================
 
35
--- maliit-framework-0.99+git20130702+97e8335.orig/input-context/maliit.json    2013-07-16 10:28:11.000000000 +0000
 
36
+++ maliit-framework-0.99+git20130702+97e8335/input-context/maliit.json         2013-07-16 10:29:24.000000000 +0000
 
37
@@ -1,3 +1,3 @@
 
38
 {
 
39
-    "Keys": [ "maliit" ]
 
40
+    "Keys": [ "maliitphablet" ]
 
41
 }