~ubuntu-backports-testers/gnome-chess/hoichess-debian

« back to all changes in this revision

Viewing changes to debian/patches/reproducible-build.patch

  • Committer: Samuel Henrique
  • Date: 2017-06-18 23:32:24 UTC
  • Revision ID: git-v1:ac7fb1fb31b7494efb9e380fb818f99f54d88b6d
d/p/[sparc|reproducible]: remove no-more-needed patched

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Sort source files for deterministic linking order
2
 
Author: Reiner Herrmann <reiner@reiner-h.de>
3
 
 
4
 
--- a/src/Makefile
5
 
+++ b/src/Makefile
6
 
@@ -35,14 +35,14 @@
7
 
 # (ADD_SOURCES can optionally be set at make command line)
8
 
 #
9
 
 
10
 
-SOURCES = $(wildcard *.cc common/*.cc) $(ADD_SOURCES)
11
 
+SOURCES = $(sort $(wildcard *.cc common/*.cc)) $(ADD_SOURCES)
12
 
 INCLUDE = -I. -Icommon -Ilib
13
 
 
14
 
-hoichess_SOURCES = $(SOURCES) $(wildcard chess/*.cc)
15
 
+hoichess_SOURCES = $(SOURCES) $(sort $(wildcard chess/*.cc))
16
 
 all-hoichess: override CXXFLAGS += -DHOICHESS
17
 
 all-hoichess: override INCLUDE += -Ichess
18
 
 
19
 
-hoixiangqi_SOURCES = $(SOURCES) $(wildcard xiangqi/*.cc)
20
 
+hoixiangqi_SOURCES = $(SOURCES) $(sort $(wildcard xiangqi/*.cc))
21
 
 all-hoixiangqi: override CXXFLAGS += -DHOIXIANGQI
22
 
 all-hoixiangqi: override INCLUDE += -Ixiangqi
23
 
 
24
 
@@ -52,7 +52,7 @@
25
 
 ifneq (,$(findstring mingw32,$(TARGET)))
26
 
 override INCLUDE += -Iwin32 -Ilib
27
 
 override LDFLAGS += -static-libgcc -static-libstdc++
28
 
-SOURCES += $(wildcard win32/*.cc)
29
 
+SOURCES += $(sort $(wildcard win32/*.cc))
30
 
 SOURCES += lib/snprintf.cc lib/strtok_r.cc
31
 
 BIN_SUFFIX = .exe
32
 
 else
33
 
@@ -63,9 +63,9 @@
34
 
 override INCLUDE += -Isparc32
35
 
 ifneq (,$(shell echo '' | $(CXX) -E -dM - | grep __leonbare__))
36
 
 override INCLUDE += -Isparc32/leon
37
 
-SOURCES += $(wildcard sparc32/leon/*.cc)
38
 
+SOURCES += $(sort $(wildcard sparc32/leon/*.cc))
39
 
 endif
40
 
-SOURCES += $(wildcard sparc32/*.cc)
41
 
+SOURCES += $(sort $(wildcard sparc32/*.cc))
42
 
 SOURCES += lib/snprintf.cc
43
 
 endif
44