~ubuntu-branches/debian/experimental/mednafen/experimental

« back to all changes in this revision

Viewing changes to debian/patches/psx-big-endian-only.patch

  • Committer: Package Import Robot
  • Author(s): Stephen Kitt
  • Date: 2012-01-31 07:21:35 UTC
  • mfrom: (1.2.8)
  • Revision ID: package-import@ubuntu.com-20120131072135-es3dj12y00xcnrsk
Tags: 0.9.19-1
* New upstream WIP version.
* Update copyright information.
* Refresh use-system-tremor.patch and remove psx-big-endian-only.patch.
* Add spelling-fixes.patch based on Lintian's recommendations.
* Build-depend on debhelper 9 or later and remove corresponding Lintian
  override.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- mednafen.orig/configure.ac
2
 
+++ mednafen/configure.ac
3
 
@@ -246,9 +246,12 @@
4
 
                AM_CONDITIONAL(WANT_PCFX_EMU, true)
5
 
 fi
6
 
 
7
 
-AC_ARG_ENABLE(psx,
8
 
- AC_HELP_STRING([--enable-psx], [build with PlayStation emulation [[default=no]]]),
9
 
-                  , enable_psx=no)
10
 
+dnl PlayStation only on little-endian systems for now
11
 
+AC_C_BIGENDIAN([enable_psx=no], [
12
 
+ AC_ARG_ENABLE(psx,
13
 
+  AC_HELP_STRING([--enable-psx], [build with PlayStation emulation (little-endian systems only) [[default=no]]]),
14
 
+                   , enable_psx=no)
15
 
+])
16
 
 
17
 
 if test x$enable_psx = xyes; then
18
 
                 AC_DEFINE([WANT_PSX_EMU], [1], [Define if we are compiling with PlayStation emulation.])