~ubuntu-branches/debian/experimental/openscenegraph/experimental

« back to all changes in this revision

Viewing changes to debian/patches/bug-528229.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Alberto Luaces
  • Date: 2010-07-21 11:19:33 UTC
  • Revision ID: james.westby@ubuntu.com-20100721111933-txprakfow6uja6qx
Tags: 2.8.3-5
* ffmpeg plugin enabled.
* Build osgIntrospection on {,kfreebsd}-{amd64,i386} architectures (Closes: #586256).
* Also build static libraries (Closes: #517273).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
2
 
3
3
@DPATCH@
4
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/CMakeLists.txt openscenegraph-2.8.2/OpenSceneGraph/CMakeLists.txt
5
 
--- openscenegraph-2.8.2~/OpenSceneGraph/CMakeLists.txt 2009-07-28 08:02:27.000000000 +0200
6
 
+++ openscenegraph-2.8.2/OpenSceneGraph/CMakeLists.txt  2009-12-12 19:30:24.000000000 +0100
7
 
@@ -772,14 +772,36 @@
 
4
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/CMakeLists.txt openscenegraph-2.8.3/OpenSceneGraph/CMakeLists.txt
 
5
--- openscenegraph-2.8.3~/OpenSceneGraph/CMakeLists.txt 2010-07-21 10:58:09.000000000 +0200
 
6
+++ openscenegraph-2.8.3/OpenSceneGraph/CMakeLists.txt  2010-07-21 11:11:52.000000000 +0200
 
7
@@ -777,14 +777,39 @@
8
8
     ENDIF(BUILD_OSG_PACKAGES)
9
9
 ENDIF(CMAKE_CPACK_COMMAND)
10
10
 
30
30
+  openscenegraph-osgShadow
31
31
+  openscenegraph-osgAnimation
32
32
+  openscenegraph-osgVolume
33
 
+  openscenegraph-osgIntrospection
34
33
+)
35
34
+
 
35
+IF(BUILD_OSG_WRAPPERS)
 
36
+  SET(PKGCONFIG_FILES ${PKGCONFIG_FILES} openscenegraph-osgIntrospection)
 
37
+ENDIF(BUILD_OSG_WRAPPERS)
 
38
+
36
39
+FOREACH(PKGCONFIG_FILE ${PKGCONFIG_FILES})
37
40
+  CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc.in
38
41
+    ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc
45
48
 
46
49
 # Run this as late as possible so users can easier spot the message
47
50
 IF (${CMAKE_INSTALL_PREFIX} STREQUAL "/usr/local")
48
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osg.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osg.pc.in
49
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osg.pc.in   1970-01-01 01:00:00.000000000 +0100
50
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osg.pc.in    2009-12-12 19:30:24.000000000 +0100
51
 
@@ -0,0 +1,14 @@
 
51
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osg.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osg.pc.in
 
52
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osg.pc.in   1970-01-01 01:00:00.000000000 +0100
 
53
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osg.pc.in    2010-07-21 11:02:46.000000000 +0200
 
54
@@ -0,0 +1,15 @@
52
55
+# pkg-config source file
53
56
+
54
57
+prefix=@CMAKE_INSTALL_PREFIX@
61
64
+Version: @OPENSCENEGRAPH_VERSION@
62
65
+Requires: openthreads
63
66
+Conflicts:
 
67
+Libs.private: /usr/lib/libGLU.so /usr/lib/libGL.so /usr/lib/libSM.so /usr/lib/libICE.so /usr/lib/libX11.so /usr/lib/libXext.so
64
68
+Libs: -L${libdir} -losg
65
69
+Cflags: -I${includedir}
66
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgAnimation.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgAnimation.pc.in
67
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgAnimation.pc.in  1970-01-01 01:00:00.000000000 +0100
68
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgAnimation.pc.in   2009-12-12 19:30:24.000000000 +0100
 
70
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgAnimation.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgAnimation.pc.in
 
71
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgAnimation.pc.in  1970-01-01 01:00:00.000000000 +0100
 
72
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgAnimation.pc.in   2010-07-21 11:02:04.000000000 +0200
69
73
@@ -0,0 +1,14 @@
70
74
+# pkg-config source file
71
75
+
81
85
+Conflicts:
82
86
+Libs: -L${libdir} -losgAnimation
83
87
+Cflags: -I${includedir}
84
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgDB.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgDB.pc.in
85
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgDB.pc.in 1970-01-01 01:00:00.000000000 +0100
86
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgDB.pc.in  2009-12-12 19:30:24.000000000 +0100
 
88
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgDB.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgDB.pc.in
 
89
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgDB.pc.in 1970-01-01 01:00:00.000000000 +0100
 
90
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgDB.pc.in  2010-07-21 11:02:04.000000000 +0200
87
91
@@ -0,0 +1,14 @@
88
92
+# pkg-config source file
89
93
+
99
103
+Conflicts:
100
104
+Libs: -L${libdir} -losgDB
101
105
+Cflags: -I${includedir}
102
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgFX.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgFX.pc.in
103
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgFX.pc.in 1970-01-01 01:00:00.000000000 +0100
104
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgFX.pc.in  2009-12-12 19:30:24.000000000 +0100
 
106
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgFX.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgFX.pc.in
 
107
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgFX.pc.in 1970-01-01 01:00:00.000000000 +0100
 
108
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgFX.pc.in  2010-07-21 11:02:04.000000000 +0200
105
109
@@ -0,0 +1,14 @@
106
110
+# pkg-config source file
107
111
+
117
121
+Conflicts:
118
122
+Libs: -L${libdir} -losgFX
119
123
+Cflags: -I${includedir}
120
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgGA.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgGA.pc.in
121
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgGA.pc.in 1970-01-01 01:00:00.000000000 +0100
122
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgGA.pc.in  2009-12-12 19:30:24.000000000 +0100
 
124
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgGA.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgGA.pc.in
 
125
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgGA.pc.in 1970-01-01 01:00:00.000000000 +0100
 
126
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgGA.pc.in  2010-07-21 11:02:04.000000000 +0200
123
127
@@ -0,0 +1,14 @@
124
128
+# pkg-config source file
125
129
+
135
139
+Conflicts:
136
140
+Libs: -L${libdir} -losgGA
137
141
+Cflags: -I${includedir}
138
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgIntrospection.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgIntrospection.pc.in
139
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgIntrospection.pc.in      1970-01-01 01:00:00.000000000 +0100
140
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgIntrospection.pc.in       2009-12-12 19:30:24.000000000 +0100
 
142
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgIntrospection.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgIntrospection.pc.in
 
143
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgIntrospection.pc.in      1970-01-01 01:00:00.000000000 +0100
 
144
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgIntrospection.pc.in       2010-07-21 11:02:04.000000000 +0200
141
145
@@ -0,0 +1,14 @@
142
146
+# pkg-config source file
143
147
+
153
157
+Conflicts:
154
158
+Libs: -L${libdir} -losgIntrospection
155
159
+Cflags: -I${includedir}
156
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgManipulator.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgManipulator.pc.in
157
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgManipulator.pc.in        1970-01-01 01:00:00.000000000 +0100
158
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgManipulator.pc.in 2009-12-12 19:30:24.000000000 +0100
 
160
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgManipulator.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgManipulator.pc.in
 
161
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgManipulator.pc.in        1970-01-01 01:00:00.000000000 +0100
 
162
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgManipulator.pc.in 2010-07-21 11:02:04.000000000 +0200
159
163
@@ -0,0 +1,14 @@
160
164
+# pkg-config source file
161
165
+
171
175
+Conflicts:
172
176
+Libs: -L${libdir} -losgManipulator
173
177
+Cflags: -I${includedir}
174
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgParticle.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgParticle.pc.in
175
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgParticle.pc.in   1970-01-01 01:00:00.000000000 +0100
176
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgParticle.pc.in    2009-12-12 19:30:24.000000000 +0100
 
178
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgParticle.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgParticle.pc.in
 
179
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgParticle.pc.in   1970-01-01 01:00:00.000000000 +0100
 
180
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgParticle.pc.in    2010-07-21 11:02:04.000000000 +0200
177
181
@@ -0,0 +1,14 @@
178
182
+# pkg-config source file
179
183
+
189
193
+Conflicts:
190
194
+Libs: -L${libdir} -losgParticle
191
195
+Cflags: -I${includedir}
192
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgShadow.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgShadow.pc.in
193
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgShadow.pc.in     1970-01-01 01:00:00.000000000 +0100
194
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgShadow.pc.in      2009-12-12 19:30:24.000000000 +0100
 
196
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgShadow.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgShadow.pc.in
 
197
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgShadow.pc.in     1970-01-01 01:00:00.000000000 +0100
 
198
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgShadow.pc.in      2010-07-21 11:02:04.000000000 +0200
195
199
@@ -0,0 +1,14 @@
196
200
+# pkg-config source file
197
201
+
207
211
+Conflicts:
208
212
+Libs: -L${libdir} -losgShadow
209
213
+Cflags: -I${includedir}
210
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgSim.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgSim.pc.in
211
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgSim.pc.in        1970-01-01 01:00:00.000000000 +0100
212
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgSim.pc.in 2009-12-12 19:30:24.000000000 +0100
 
214
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgSim.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgSim.pc.in
 
215
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgSim.pc.in        1970-01-01 01:00:00.000000000 +0100
 
216
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgSim.pc.in 2010-07-21 11:02:04.000000000 +0200
213
217
@@ -0,0 +1,14 @@
214
218
+# pkg-config source file
215
219
+
225
229
+Conflicts:
226
230
+Libs: -L${libdir} -losgSim
227
231
+Cflags: -I${includedir}
228
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgTerrain.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgTerrain.pc.in
229
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgTerrain.pc.in    1970-01-01 01:00:00.000000000 +0100
230
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgTerrain.pc.in     2009-12-12 19:30:24.000000000 +0100
 
232
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgTerrain.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgTerrain.pc.in
 
233
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgTerrain.pc.in    1970-01-01 01:00:00.000000000 +0100
 
234
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgTerrain.pc.in     2010-07-21 11:02:04.000000000 +0200
231
235
@@ -0,0 +1,14 @@
232
236
+# pkg-config source file
233
237
+
243
247
+Conflicts:
244
248
+Libs: -L${libdir} -losgTerrain
245
249
+Cflags: -I${includedir}
246
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgText.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgText.pc.in
247
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgText.pc.in       1970-01-01 01:00:00.000000000 +0100
248
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgText.pc.in        2009-12-12 19:30:24.000000000 +0100
 
250
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgText.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgText.pc.in
 
251
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgText.pc.in       1970-01-01 01:00:00.000000000 +0100
 
252
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgText.pc.in        2010-07-21 11:02:04.000000000 +0200
249
253
@@ -0,0 +1,14 @@
250
254
+# pkg-config source file
251
255
+
261
265
+Conflicts:
262
266
+Libs: -L${libdir} -losgText
263
267
+Cflags: -I${includedir}
264
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgUtil.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgUtil.pc.in
265
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgUtil.pc.in       1970-01-01 01:00:00.000000000 +0100
266
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgUtil.pc.in        2009-12-12 19:30:24.000000000 +0100
 
268
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgUtil.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgUtil.pc.in
 
269
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgUtil.pc.in       1970-01-01 01:00:00.000000000 +0100
 
270
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgUtil.pc.in        2010-07-21 11:02:04.000000000 +0200
267
271
@@ -0,0 +1,14 @@
268
272
+# pkg-config source file
269
273
+
279
283
+Conflicts:
280
284
+Libs: -L${libdir} -losgUtil
281
285
+Cflags: -I${includedir}
282
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgViewer.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgViewer.pc.in
283
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgViewer.pc.in     1970-01-01 01:00:00.000000000 +0100
284
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgViewer.pc.in      2009-12-12 19:30:24.000000000 +0100
 
286
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgViewer.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgViewer.pc.in
 
287
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgViewer.pc.in     1970-01-01 01:00:00.000000000 +0100
 
288
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgViewer.pc.in      2010-07-21 11:02:04.000000000 +0200
285
289
@@ -0,0 +1,14 @@
286
290
+# pkg-config source file
287
291
+
297
301
+Conflicts:
298
302
+Libs: -L${libdir} -losgViewer
299
303
+Cflags: -I${includedir}
300
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgVolume.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgVolume.pc.in
301
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgVolume.pc.in     1970-01-01 01:00:00.000000000 +0100
302
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgVolume.pc.in      2009-12-12 19:30:24.000000000 +0100
 
304
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgVolume.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgVolume.pc.in
 
305
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgVolume.pc.in     1970-01-01 01:00:00.000000000 +0100
 
306
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgVolume.pc.in      2010-07-21 11:02:04.000000000 +0200
303
307
@@ -0,0 +1,14 @@
304
308
+# pkg-config source file
305
309
+
315
319
+Conflicts:
316
320
+Libs: -L${libdir} -losgVolume
317
321
+Cflags: -I${includedir}
318
 
diff -urNad openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgWidget.pc.in openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgWidget.pc.in
319
 
--- openscenegraph-2.8.2~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgWidget.pc.in     1970-01-01 01:00:00.000000000 +0100
320
 
+++ openscenegraph-2.8.2/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgWidget.pc.in      2009-12-12 19:30:24.000000000 +0100
 
322
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgWidget.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgWidget.pc.in
 
323
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgWidget.pc.in     1970-01-01 01:00:00.000000000 +0100
 
324
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph-osgWidget.pc.in      2010-07-21 11:02:04.000000000 +0200
321
325
@@ -0,0 +1,14 @@
322
326
+# pkg-config source file
323
327
+
333
337
+Conflicts:
334
338
+Libs: -L${libdir} -losgWidget
335
339
+Cflags: -I${includedir}
 
340
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph.pc.in
 
341
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openscenegraph.pc.in       2009-01-27 16:34:28.000000000 +0100
 
342
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openscenegraph.pc.in        2010-07-21 11:02:31.000000000 +0200
 
343
@@ -10,5 +10,6 @@
 
344
 Version: @OPENSCENEGRAPH_VERSION@
 
345
 Requires: openthreads
 
346
 Conflicts:
 
347
+Libs.private: /usr/lib/libGLU.so /usr/lib/libGL.so /usr/lib/libSM.so /usr/lib/libICE.so /usr/lib/libX11.so /usr/lib/libXext.so
 
348
 Libs: -L${libdir} -losg -losgDB -losgFX -losgGA -losgParticle -losgSim -losgText -losgUtil -losgTerrain -losgManipulator -losgViewer -losgWidget -losgShadow -losgAnimation -losgVolume
 
349
 Cflags: -I${includedir}
 
350
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openthreads.pc.in openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openthreads.pc.in
 
351
--- openscenegraph-2.8.3~/OpenSceneGraph/packaging/pkgconfig/openthreads.pc.in  2009-01-27 16:34:28.000000000 +0100
 
352
+++ openscenegraph-2.8.3/OpenSceneGraph/packaging/pkgconfig/openthreads.pc.in   2010-07-21 11:04:50.000000000 +0200
 
353
@@ -10,5 +10,5 @@
 
354
 Version: @OPENTHREADS_VERSION@
 
355
 Requires:
 
356
 Conflicts:
 
357
-Libs: -L${libdir} -lOpenThreads
 
358
-Cflags: -I${includedir}
 
359
+Libs: -L${libdir} -lOpenThreads -pthread
 
360
+Cflags: -I${includedir} -pthread