~ubuntu-branches/debian/experimental/protobuf/experimental

« back to all changes in this revision

Viewing changes to debian/patches/revert_upstream_issue_388_about_rpath.diff

  • Committer: Package Import Robot
  • Author(s): Robert S. Edmonds, Micah Anderson, Colin Watson, Steve Langasek, Robert S. Edmonds
  • Date: 2013-10-12 18:32:37 UTC
  • mfrom: (1.3.1) (10.1.4 sid)
  • Revision ID: package-import@ubuntu.com-20131012183237-jz6tvmj9tn68atrf
Tags: 2.5.0-1
[ Micah Anderson ]
* New upstream version. (Closes: #704731.)
* Update debian/watch.
* Refresh patches.

[ Colin Watson ]
* Use the autotools-dev dh addon to update config.guess/config.sub for
  arm64. (Closes: #725976.)

[ Steve Langasek ]
* Don't recommend protobuf-compiler from the bindings, it's not used and
  this doesn't need to be pulled in at runtime. (Closes: #703628.)
* Mark protobuf-compiler Multi-Arch: foreign; the output of this command
  is architecture-independent source, we don't need the version of the
  compiler to match the target arch.
* Bump to debhelper compat 9, so that our libs get installed to the
  multiarch locations.
* Mark the library packages Multi-Arch: same.
* Fix debian/rules to support cross-building of the python bindings.
* Build-depend on libpython-dev, not python-dev, for cross-build
  compatibility.
* (Closes: #726083.)

[ Robert S. Edmonds ]
* Upload to experimental.
* Bump ABI version from 7 to 8.
* Bump Standards-Version to 3.9.4.
* Convert from python-support to dh-python.
* Drop support for python2.6.
* python-protobuf: switch back to the pure Python implementation, as
  upstream appears to no longer be maintaining the current C++ based Python
  binding. See the following upstream issues for details:
  - https://code.google.com/p/protobuf/issues/detail?id=434
  - https://code.google.com/p/protobuf/issues/detail?id=503

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: workaround issue 271 upstream
 
2
Author: Thomas Koch <thomas@koch.ro
 
3
Bug: http://code.google.com/p/protobuf/issues/detail?id=271
 
4
Last-Update: 2011-11-07
 
5
Index: protobuf/python/README.txt
 
6
===================================================================
 
7
--- protobuf.orig/python/README.txt     2013-08-13 17:00:57.056444999 -0400
 
8
+++ protobuf/python/README.txt  2013-08-13 17:00:57.052445109 -0400
 
9
@@ -64,9 +64,9 @@
 
10
      $ python setup.py install
 
11
 
 
12
    This step may require superuser privileges.
 
13
-   NOTE: To use C++ implementation, you need to install C++ protobuf runtime
 
14
-   library of the same version and export the environment variable before this
 
15
-   step. See the "C++ Implementation" section below for more details.
 
16
+   NOTE: To use C++ implementation, you need to export the environment variable
 
17
+   before this step. See the "C++ Implementation" section below for more
 
18
+   details.
 
19
 
 
20
 Usage
 
21
 =====
 
22
@@ -84,10 +84,7 @@
 
23
 The C++ implementation for Python messages is built as a Python extension to
 
24
 improve the overall protobuf Python performance.
 
25
 
 
26
-To use the C++ implementation, you need to:
 
27
-1) Install the C++ protobuf runtime library, please see instructions in the
 
28
-   parent directory.
 
29
-2) Export an environment variable:
 
30
+To use the C++ implementation, export an environment variable:
 
31
 
 
32
   $ export PROTOCOL_BUFFERS_PYTHON_IMPLEMENTATION=cpp
 
33
 
 
34
Index: protobuf/python/setup.py
 
35
===================================================================
 
36
--- protobuf.orig/python/setup.py       2013-08-13 17:00:57.056444999 -0400
 
37
+++ protobuf/python/setup.py    2013-08-13 17:00:57.052445109 -0400
 
38
@@ -152,8 +152,10 @@
 
39
         [ "google/protobuf/pyext/python_descriptor.cc",
 
40
           "google/protobuf/pyext/python_protobuf.cc",
 
41
           "google/protobuf/pyext/python-proto2.cc" ],
 
42
-        include_dirs = [ "." ],
 
43
-        libraries = [ "protobuf" ]))
 
44
+        include_dirs = [ "../src", "." ],
 
45
+        libraries = [ "protobuf" ],
 
46
+#        runtime_library_dirs = [ "../src/.libs" ],
 
47
+        library_dirs = [ "../src/.libs" ]))
 
48
 
 
49
   setup(name = 'protobuf',
 
50
         version = '2.5.0',