~ubuntu-branches/debian/experimental/scribus/experimental

« back to all changes in this revision

Viewing changes to debian/patches/762942

  • Committer: Package Import Robot
  • Author(s): Mattia Rizzolo
  • Date: 2014-10-20 21:01:51 UTC
  • Revision ID: package-import@ubuntu.com-20141020210151-997gbaodfti1015w
Tags: 1.4.4+dfsg1-2
* [a780c7d] Use /usr/share/hyphen to provide hyphenator dicts:
  + debian/control:
    - promote hyphen-hyphenation-patterns from suggests to recommends.
  + debian/patches/762942:
    - allow the use of symlinks in the directory used to pick up dicts.
  + debian/scribus.links:
    - link usr/share/hyphen → usr/share/scribus/dicts.
  + Closes: #762942
* [3590799] debian/control: bump standards-version to 3.9.6.
* [7b37ea0] debian/rules: use gzip -n to allow reproducibily building.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Allow the use of others hyphenators files.
 
2
 The idea here is to allow the use of hyphenator dictionaries presents in
 
3
 /usr/share/hyphen through a symlink from /usr/share/scribus/dicts.
 
4
 It's clearly a workaround-
 
5
Author: Mattia Rizzolo <mattia@mapreri.org>
 
6
Forwarded: not-needed, but looks like upstream don't want it
 
7
Bug: http://bugs.scribus.net/view.php?id=8157
 
8
Bug-Debian: https://bugs.debian.org/533081
 
9
Bug-Debian: https://bugs.debian.org/762942
 
10
Last-Update: 2014-10-11
 
11
 
 
12
--- a/scribus/scribus.cpp
 
13
+++ b/scribus/scribus.cpp
 
14
@@ -7935,7 +7935,7 @@
 
15
                delete dia;
 
16
                QFile::remove(prefsManager->preferencesLocation()+"/tmp.ps");
 
17
                QFile::remove(prefsManager->preferencesLocation()+"/sc.png");
 
18
-               QDir d(prefsManager->preferencesLocation()+"/", "sc.*", QDir::Name, QDir::Files | QDir::NoSymLinks);
 
19
+               QDir d(prefsManager->preferencesLocation()+"/", "sc.*", QDir::Name, QDir::Files);
 
20
                if ((d.exists()) && (d.count() != 0))
 
21
                {
 
22
                        for (uint dc = 0; dc < d.count(); dc++)