~ubuntu-branches/debian/experimental/smokeping/experimental

« back to all changes in this revision

Viewing changes to debian/patches/15_clean_makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Niko Tyni
  • Date: 2008-08-29 18:29:34 UTC
  • mfrom: (2.1.14 intrepid)
  • Revision ID: james.westby@ubuntu.com-20080829182934-ad5b9csusoqn1155
Tags: 2.3.6-3
* Unset LC_ALL in the init script because the daemon needs to 
  reset LC_NUMERIC. (Closes: #489766)
* Fix a bashism in the postinst script. Thanks, lintian.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
## DP: remove unneeded and potentially unsecure include paths
6
6
 
7
7
@DPATCH@
8
 
diff -urNad smokeping-2.0.9~/Makefile smokeping-2.0.9/Makefile
9
 
--- smokeping-2.0.9~/Makefile   2006-07-14 14:17:47.000000000 +0300
10
 
+++ smokeping-2.0.9/Makefile    2006-10-25 23:17:47.000000000 +0300
11
 
@@ -36,8 +36,8 @@
 
8
diff -urNad smokeping-2.1.1~/Makefile smokeping-2.1.1/Makefile
 
9
--- smokeping-2.1.1~/Makefile   2007-05-06 23:36:18.000000000 +0300
 
10
+++ smokeping-2.1.1/Makefile    2007-05-06 23:36:57.000000000 +0300
 
11
@@ -39,8 +39,8 @@
12
12
 # pod2html apparently needs to be in the target directory to get L<> links right
13
13
 POD2HTML= cd $(dir $@); top="$(shell echo $(dir $@)|sed -e 's,doc/,,' -e 's,[^/]*/,../,g' -e 's,/$$,,')"; top=$${top:-.}; pod2html --infile=$(CURDIR)/$< --noindex --htmlroot=. --podroot=. --podpath=$${top} --title=$* | $${top}/../util/fix-pod2html.pl > $(notdir $@)
14
14
 # we go to this trouble to ensure that MAKEPOD only uses modules in the installation directory
15
 
-MAKEPOD= perl -I/home/oetiker/lib/fake-perl/ -Ilib -I/usr/pack/rrdtool-1.2svn-to/lib/perl -mSmokeping -e 'Smokeping::main()' -- --makepod
16
 
-GENEX= perl -I/home/oetiker/lib/fake-perl/ -Ilib -I/usr/pack/rrdtool-1.2svn-to/lib/perl -mSmokeping -e 'Smokeping::main()' -- --gen-examples
17
 
+MAKEPOD= perl -Ilib -mSmokeping -e 'Smokeping::main()' -- --makepod
18
 
+GENEX= perl -Ilib -mSmokeping -e 'Smokeping::main()' -- --gen-examples
 
15
-MAKEPOD= $(PERL) -I/home/oetiker/lib/fake-perl/ -Ilib -I/usr/pack/rrdtool-1.2svn-to/lib/perl -mSmokeping -e 'Smokeping::main()' -- --makepod
 
16
-GENEX= $(PERL) -I/home/oetiker/lib/fake-perl/ -Ilib -I/usr/pack/rrdtool-1.2svn-to/lib/perl -mSmokeping -e 'Smokeping::main()' -- --gen-examples
 
17
+MAKEPOD= $(PERL) -Ilib -mSmokeping -e 'Smokeping::main()' -- --makepod
 
18
+GENEX= $(PERL) -Ilib -mSmokeping -e 'Smokeping::main()' -- --gen-examples
19
19
 
20
20
 doc/%.7: doc/%.pod
21
21
        $(POD2MAN) --section 7 > $@