~ubuntu-branches/debian/experimental/sysvinit/experimental

« back to all changes in this revision

Viewing changes to debian/patches/31_build_warnings.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Petter Reinholdtsen
  • Date: 2008-08-12 16:07:50 UTC
  • Revision ID: james.westby@ubuntu.com-20080812160750-65gpyv74vh4qr69w
Tags: 2.86.ds1-61
* Fix typo in rcS(5), proberly->properly (Closes: #484233).  Thanks to
  Julien Danjou for noticing.
* Fix typo in rcS(5), maually->manually (Closes: #493680).  Thanks to
  Xr for noticing.
* Modify runlevel detection code in invoke-rc.d to notice the
  difference between runlevels 0 and 6, and the boot runlevel, to
  make it possible to use invoke-rc.d during boot (Closes: 384509).
* Make sure to call restorecon after mounting tmpfs file systems, to
  set SELinux permissions (Closes: #493679).  Patch from Russell
  Coker.
* Move responsibility of stopping the splash screen process from
  individual init.d scripts to init.d/rc.  This make sure the
  progress calculation reflect reality, and that the splash screen
  is taken down in runlevel 1 (Closes: #431560) and that it stop
  before gdm and kdm (Closes: #422922, #489734).
* Skip error message from checkfs.sh when / is read-only.  Patch
  from Mirek Slugen (Closes: #492214).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 31_build_warnings.dpatch by Petter Reinholdtsten
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Increase the compiler warning level.
 
6
 
 
7
@DPATCH@
 
8
Index: trunk/src/Makefile
 
9
===================================================================
 
10
--- trunk/src/Makefile  (revisjon 62)
 
11
+++ trunk/src/Makefile  (arbeidskopi)
 
12
@@ -9,7 +9,7 @@
 
13
 #
 
14
 
 
15
 CC     = gcc
 
16
-CFLAGS = -Wall -O2 -fomit-frame-pointer -D_GNU_SOURCE
 
17
+CFLAGS = -ansi -W -Wall -O2 -fomit-frame-pointer -D_GNU_SOURCE
 
18
 LDFLAGS        = -s
 
19
 STATIC =
 
20