~ubuntu-branches/debian/jessie/android-platform-frameworks-base/jessie

« back to all changes in this revision

Viewing changes to debian/patches/tools_aapt_makefile.patch

  • Committer: Package Import Robot
  • Author(s): Hans-Christoph Steiner
  • Date: 2014-09-30 20:55:30 UTC
  • Revision ID: package-import@ubuntu.com-20140930205530-rlfscbdm3mrzcxqw
Tags: 21-1
Initial release (Closes: #763571)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- /dev/null
 
2
+++ b/tools/aapt/Makefile
 
3
@@ -0,0 +1,29 @@
 
4
+#!/usr/bin/make
 
5
+
 
6
+CXX = g++
 
7
+
 
8
+HOST_OS=linux
 
9
+include Android.mk
 
10
+
 
11
+OBJECTS = $(LOCAL_SRC_FILES:.cpp=.o)
 
12
+
 
13
+ALL_CXXFLAGS = -O2 -fPIC $(LOCAL_CFLAGS) \
 
14
+       -I../../include -I/usr/include/android \
 
15
+       -include /usr/include/android/arch/linux-x86/AndroidConfig.h
 
16
+ALL_LDFLAGS = -fPIC -Wl,-rpath=/usr/lib/android
 
17
+ALL_LIBS = $(LOCAL_LDLIBS) -lexpat -lpng \
 
18
+       -L/usr/lib/android  -lcutils -lhost -llog -lutils \
 
19
+       -L../../libs/androidfw  -landroidfw
 
20
+
 
21
+CXXFLAGS := $(ALL_CXXFLAGS) $(CXXFLAGS)
 
22
+LDFLAGS := $(ALL_LDFLAGS) $(LDFLAGS)
 
23
+LIBS := $(ALL_LIBS) $(LIBS)
 
24
+
 
25
+all: aapt
 
26
+
 
27
+aapt: $(OBJECTS)
 
28
+       $(CXX) $(LDFLAGS) -o aapt $(OBJECTS) $(LIBS)
 
29
+
 
30
+clean:
 
31
+       rm -f $(OBJECTS)
 
32
+       rm -f aapt