~ubuntu-branches/debian/jessie/empathy/jessie

« back to all changes in this revision

Viewing changes to debian/patches/0003-use-gtk-clutter-init.patch

  • Committer: Bazaar Package Importer
  • Author(s): Laurent Bigonville
  • Date: 2011-07-31 01:32:02 UTC
  • Revision ID: james.westby@ubuntu.com-20110731013202-j6dl8lmu9pajgvl3
Tags: 2.30.3-3
* debian/control:
  - Adjust webkit build-dependency for webkit 1.3 (Closes: #635406)
  - Do not Recommends geoclue providers anymore, geoclue package is already
    doing it (Closes: #599646)
  - Use architecture wildcards instead of negated architectures
    (Closes: #634481)
  - Add missing build-dependency against gnome-common (needed for
    autoreconf)
  - Bump Standards-Version to 3.9.2 (no further changes)
* debian/patches/0002-port-libnotify-0.7.patch: Port to libnotify 0.7 API
  (Closes: #630267)
* debian/patches/0003-use-gtk-clutter-init.patch: Call gtk_clutter_init()
  instead of clutter_init() (Backported from upstream)
* debian/rules, debian/control: Limit runtime dependencies against unndeeded
  libraries

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
commit 2f7d7b2d43b15f9133e2c89ead564651b03e6bd5
 
2
Author: Guillaume Desmottes <guillaume.desmottes@collabora.co.uk>
 
3
Date:   Mon Aug 9 10:05:35 2010 +0200
 
4
 
 
5
    use gtk_clutter_init rather than clutter_init
 
6
    
 
7
    This should fix the "Unable to make the stage window ..... the current GLX
 
8
    drawable" warning.
 
9
    Thanks to Jiri Techet to have spotted this.
 
10
 
 
11
--- a/src/empathy.c
 
12
+++ b/src/empathy.c
 
13
@@ -595,14 +595,16 @@
 
14
 
 
15
   /* Init */
 
16
   g_thread_init (NULL);
 
17
+
 
18
+#ifdef HAVE_LIBCHAMPLAIN
 
19
+  gtk_clutter_init (&argc, &argv);
 
20
+#endif
 
21
+
 
22
   empathy_init ();
 
23
 
 
24
   optcontext = g_option_context_new (N_("- Empathy IM Client"));
 
25
   g_option_context_add_group (optcontext, gst_init_get_option_group ());
 
26
   g_option_context_add_group (optcontext, gtk_get_option_group (TRUE));
 
27
-#if HAVE_LIBCHAMPLAIN
 
28
-  g_option_context_add_group (optcontext, clutter_get_option_group ());
 
29
-#endif
 
30
   g_option_context_add_main_entries (optcontext, options, GETTEXT_PACKAGE);
 
31
 
 
32
   if (!g_option_context_parse (optcontext, &argc, &argv, &error)) {