~ubuntu-branches/debian/jessie/libapache2-mod-python/jessie

« back to all changes in this revision

Viewing changes to debian/patches/01_configure.patch

  • Committer: Package Import Robot
  • Author(s): Arthur de Jong
  • Date: 2013-06-28 13:13:39 UTC
  • mfrom: (6.1.3 sid)
  • Revision ID: package-import@ubuntu.com-20130628131339-k0153luvvedddtml
Tags: 3.3.1-11
* Team upload.
* Upload to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Patch configure script.
 
2
 Remove apache version check for debian package, since we don't want to
 
3
 build-depend on apache2.
 
4
Author: Robert S. Edmonds <edmonds@debian.org>
 
5
 
 
6
--- a/configure.in
 
7
+++ b/configure.in
 
8
@@ -107,15 +107,17 @@ else
 
9
   ALL="dso"
 
10
 
 
11
   # check Apache version
 
12
-  AC_MSG_CHECKING(Apache version)
 
13
-  HTTPD="`${APXS} -q SBINDIR`/`${APXS} -q TARGET`"
 
14
-  ver=`$HTTPD -v | awk '/version/ {print $3}' | awk -F/ '{print $2}'`
 
15
-  AC_MSG_RESULT($ver)
 
16
+# peterh: Remove apache version check for debian package, since we don't
 
17
+# want to build-depend on apache2.
 
18
+#  AC_MSG_CHECKING(Apache version)
 
19
+#  HTTPD="`${APXS} -q SBINDIR`/`${APXS} -q TARGET`"
 
20
+#  ver=`$HTTPD -v | awk '/version/ {print $3}' | awk -F/ '{print $2}'`
 
21
+#  AC_MSG_RESULT($ver)
 
22
 
 
23
   # make sure version begins with 2
 
24
-  if test -z "`echo $ver | egrep \^2`"; then
 
25
-    AC_MSG_ERROR([This version of mod_python only works with Apache 2. The one you have seems to be $ver.])
 
26
-  fi
 
27
+#  if test -z "`echo $ver | egrep \^2`"; then
 
28
+#    AC_MSG_ERROR([This version of mod_python only works with Apache 2. The one you have seems to be $ver.])
 
29
+#  fi
 
30
 
 
31
   # determine LIBEXEC
 
32
   AC_MSG_CHECKING(for Apache libexec directory)
 
33
@@ -287,7 +289,7 @@ MOD_PYTHON_SO="`pwd`/src/mod_python.so"
 
34
 # get the mod_python version
 
35
 AC_SUBST(MP_VERSION)
 
36
 MP_VERSION=`awk '/MPV_STRING/ {print $3}' src/include/mpversion.h`
 
37
-MP_VERSION=`echo $MP_VERSION | sed 's/["]//g'`
 
38
+MP_VERSION=`echo $MP_VERSION | sed 's/"//g'`
 
39
 
 
40
 # get --with-python-src. The python src is required to generate the documentation
 
41
 # It is not required to compile or install mod_python itself