~ubuntu-branches/debian/jessie/synthv1/jessie

« back to all changes in this revision

Viewing changes to debian/patches/0001-buildsystem.patch

  • Committer: Package Import Robot
  • Author(s): Jaromír Mikeš
  • Date: 2014-03-11 15:08:33 UTC
  • mfrom: (1.1.8)
  • Revision ID: package-import@ubuntu.com-20140311150833-hdd95xtc6ks4lwv5
Tags: 0.4.0-1
* Imported Upstream version 0.4.0
* Two patches removed - applied upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Don't evaluate /usr/lib64 as valid library path.
2
 
Author: Alessio Treglia <alessio@debian.org>
3
 
Forwarded: yes
4
 
---
5
 
 configure.ac    |    6 +-----
6
 
 src/src_lv2.pro |    7 +------
7
 
 2 files changed, 2 insertions(+), 11 deletions(-)
8
 
 
9
 
Index: synthv1/configure.ac
10
 
===================================================================
11
 
--- synthv1.orig/configure.ac   2014-01-23 01:21:05.403082611 +0100
12
 
+++ synthv1/configure.ac        2014-01-23 01:21:55.421611094 +0100
13
 
@@ -107,7 +107,7 @@
14
 
 fi
15
 
 
16
 
 # Some a-la-debian alternatives...
17
 
-for X in /usr/lib /usr/lib64 /usr/share; do
18
 
+for X in /usr/lib /usr/share; do
19
 
   for Y in $ac_qtdirs; do
20
 
     if test -d $X/$Y/bin; then
21
 
       ac_with_paths="$ac_with_paths $X/$Y"
22
 
@@ -179,10 +179,6 @@
23
 
     CPPFLAGS="-I$X/include $CPPFLAGS"
24
 
     ac_incpath="$X/include $ac_incpath"
25
 
   fi
26
 
-  if test -d $X/lib64; then
27
 
-    LIBS="-L$X/lib64 $LIBS"
28
 
-    ac_libs="-L$X/lib64 $ac_libs"
29
 
-  fi
30
 
   if test -d $X/lib; then
31
 
     LIBS="-L$X/lib $LIBS"
32
 
     ac_libs="-L$X/lib $ac_libs"
33
 
Index: synthv1/src/src_lv2.pro
34
 
===================================================================
35
 
--- synthv1.orig/src/src_lv2.pro        2014-01-23 01:21:05.403082611 +0100
36
 
+++ synthv1/src/src_lv2.pro     2014-01-23 01:21:05.399082729 +0100
37
 
@@ -38,12 +38,7 @@
38
 
        contains(PREFIX, $$system(echo $HOME)) {
39
 
                LV2DIR = $${PREFIX}/.lv2
40
 
        } else {
41
 
-               ARCH = $$system(uname -m)
42
 
-               contains(ARCH, x86_64) {
43
 
-                       LV2DIR = $${PREFIX}/lib64/lv2
44
 
-               } else {
45
 
-                       LV2DIR = $${PREFIX}/lib/lv2
46
 
-               }
47
 
+               LV2DIR = $${PREFIX}/lib/lv2
48
 
        }
49
 
 
50
 
        TARGET_LV2 = $${NAME}.lv2/$${TARGET}.so