~ubuntu-branches/debian/jessie/ufsutils/jessie

« back to all changes in this revision

Viewing changes to debian/patches/02_fsck.ufs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Aurelien Jarno, Petr Salinger, Aurelien Jarno
  • Date: 2010-04-13 22:20:32 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20100413222032-je6xhqdvomf3yrj2
Tags: 7.3-1
[ Petr Salinger ]
* New upstream version (RELENG_7_3_0_RELEASE)
* Use intmax_t cast in fsbtodb() to fix aborts when 
  making a filesystem larger than one terabyte. Closes: #559647.

[ Aurelien Jarno ]
* Bump Standard-Versions to 3.8.4 (no changes).

Show diffs side-by-side

added added

removed removed

Lines of Context:
554
554
+include ../Makefile.common
555
555
 
556
556
-.include <bsd.prog.mk>
 
557
--- a/fsck.ufs/fsck.h
 
558
+++ b/fsck.ufs/fsck.h
 
559
@@ -63,6 +63,7 @@
 
560
 #include <unistd.h>
 
561
 #include <stdlib.h>
 
562
 #include <stdio.h>
 
563
+#include <signal.h>
 
564
 
 
565
 #define        MAXDUP          10      /* limit on dup blks (per inode) */
 
566
 #define        MAXBAD          10      /* limit on bad blks (per inode) */