~ubuntu-branches/debian/lenny/netatalk/lenny

« back to all changes in this revision

Viewing changes to debian/patches/112_fix_zeroconf_assertion.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jonas Smedegaard
  • Date: 2008-06-29 13:57:28 UTC
  • mfrom: (7.1.6 intrepid)
  • Revision ID: james.westby@ubuntu.com-20080629135728-ll66avwtcnq64pbs
Tags: 2.0.3-11
* Add patch 001 from upstream CVS to fix LFS test for cross
  compilation.
* Update cdbs tweaks:
  + Relax copyright-check.mk to only warn about its discoveries.
    Closes: bug#487061, thanks to Lucas Nussbaum.
  + Correct abbreviation of BSD licenses in copyright-check.mk.
  + Update dependency cleanup to strip cdbs 0.4.27 (not 0.4.27-1).
* Update debian/copyright-hints.
* Raise urgency to medium due to FTBFS bugfix.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -ruN netatalk-2.0.3.orig/etc/afpd/afp_avahi.c netatalk-2.0.3/etc/afpd/afp_avahi.c
 
2
--- netatalk-2.0.3.orig/etc/afpd/afp_avahi.c    2008-01-08 13:47:25.000000000 +0100
 
3
+++ netatalk-2.0.3/etc/afpd/afp_avahi.c 2008-01-08 13:49:22.000000000 +0100
 
4
@@ -91,7 +91,7 @@
 
5
 {
 
6
   struct context *ctx = userdata;
 
7
 
 
8
-  assert(g == ctx->group);
 
9
+  assert(!ctx->group || g == ctx->group);
 
10
 
 
11
   switch (state) {
 
12