~ubuntu-branches/debian/lenny/pykdeextensions/lenny

« back to all changes in this revision

Viewing changes to debian/patches/13_default_compiler_flags.diff

  • Committer: Bazaar Package Importer
  • Author(s): Michael Meskes, Fathi Boudra, Michael Meskes
  • Date: 2008-07-10 10:26:59 UTC
  • Revision ID: james.westby@ubuntu.com-20080710102659-xq2ohd500wsoz6lc
Tags: 0.4.0-6
[ Fathi Boudra ]
* Use Homepage, Vcs-Browser and Vcs-Svn fields.

[ Michael Meskes ]
* Added myself as uploader.
* Bumped needed python version to 2.5.
* Build depend on python-dev and not python-all-dev.
* Bumped Standards-Version to 3.8.0.
* Added patch to open shared library, not .so link provided by -dev package.
  No need to depend on the development package anymore. (Closes: #459960)
* Made shlibs file list version.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/setup.py
 
2
+++ b/setup.py
 
3
@@ -188,7 +188,7 @@
 
4
                 cmdlist.extend(cflags)
 
5
             else:
 
6
                 # Still no CFLAGS found, use these ...
 
7
-                cmdlist.extend(['-fno-strict-aliasing', '-DNDEBUG', '-g', '-O3', '-Wall', '-Wstrict-prototypes'])
 
8
+                cmdlist.extend(['-fno-strict-aliasing', '-DNDEBUG', '-g', '-O2', '-Wall', '-Wstrict-prototypes'])
 
9
             
 
10
         # includes
 
11
         cmdlist.append("-I" + sysconfig.get_config_var("INCLUDEDIR"))
 
12
--- a/src/kdedistutils.py
 
13
+++ b/src/kdedistutils.py
 
14
@@ -758,7 +758,7 @@
 
15
                     cmdlist.extend(cflags)
 
16
                 else:
 
17
                     # Still no CFLAGS found, use these ...
 
18
-                    cmdlist.extend(['-fno-strict-aliasing', '-DNDEBUG', '-g', '-O3', '-Wall', '-Wstrict-prototypes'])
 
19
+                    cmdlist.extend(['-fno-strict-aliasing', '-DNDEBUG', '-g', '-O2', '-Wall', '-Wstrict-prototypes'])
 
20
                 
 
21
             #sysconfig.get_config_var("CFLAGS").split()
 
22
             # includes
 
23
@@ -1652,7 +1652,7 @@
 
24
                     cmdlist.extend(cflags)
 
25
                 else:
 
26
                     # Still no CFLAGS found, use these ...
 
27
-                    cmdlist.extend(['-fno-strict-aliasing', '-DNDEBUG', '-g', '-O3', '-Wall', '-Wstrict-prototypes'])
 
28
+                    cmdlist.extend(['-fno-strict-aliasing', '-DNDEBUG', '-g', '-O2', '-Wall', '-Wstrict-prototypes'])
 
29
                 
 
30
             #sysconfig.get_config_var("CFLAGS").split()
 
31
             # includes