~ubuntu-branches/debian/lenny/smokeping/lenny

« back to all changes in this revision

Viewing changes to debian/patches/15_clean_makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Niko Tyni
  • Date: 2006-10-26 21:45:56 UTC
  • mfrom: (1.2.2 upstream) (2.1.5 edgy)
  • Revision ID: james.westby@ubuntu.com-20061026214556-5jnpiesx4vdijmu6
* debian/patches/15_clean_makefile.dpatch:
  + remove unneeded and potentially unsecure include paths.
* debian/patches: selected patches from the upstream SVN repository
  + 40_password.dpatch: skip reading the password file when running as a CGI.
  + 50_ldap.dpatch: Make the 'scope' option in the LDAP probe actually work.
  + 60_fping.dpatch:
    * Support the '-S' (set source address, see #198486) fping option.
    * Don't try to execute fping when running as a CGI.
  + 70_syslog.dpatch: Don't die silently if syslogd is unavailable.
    (Closes: #395056)
* Remove all the autogenerated documentation at clean time, to properly
  undo the effects of the 'build' target.
* Install example configuration files for documentation.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 15_clean_makefile.dpatch by Niko Tyni <ntyni@iki.fi>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: remove unneeded and potentially unsecure include paths
 
6
 
 
7
@DPATCH@
 
8
diff -urNad smokeping-2.0.9~/Makefile smokeping-2.0.9/Makefile
 
9
--- smokeping-2.0.9~/Makefile   2006-07-14 14:17:47.000000000 +0300
 
10
+++ smokeping-2.0.9/Makefile    2006-10-25 23:17:47.000000000 +0300
 
11
@@ -36,8 +36,8 @@
 
12
 # pod2html apparently needs to be in the target directory to get L<> links right
 
13
 POD2HTML= cd $(dir $@); top="$(shell echo $(dir $@)|sed -e 's,doc/,,' -e 's,[^/]*/,../,g' -e 's,/$$,,')"; top=$${top:-.}; pod2html --infile=$(CURDIR)/$< --noindex --htmlroot=. --podroot=. --podpath=$${top} --title=$* | $${top}/../util/fix-pod2html.pl > $(notdir $@)
 
14
 # we go to this trouble to ensure that MAKEPOD only uses modules in the installation directory
 
15
-MAKEPOD= perl -I/home/oetiker/lib/fake-perl/ -Ilib -I/usr/pack/rrdtool-1.2svn-to/lib/perl -mSmokeping -e 'Smokeping::main()' -- --makepod
 
16
-GENEX= perl -I/home/oetiker/lib/fake-perl/ -Ilib -I/usr/pack/rrdtool-1.2svn-to/lib/perl -mSmokeping -e 'Smokeping::main()' -- --gen-examples
 
17
+MAKEPOD= perl -Ilib -mSmokeping -e 'Smokeping::main()' -- --makepod
 
18
+GENEX= perl -Ilib -mSmokeping -e 'Smokeping::main()' -- --gen-examples
 
19
 
 
20
 doc/%.7: doc/%.pod
 
21
        $(POD2MAN) --section 7 > $@