~ubuntu-branches/debian/sid/acx100/sid

« back to all changes in this revision

Viewing changes to debian/patches/01_acx100_kcompat-2.6.24.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Stefano Canepa
  • Date: 2008-01-23 23:29:44 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20080123232944-zj28ri4e3xngonjs
Tags: 20070101-3
Added dpatch in depends (Closes: #462118)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 01_acx100_kcompat-2.6.24 <sc@linux.it>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Create a setup.py file
 
6
 
 
7
@DPATCH@
 
8
 
 
9
diff -u acx100-20070101/pci.c acx100-20070101/pci.c
 
10
--- acx100-20070101/pci.c
 
11
+++ acx100-20070101/pci.c
 
12
@@ -1617,9 +1617,11 @@
 
13
        acx_show_card_eeprom_id(adev);
 
14
 #endif /* NONESSENTIAL_FEATURES */
 
15
 
 
16
+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
 
17
 #ifdef SET_MODULE_OWNER
 
18
        SET_MODULE_OWNER(ndev);
 
19
 #endif
 
20
+#endif
 
21
        SET_NETDEV_DEV(ndev, &pdev->dev);
 
22
 
 
23
        log(L_IRQ|L_INIT, "using IRQ %d\n", pdev->irq);
 
24
--- acx100-20070101.orig/usb.c
 
25
+++ acx100-20070101/usb.c
 
26
@@ -859,7 +859,9 @@
 
27
        ndev->watchdog_timeo = 4 * HZ;
 
28
 #endif
 
29
        ndev->change_mtu = &acx_e_change_mtu;
 
30
+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
 
31
        SET_MODULE_OWNER(ndev);
 
32
+#endif
 
33
 
 
34
        /* Setup private driver context */
 
35