~ubuntu-branches/debian/sid/adabrowse/sid

« back to all changes in this revision

Viewing changes to debian/00-gnatmake.patch

  • Committer: Bazaar Package Importer
  • Author(s): Ludovic Brenta
  • Date: 2006-08-08 23:48:07 UTC
  • mfrom: (2.1.3 edgy)
  • Revision ID: james.westby@ubuntu.com-20060808234807-u76f3ful3n21w0qs
Tags: 4.0.2-5

* debian/control: add alpha, remove mips and mipsel.
* Recompile now that asis is available on all architectures.
  Closes: #373247.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Make sure never to call the "gnat" command, just "gnatmake" or "gnatgcc".
 
2
 
 
3
-- 
 
4
Ludovic Brenta, 2005-09-29.
 
5
 
 
6
--- ad-driver.adb~      2003-11-20 11:16:55.000000000 +0100
 
7
+++ ad-driver.adb       2005-09-29 18:38:50.000000000 +0200
 
8
@@ -660,7 +660,7 @@
 
9
          --  it needs (configuration pragmas, naming schemes, etc.)
 
10
          --     Note: we also pass on -X options!
 
11
          AD.Compiler.Set_Compile_Command
 
12
-           ("gnat compile -c -gnatc -gnatt -P" &
 
13
+           ("gnatmake -c -gnatc -gnatt -P" &
 
14
             AD.Projects.Get_Project_File_Name &
 
15
             ASU.To_String (Pass_On_Options));
 
16
       end if;
 
17
--- ad-projects.ads~    2003-11-20 11:16:52.000000000 +0100
 
18
+++ ad-projects.ads     2005-09-29 18:38:50.000000000 +0200
 
19
@@ -75,9 +75,10 @@
 
20
    --  specified and no "-f" option is given, AdaBrowse will process all specs
 
21
    --  from the source files of the root project.
 
22
    --
 
23
-   --  Warning: if a project file is given, the compile command is changed to
 
24
-   --  "gnat compile -P<file_name>", if it starts with the default compiler
 
25
-   --  name (which is "gcc" -- or "gnatgcc" on some Linux installations.)
 
26
+   --  Warning: if a project file is given, the compile command is
 
27
+   --  changed to "gnatmake -c -gnatc -gnatt -P<file_name>", if it
 
28
+   --  starts with the default compiler name (which is "gcc" -- or
 
29
+   --  "gnatgcc" on some Linux installations.)
 
30
    --
 
31
    --  The AdaBrowse currently doesn't handle the other project-related
 
32
    --  switches of GNAT tools, i.e. "-X" and "-vP". To define values for