~ubuntu-branches/debian/sid/apophenia/sid

« back to all changes in this revision

Viewing changes to debian/patches/debianization.patch

  • Committer: Package Import Robot
  • Author(s): Jerome Benoit
  • Date: 2014-10-15 11:20:08 UTC
  • Revision ID: package-import@ubuntu.com-20141015112008-mmznntlqtk5ibmsm
Tags: 0.999b+ds3-2
* Debianization:
  - debian/control:
    - Priority, promote to optional;
    - Build-Depends-Indep field, introduce (build-indep scheme, see below);
  - build-arch/build-indep scheme, introduce and consolidate (Closes: #764903)
    (thanks to Aaron M. Ucko <ucko@debian.org> for the hint);
  - debian/patches/:
    - docs/doxygen.conf.in, update with `doxygen -u'.
* Update patch for docs/doxygen.conf.in submitted to the upstream maintainer.

Show diffs side-by-side

added added

removed removed

Lines of Context:
7
7
 
8
8
--- a/docs/Makefile.am
9
9
+++ b/docs/Makefile.am
10
 
@@ -3,6 +3,8 @@
11
 
 
12
 
 default:
13
 
 
14
 
+all: html
15
 
+
16
 
 ## adhoc
17
 
 html man: doc
18
 
 
19
 
@@ -35,6 +37,8 @@
 
10
@@ -35,6 +35,8 @@
20
11
        sed -i -f edit_globals.sed html/globals.html
21
12
        sed -i -f edit_group.sed html/group__models.html
22
13
        sed -i -f edit_width.sed html/*.html
25
16
 
26
17
 doc-clean:
27
18
        -rm -rf html latex man
28
 
@@ -58,3 +62,12 @@
 
19
@@ -58,3 +60,12 @@
29
20
        typical.css \
30
21
        documentation.h
31
22
 
40
31
+
41
32
--- a/docs/doxygen.conf.in
42
33
+++ b/docs/doxygen.conf.in
43
 
@@ -32,7 +32,7 @@
44
 
 # This could be handy for archiving the generated documentation or
45
 
 # if some version control system is used.
 
34
@@ -38,7 +38,7 @@
 
35
 # could be handy for archiving the generated documentation or if some version
 
36
 # control system is used.
46
37
 
47
38
-PROJECT_NUMBER         =
48
39
+PROJECT_NUMBER         = "@DEB_PKG_VERSION@"
49
40
 
50
41
 # Using the PROJECT_BRIEF tag one can provide an optional one line description
51
 
 # for a project that appears at the top of each page and should give viewer
52
 
@@ -687,7 +687,7 @@
 
42
 # for a project that appears at the top of each page and should give viewer a
 
43
@@ -789,7 +789,7 @@
53
44
 # Note that relative paths are relative to the directory from which doxygen is
54
45
 # run.
55
46
 
58
49
 
59
50
 # The EXCLUDE_SYMLINKS tag can be used to select whether or not files or
60
51
 # directories that are symbolic links (a Unix file system feature) are excluded
61
 
@@ -1216,7 +1216,7 @@
62
 
 # If the GENERATE_LATEX tag is set to YES (the default) Doxygen will
63
 
 # generate Latex output.
 
52
@@ -1552,7 +1552,7 @@
 
53
 # If the GENERATE_LATEX tag is set to YES doxygen will generate LaTeX output.
 
54
 # The default value is: YES.
64
55
 
65
56
-GENERATE_LATEX         = YES
66
57
+GENERATE_LATEX         = NO
67
58
 
68
 
 # The LATEX_OUTPUT tag is used to specify where the LaTeX docs will be put.
69
 
 # If a relative path is entered the value of OUTPUT_DIRECTORY will be
70
 
@@ -1357,7 +1357,7 @@
71
 
 # If the GENERATE_MAN tag is set to YES (the default) Doxygen will
72
 
 # generate man pages
 
59
 # The LATEX_OUTPUT tag is used to specify where the LaTeX docs will be put. If a
 
60
 # relative path is entered the value of OUTPUT_DIRECTORY will be put in front of
 
61
@@ -1754,7 +1754,7 @@
 
62
 # classes and files.
 
63
 # The default value is: NO.
73
64
 
74
65
-GENERATE_MAN           = YES
75
66
+GENERATE_MAN           = NO
76
67
 
77
 
 # The MAN_OUTPUT tag is used to specify where the man pages will be put.
78
 
 # If a relative path is entered the value of OUTPUT_DIRECTORY will be
 
68
 # The MAN_OUTPUT tag is used to specify where the man pages will be put. If a
 
69
 # relative path is entered the value of OUTPUT_DIRECTORY will be put in front of
79
70
--- a/configure.ac
80
71
+++ b/configure.ac
81
 
@@ -4,7 +4,7 @@
 
72
@@ -4,13 +4,13 @@
82
73
 
83
74
 AC_PREREQ(2.60)
84
75
 AC_INIT([apophenia], [0.999b], [fluffmail@f-m.fm])
87
78
 AC_CONFIG_SRCDIR([apop_arms.c])
88
79
 AC_CONFIG_AUX_DIR([build-aux])
89
80
 AC_CONFIG_HEADER([config.h])
 
81
 AC_CONFIG_MACRO_DIR([m4])
 
82
 AM_INIT_AUTOMAKE
 
83
-AM_MAINTAINER_MODE
 
84
+AM_MAINTAINER_MODE([enable])
 
85
 
 
86
 # The normal /usr/local default confused too many people
 
87
 ##AC_PREFIX_DEFAULT([/usr])
90
88
@@ -63,6 +63,11 @@
91
89
 AC_PATH_PROGS([SQLITE3],[sqlite3],[/usr/bin/sqlite3])
92
90